New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
Internet, Networking, and Wireless Discussion of networking, internet, and wireless including Apple's Airport products.

DLink 655 connect issue


Post Reply New Thread Subscribe

 
Thread Tools
BrooklynStudent

 
Member Since: Feb 04, 2009
Posts: 22
BrooklynStudent is on a distinguished road

BrooklynStudent is offline
Last week I bought a DLink 655 Extreme N router for the house. I was able to connect without any problems until today when although my computer said that I was connected, my browsers (both firefox and safari) could open any websites. Distance did not appear to be a problem with this. I was wondering if bandwith was, but my housemates were not using their computers at the same time that I was. My computer is a macbook intel core duo version 10.4.11. Reseting the mac has normally fixed the issue, but it would be a pain to turn the mac on and then reset it each time to connect to the internet. Does anyone have any ideas why my mac would be doing this?

Thanks.
QUOTE Thanks
chscag

 
chscag's Avatar
 
Member Since: Jan 23, 2008
Location: Fort Worth, Texas
Posts: 39,365
chscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond repute
Mac Specs: 27" iMac i5, 3.2 GHz, iPad 3, iPhone 5c, 3 iPods, OS X Mavericks

chscag is offline
You purchased a very good router with plenty of range. I would consult the router manual and make sure you have everything setup properly. Check security, SID, broadcast channel, DNS settings and so forth. Do likewise with the airport settings on your MacBook.

Regards.
QUOTE Thanks
cwa107

 
cwa107's Avatar
 
Member Since: Dec 20, 2006
Location: Middletown, Pennsylvania
Posts: 26,493
cwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond repute
Mac Specs: 15" MBP, Core i7/2GHz, 8GB RAM, 480GB Crucial M500 SSD

cwa107 is offline
What kind of security are you using?

Liquid and computers don't mix. It might seem simple, but we see an incredible amount of people post here about spills. Keep drinks and other liquids away from your expensive electronics!
QUOTE Thanks
BrooklynStudent

 
Member Since: Feb 04, 2009
Posts: 22
BrooklynStudent is on a distinguished road

BrooklynStudent is offline
We're using. WEP 40/128 bit hex. The weird thing is, I had no problems connecting earlier until a couple of days ago, and I know that neither me nor my housemates changed any setting on either my computer or the router.
QUOTE Thanks
cwa107

 
cwa107's Avatar
 
Member Since: Dec 20, 2006
Location: Middletown, Pennsylvania
Posts: 26,493
cwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond repute
Mac Specs: 15" MBP, Core i7/2GHz, 8GB RAM, 480GB Crucial M500 SSD

cwa107 is offline
Switch it over to WPA instead of WEP and you'll be fine. WEP is an old, insecure protocol - and in my experience - can cause these kinds of issues. I use a DIR655 and have never had any issues using WPA.
QUOTE Thanks
BrooklynStudent

 
Member Since: Feb 04, 2009
Posts: 22
BrooklynStudent is on a distinguished road

BrooklynStudent is offline
Thanks!

But would that be an issue if I can't find the start up CD? How do I change the settings without reseting the router?
QUOTE Thanks
cwa107

 
cwa107's Avatar
 
Member Since: Dec 20, 2006
Location: Middletown, Pennsylvania
Posts: 26,493
cwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond repute
Mac Specs: 15" MBP, Core i7/2GHz, 8GB RAM, 480GB Crucial M500 SSD

cwa107 is offline
The CD is useless. All of the routers settings can be accessed through its built in web portal. More details to follow - am writing this on my iPod touch.
QUOTE Thanks
cwa107

 
cwa107's Avatar
 
Member Since: Dec 20, 2006
Location: Middletown, Pennsylvania
Posts: 26,493
cwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond repute
Mac Specs: 15" MBP, Core i7/2GHz, 8GB RAM, 480GB Crucial M500 SSD

cwa107 is offline
First off, you should connect the computer directly to the router via an Ethernet cable to attempt this configuration.

In order to use your router's web portal, you'll need its IP address. This can vary depending on how the router was setup, but it should be easy enough to find. On one of the connected computers, you'll need to look up the "default gateway". Assuming your housemates are using Windows, it can be done by doing the following:

Start => Run => Type:

CMD

..press Enter.

This should bring up a command prompt. In the command prompt, type:

Code:
ipconfig /all
...press Enter.

One of the tidbits should be the default gateway:



(The window pictured above is from a VM session - your address should be 192.168.1.1 or something similar).

If you're doing it on your Mac, you can see your default gateway by going to the Terminal (Applications => Utilities => Terminal) and type:

Code:
netstat -nr | grep '^default'
...which should yield something like:



Then, on one of the connected computers, open a web browser and type that default gateway address into the address bar in the browser. You'll be prompted for a username/password, these should have been setup during the installation process. If you didn't set them up, or left them as default, the username will be admin and the password will be blank. Hit Enter and you should be taken to the portal page.

Security settings are configured in Setup tab => Wireless Settings (left window pane) => Manual Wireless Settings (middle pane) => Wireless Security mode section:



Here, you'll choose the settings as shown above. Be sure to set a "Pre Shared Key" and save your settings. The "Pre Shared Key" is the password you'll be prompted to enter on each one of your client devices.

I know it sounds like a lot, but not only will your network be more secure, it should be faster and a lot more reliable.

Liquid and computers don't mix. It might seem simple, but we see an incredible amount of people post here about spills. Keep drinks and other liquids away from your expensive electronics!
QUOTE Thanks
BrooklynStudent

 
Member Since: Feb 04, 2009
Posts: 22
BrooklynStudent is on a distinguished road

BrooklynStudent is offline
Wow, thanks a lot! i will let you know how that works. also, i've noticed that i can sometimes fix the problem if i reset my browser. do you know why that works?
QUOTE Thanks
cwa107

 
cwa107's Avatar
 
Member Since: Dec 20, 2006
Location: Middletown, Pennsylvania
Posts: 26,493
cwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond repute
Mac Specs: 15" MBP, Core i7/2GHz, 8GB RAM, 480GB Crucial M500 SSD

cwa107 is offline
If you have no wireless connectivity at all, reseting your browser shouldn't make a difference. So not sure what the deal is there. Either way, changing to WPA is the smart move - I'm not even sure why modern routers ship with WEP support.
QUOTE Thanks
BrooklynStudent

 
Member Since: Feb 04, 2009
Posts: 22
BrooklynStudent is on a distinguished road

BrooklynStudent is offline
Hey, the problem seems to have resolved itself (for now at least) without me having to change the security settings. Any idea why that would be?
QUOTE Thanks
cnilles

 
Member Since: Dec 31, 2008
Posts: 4
cnilles is on a distinguished road

cnilles is offline
I've been having the same problems with my macbook. I'm visiting home for a week and the fam also has a d-link router. Connecting to the internet can take 5 minutes sometimes. Most, frustrating, thing, ever. The thing is, all of the other computers don't have the problem, so I don't want to toy around with the router just for my short time here.
QUOTE Thanks
BrooklynStudent

 
Member Since: Feb 04, 2009
Posts: 22
BrooklynStudent is on a distinguished road

BrooklynStudent is offline
Hi,

The problem started itself up again, so I'm going to take your advice. Can I use the same ethernet cord that the router is hooked up to the modem, or will I need to use a different one, so the router is hooked up to the modem the same time it's hooked up to the computer. Also, will I need to switch settings using the same computer I started the network on, or can use my computer for it?
QUOTE Thanks
cwa107

 
cwa107's Avatar
 
Member Since: Dec 20, 2006
Location: Middletown, Pennsylvania
Posts: 26,493
cwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond repute
Mac Specs: 15" MBP, Core i7/2GHz, 8GB RAM, 480GB Crucial M500 SSD

cwa107 is offline
Quote:
Originally Posted by BrooklynStudent View Post
Hi,

The problem started itself up again, so I'm going to take your advice. Can I use the same ethernet cord that the router is hooked up to the modem, or will I need to use a different one, so the router is hooked up to the modem the same time it's hooked up to the computer. Also, will I need to switch settings using the same computer I started the network on, or can use my computer for it?
You should leave it connected to the modem. Use a separate Ethernet cord, plugged into one of the four port on the back of the router. Also, you can use any computer you like as you're just using it as a venue to connect to the router's built in web interface.

Liquid and computers don't mix. It might seem simple, but we see an incredible amount of people post here about spills. Keep drinks and other liquids away from your expensive electronics!
QUOTE Thanks
BrooklynStudent

 
Member Since: Feb 04, 2009
Posts: 22
BrooklynStudent is on a distinguished road

BrooklynStudent is offline
thank you very much.

you don't happen to think that the connection issue is also due in part to a defective router, do you?
QUOTE Thanks

Post Reply New Thread Subscribe


« VPN with certificate | Mac/Virgin Broadband Wireless »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
Aqua Connect Terminal Server Josh Trenor OS X - Apps and Games 2 03-12-2009 06:44 PM
use airport extreme to play music and connect wireless but still use ethernet?????? dairyman Music, Audio, and Podcasting 0 05-27-2008 11:37 PM
Airport won't connect drjoan827 Internet, Networking, and Wireless 0 03-05-2008 09:28 AM
SMTP and PHP MrGecko Web Design and Hosting 0 02-08-2008 02:50 PM
Airport won't connect anywhere but home einheit Internet, Networking, and Wireless 0 09-30-2004 12:21 PM

All times are GMT -4. The time now is 12:12 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?