New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus • Advice and insight from world-class Apple enthusiasts • Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
Internet, Networking, and Wireless Discussion of networking, internet, and wireless including Apple's Airport products.

How do I make airport auto connect to a WAN with WEP?


Post Reply New Thread Subscribe

 
Thread Tools
edokid

 
Member Since: Aug 28, 2004
Posts: 231
edokid is on a distinguished road

edokid is offline
Hey everyone. I have a home network here and a PowerBook 12". Under network settings I have it set to automatically connect to my airport network which works fine. I shut down or sleep the computer, turn it back on and it connects np. But the other day I turned on WEP encryption in the router to be more secure than just MAC filtering and now the PowerBook doesn't auto connect. I have to click the airport icon and choose the network. I've saved the WEP key under keychain so when I click the network it connects as though its a network with no WEP but I still have to click my WAN every time I put the PB to sleep. Anyone know what I'm doing wrong? I just turned off WEP encryption for now because it was so much of a pain. Thanks.
QUOTE Thanks
edokid

 
Member Since: Aug 28, 2004
Posts: 231
edokid is on a distinguished road

edokid is offline
Does no one do this? I can't figure it out at all please help! I hate having to manually select the airport every time I come out of sleep...
QUOTE Thanks
Kokopelli
Guest
 
Posts: n/a

Have you tried setting you PowerBook to always connect to a specific WAP rather than use automatic? It won't solve your problem but might narrow it down.

Another possibility is changing the name of your access point and have WEP enabled before you attempt to connect via the PowerBook. Then connect and set up WEP. If you do not get prompted the next time your Laptop awakes I would guess it to be some incorrect data stored somewhere.
QUOTE Thanks
edokid

 
Member Since: Aug 28, 2004
Posts: 231
edokid is on a distinguished road

edokid is offline
No that's how it's set. I have it set to always connect to my specified network "Silver Millenium" which it does no problem. But I turned on WEP in the router and added a key. Now when I turn on PB it obviously doesn't connect so I select Silver Millenium then it asks for wep key so I type it in and it connects. I told it to save the key in keychain which it did. But every time I turn on the PB its not connected to any network. I have to click the airport icon, then choose Silver Millenium from the list and it connects. Doesn't ask for password or wep or anything because it's saved, so I don't know why it has such a problem with automatically connecting to it...
QUOTE Thanks
Kokopelli
Guest
 
Posts: n/a

So how about trying it on automatic? I had a similar problem with one of my access points. In my case everytime I came home my PB asked whether I wanted to connect to my AP automatically in the future. I resolved it by changing the AP name. Not the most elegant of solutions but it worked.

In my case I assume he PB has a setting to not connect somewhere that is not getting removed when I click to automatically connect in the future. I suppose I could grep around and find the setting but it did not seem worth the effort.
QUOTE Thanks
edokid

 
Member Since: Aug 28, 2004
Posts: 231
edokid is on a distinguished road

edokid is offline
Hey that worked thanks!!!! Automatic did the trick. I just hope it's smart enough to always connect to MY ap. I live in a condo downtown Toronto and there's like 10 nearby when I view the list. 8 of them are unsecured lol. Handy if mine ever goes down tho lol. Thanks,
QUOTE Thanks
Kokopelli
Guest
 
Posts: n/a

Cool beans. Automatic is supposed to go down the list of APs you have told it to always connect to autmoatically. If it does not find any of them it will prompt you to choose. At least that is the way it is supposed to work.
QUOTE Thanks
edokid

 
Member Since: Aug 28, 2004
Posts: 231
edokid is on a distinguished road

edokid is offline
Is there a way to reselect that list? Because it works sometimes others it doesn't. Sometimes it connects to the neighbour and I don't realize and freak out because my internet is so slow then I check and notice it... How do I view or change my list of trusted networks and take those other people off? In windows u can tell it to only connect to one network.
QUOTE Thanks
Kokopelli
Guest
 
Posts: n/a

I don't know but I will see if I can find out. Maybe somebody else here has an idea?

I did a little research and Mac OS X wireless configuration seems fine for simple situations but does not have any obvious documentation on more advanced configurations. I would expect there to be some way to set it to connect to access point X or Y exclusively but I can't seem to find a way. This would seem important for those who travel between multiple wireless locations.
QUOTE Thanks
edokid

 
Member Since: Aug 28, 2004
Posts: 231
edokid is on a distinguished road

edokid is offline
Hmm yeah it's really weird. Maybe there's a 3rd party app that will manage networks or something, it's such a pain. Automatic is fine if you live in a house with only one network but when there's like 10 of them it goes wherever it wants half the time.
QUOTE Thanks
edokid

 
Member Since: Aug 28, 2004
Posts: 231
edokid is on a distinguished road

edokid is offline
Hmm yeah it's really weird. Maybe there's a 3rd party app that will manage networks or something, it's such a pain. Automatic is fine if you live in a house with only one network but when there's like 10 of them it goes wherever it wants half the time.
QUOTE Thanks

Post Reply New Thread Subscribe


« how do i connect to the net with my airport to wanadoo | thinking about airport. »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
Airport on my powerbook won't connect when my WEP key is 64-bit gort Internet, Networking, and Wireless 2 08-21-2010 12:59 PM
How do I connect via airport and adsl modem? Maju Apple Notebooks 0 11-23-2004 05:51 AM
Airport won't connect anywhere but home einheit Internet, Networking, and Wireless 0 09-30-2004 12:21 PM
AirPort won't connect to the internet Absolute Zero Internet, Networking, and Wireless 0 06-30-2004 07:37 PM
make and CDRecord plunger OS X - Development and Darwin 3 12-29-2003 05:49 PM

All times are GMT -4. The time now is 01:37 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?