Results 1 to 6 of 6
  1. #1


    Member Since
    Jun 11, 2008
    Posts
    4
    Network Problem; Internet Connect says full signal but no connection
    I've been having this problem with my Mac ever since moving into a new house a while back.

    The house has a wireless network and I've successfuly connected my Mac to it so when I open the Internet Connect utility, the network appears and tells me I have a full signal. Problem is my browser wont load any pages. I tried the network diagnostic and restarted my modem and router already. That didn't work.

    This has been going on for sometime now. When I first moved in I had this problem and was so busy that I just used an old PC I had for a while. Then one day I just started my Mac up and all of a sudden I was connected to the network. Its been working fine until today when I was trying to load a couple of old hardrives to do some backups. All of a sudden my network no longer works again! And again, Internet Connect tells me I'm getting a full signal so access to the network or interference doesn't seem to be the problem.

    Here are my Mac's specs:

    Power Mac G4 2.1
    Dual CPU 867MHz
    Airport Firmware v.9.52
    Wireless Channel 6

    Would really appreciate any help ... ???

  2. #2


    Member Since
    Oct 22, 2008
    Posts
    3
    Airport is on but don't connect to the internet
    I have a similar problem - although not as bad as yours - when I'm at work I can sometimes get connected to the internet, but more often than not I can't. It always tells me that I'm fully connected via the Airport.
    At home however, I always get connected no problems.
    Did you ever sort this one out?

  3. #3


    Member Since
    Jun 23, 2008
    Location
    Hoover, AL
    Posts
    81
    Specs:
    Mac Mini
    If you hard wire your mac will it work correctly?
    War Eagle!

  4. #4

    STRIKE859's Avatar
    Member Since
    May 30, 2008
    Location
    Sunshine State
    Posts
    18
    Specs:
    Powermac G5 Dual 2 GHz, 2 GB RAM
    I have the same problem as shotdsherrif. And when I connect an ethernet cord from the modem/router combo directly to my mac, my internet works. All help is greatly appreciated.

    Tom

  5. #5

    youthpastor's Avatar
    Member Since
    Dec 06, 2005
    Posts
    439
    Have you tried changing the wireless channel to see if that helps?
    New MacBookPro | 2.4 GHz Intel Core 2 Duo |2 GB RAMMac OS X Leopard Version 10.5.5 | iPod Touch 8 GB | iPod Classic 80 GB

  6. #6

    STRIKE859's Avatar
    Member Since
    May 30, 2008
    Location
    Sunshine State
    Posts
    18
    Specs:
    Powermac G5 Dual 2 GHz, 2 GB RAM
    i got mine working again. All I did was go to the CONFIGURE screen for my AIRPORT and deleted all the wireless networks on the list, including my own. Then I added it again, turned off the AIRPORT, waited a minute, then turned the AIRPORT back on and it's been working ever since.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help Please! Airport showing full signal but no internet connection.
    By Louise McSharry in forum Internet, Networking, and Wireless
    Replies: 17
    Last Post: 03-03-2012, 01:57 PM
  2. Full signal and IP but no internet
    By brentl in forum Internet, Networking, and Wireless
    Replies: 2
    Last Post: 06-24-2011, 10:17 AM
  3. Airport connected, full signal, suddenly no internet!?!? :(
    By conchshell123 in forum Internet, Networking, and Wireless
    Replies: 2
    Last Post: 12-06-2010, 08:59 PM
  4. Airport shows full connection, but can't connect to internet
    By millerem in forum Internet, Networking, and Wireless
    Replies: 1
    Last Post: 09-03-2010, 10:00 AM
  5. Can't connect to Internet with full signal
    By mikcali86 in forum Internet, Networking, and Wireless
    Replies: 2
    Last Post: 11-01-2009, 10:04 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •