Results 1 to 9 of 9
  1. #1

    Member Since
    Dec 29, 2007
    Wireless works fine, ethernet connection doesn't

    I really hoping someone can help me out here... I'm getting close to resorting to physical violence.

    I have a macbook, which connects wirelessly to a DLink DIR655 wireless-N router. I also have a WD MyBookWorld that connects via ethernet to the dlink. After many hours (and a lot of help from this and other online forums) this setup has been working without a hitch for several months.

    Problem is, I want to update the firmware for the router which is still the original version and two years out of date. To do this I need a wired connection to the router.

    Nothing I do will make this !@#$ laptop accept a wired connection to the router. I have rebooted, reset, reconfigured, re-everythinged for several hours. As soon as I disable the airport, I can not access the router or internet. I've tried swapping cables - no difference. Typing the router ip address into safari just gives an error 'you cannot connect to because you are not connected to the internet'

    Diagnostics shows a green light for the ethernet connection, and a valid IP address assigned, and also a green light for network settings. Sometimes a green light will appear briefly for ISP, but turns red again. Internet and SErver are both red.

    I can't believe this should be so hard! I'm sure I've missed something obvious...... Can anybody see what it is?



  2. #2

    Member Since
    Sep 11, 2007
    Durham NC
    Sawtooth G4 and PB G4 w/FW800
    For what it's worth, you should be able to access the router without connecting to the internet.

    Have you configured the connection manually? Set up the ethernet port with the router's IP address and subnet address and manually assign the computer an address within the routers range.

    Are you sure you are entering the right IP address for the router? The "default" linksys address is not usually, it's (if you hit the reset button on the router, I think it will revert to the original address).

    Hopefully it is something easy, because networking stuff isn't fun (at least not for me). Too many resets and restarts when things aren't working right.

  3. #3

    youthpastor's Avatar
    Member Since
    Dec 06, 2005
    Have you checked to make sure you are set up to connect via PPoE? You may need to disconnect the ISP router from the D-Link and hook your Mac to the ISP router via ethernet. Once you have done that, go to the modem page and make sure you are logged in and using the PPoE protocol. If that does not work some folks have success by using Bridged Ethernet.

    Let us know how that works, and feel free to post some more I really want to help you get things back in order. Good luck <><
    New MacBookPro | 2.4 GHz Intel Core 2 Duo |2 GB RAMMac OS X Leopard Version 10.5.5 | iPod Touch 8 GB | iPod Classic 80 GB

  4. #4

    dtravis7's Avatar
    Member Since
    Jan 04, 2005
    Modesto, Ca.
    iMac late 2007 10.11.b4, iMac 2008 10.10.5, Macbook2007 10.7.5, Mac Mini 10.7.5, iPhone 3GS Note 8!!
    If you open System Preferences/Network on OSX what IP address does it show under Built In Ethernet? Does it show a router address? If so what is it?

  5. #5

    Member Since
    Dec 29, 2007
    Thanks for your replies.

    Celica73 - my DLink router seems happy with - I can access it using this ip with no problems using the wireless connection; it is only when I try using the ethernet cable that it can't connect - despite showing it is connected in the network diagnostics.

    Youthpastor - My ISP works fine with DHCP; again, wireless internet connection is not a problem, it's only when I disable the airport and try and connect to the router (same router, same config, same ip for router and laptop etc etc) that it spits the dummy.

    dtravis - ip address for router under the network settings depends on whether I'm setting it manually or not - at present it is set to The router is setup to use static IP for the laptop client (found this easier for the wireless). I've tried using auto DHCP and it gives the router an ip like When I use manual settings ( I get green lights for ethernet connection and network settings in the diagnostics. Anything else and these also are red lights.



  6. #6

    matt1985's Avatar
    Member Since
    Nov 11, 2006
    Perth, Australia
    2.5ghz Penryn MBP, 4 Gb Ram, 512mb 8600M GT, 250gb HDD & Black 30gb iPod, Black 16gb iPhone 3G
    did you set up MAC address filtering in your router?
    your ethernet and airport cards will have different addresses so if you didnt enter the address for the ethernet card you wont be able to get on.

  7. #7

    Dysfunction's Avatar
    Member Since
    Mar 17, 2008
    Tucson, AZ
    Way... way too many specs to list.
    if you can boot off the install DVD and en0 (your ethernet adapter) works, then open a terminal do a

    mv /Library/Preferences /Library/Preferences.bak

    and reboot.

    bet it'll work.
    This machine kills fascists
    Got # ? phear the command line!

  8. #8

    Member Since
    Dec 29, 2007
    So close and yet.... Matt, didn't realise there was a separate MAC for the ethernet card, and yes, was using MAC filtering. Have added the ethernet card MAC now, and allocated it its own IP address.

    So with that, I cannot connect to the internet still, nor can I access the router. For a web page, it just says that 'computer is not connected to the internet'. For the router, it just hangs - doesn't say can't connect, but doesn't connect either (address box in safari starts the blue highlight thing, but doesn't get past about 1/4 - just stays there indefinately).

    Now the really stupid part is that I can connect to - and read and write files - my mybookworld drive, which is accessible only through the router.

    It's not making sense!

    Disfunction, yet to try your tip as I expected the MAC thing would fix it. Question - do I need to do the install DVD boot in order to do the preferences thing, or can I just do it? The ethernet adapter seems to work fine (otherwise couldn't access the network drive) - just can't see the stupid router....

  9. #9

    PerryLynch's Avatar
    Member Since
    Sep 24, 2007
    17" MacBook Pro 4GB
    OK, try this: Copy your dns settings, save the mac's IP, and then create a new Ethernet network profile, using this information. But make one change: If the mac's wireless IP is, make the wired IP

    Also, check to see if the router has a "management IP" setting somewhere. It sounds like it might. Some of them have a feature that will prevent you from accessing the config page from more than 1 IP within a certain amount of time.
    Perry M Lynch, CISSP CISA
    Mac Newbie, Security not-so-newbie

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Ethernet is active but no internet connection (although Wi-fi works)
    By Pluistronaut in forum Internet, Networking, and Wireless
    Replies: 3
    Last Post: 11-03-2012, 05:49 PM
  2. Internet Connection Problems, Wireless and Ethernet
    By Neil79 in forum Internet, Networking, and Wireless
    Replies: 6
    Last Post: 03-15-2012, 05:12 PM
  3. Tether wireless connection to ethernet port
    By cjmarshall in forum Internet, Networking, and Wireless
    Replies: 1
    Last Post: 09-10-2010, 02:03 PM
  4. Wireless Works - Wired Doesn't
    By grimesh in forum Internet, Networking, and Wireless
    Replies: 5
    Last Post: 10-04-2008, 03:53 AM
  5. wireless ethernet connection questions
    By dolphin01 in forum Internet, Networking, and Wireless
    Replies: 1
    Last Post: 09-07-2007, 07:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts