Results 1 to 5 of 5
  1. #1

    Member Since
    Jan 17, 2008
    USB Hub causes wireless internet to drop - webpage wont load
    i've finally isolated this problem.
    ive got a belkin 7 port USB hub attached to my mini and use a belkin wireless router.

    plug any active device into the hub and my webpage wont load. it just hangs.
    plug out usb device and refresh page and it works.

  2. #2

    Aptmunich's Avatar
    Member Since
    Mar 09, 2004
    Aluminium Macbook 2.4 Ghz 4GB RAM, SSD 24" Samsung Display, iPhone 4, iPad 2
    Wow, that's weird. You don't use an external USB wireless adapter do you?

  3. #3

    Member Since
    Jan 17, 2008
    im using a belkin wireless modem/router. my mac connected by airport to this.

    previous to that i was using a ZyXel wired modem and had my mini connected to the web by ethernet and there was no problems with the hub then.

    it seems to cut the wireless completely as a webpage wont load on my macbook either.

    cant understand how its interfering with the wireless.
    ive tried changing the wireless channel but now luck there.

  4. #4

    Member Since
    Jan 17, 2008
    its actually the power adapter to my usb hub that causing the problem. tried it without power adapter. also used a multi - adapter power supply and it works fine with that.

    will have to ask belkin for a new power supply

  5. #5

    Member Since
    Dec 29, 2008
    2.4Ghz wireless interfering with USB hub connected to MAC
    Have Linksys wireless (2.4Ghz [B/G]) router (WRT54G v6) connected to MAC. Can print once to HP laser (USB attached printer). Subsequent prints don't work although MAC print dialogue box shows "printing". Restarted MAC and HP laser, still no print. Power cycled USB hub, began printing that job. Subsequent prints did not work. Finally removed Linksys and plugged MAC into DSL modem, still same issue. Removed power from Linksys (stopped 2.4Ghz wireless transmission) and printing worked fine. I think the 2.4Ghz signal is interfering with the USB hub somehow. Next step is to replace USB hub and look at better, shielded USB cables.

    Anyone experience or seen this type issue?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Full internet connection, browsers wont load
    By dillonupgrade in forum Apple Notebooks
    Replies: 1
    Last Post: 04-29-2014, 08:24 PM
  2. wireless/network usb hub
    By drake in forum Internet, Networking, and Wireless
    Replies: 0
    Last Post: 02-12-2009, 06:59 PM
  3. Wireless Internet - Webpage problems
    By macamrstudios in forum Internet, Networking, and Wireless
    Replies: 1
    Last Post: 01-25-2008, 10:41 PM
  4. Can I setup a Wireless USB Hub?
    By DesignVHL in forum Other Hardware and Peripherals
    Replies: 3
    Last Post: 02-19-2007, 02:04 PM
  5. Can you use USB hub on Airport Wireless Base Station?
    By markw10 in forum Internet, Networking, and Wireless
    Replies: 4
    Last Post: 01-15-2007, 12:28 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts