Mac Forums

Mac Forums (http://www.mac-forums.com/forums/)
-   Images, Graphic Design, and Digital Photography (http://www.mac-forums.com/forums/images-graphic-design-digital-photography/)
-   -   iPhoto or Lion update has stopped some pictures from 'working' (http://www.mac-forums.com/forums/images-graphic-design-digital-photography/279782-iphoto-lion-update-has-stopped-some-pictures-working.html)

Poptasticdave 07-20-2012 04:10 AM

iPhoto or Lion update has stopped some pictures from 'working'
 
Can anyone help please?

I have an iMac running OS X Lion and iPhoto - now upgraded to latest version but until 2 days ago running the iLife '09 version.

I have over 26,000 pictures in iPhoto / on the computer.

I've been using this set up since 2008 and not experienced any problems until 2 days ago.
My 'photos mainly come from my Nikon D3000 camera or from my Motorola XT910 SmartPhone.

When I import photos I always do it by connecting the camera or 'phone via USB and importing directly to iPhoto.

Two days ago I installed the latest upgrades to OS X Lion.

Yesterday I connected up the XT910 to import 23 pictures I'd taken.

iPhoto won't import them, telling me that each one is "in an unrecognised format", but hey are just jepgs like the approx 750 others I've imported from this 'phone before.

More worryingly, I looked back at an iPhoto event from July 8th, which contains 56 'photos imported from the XT910, which DID work fine, and now when I scroll down the event in iPhoto, the thumbnails briefly flash up and then are replaced by a blank space. Clicking each one to open it brings up the warning triangle with the exclamation mark in it, but no picture.

However, very oddly, another iPhoto event, from July 6th, containing 12 'photo's from the XT910 still works fine.

Yesterday I upgraded iPhoto to the latest version, in the hope that this might cure things, but it has made no change at all.

I've tried opening the images on the 'phone and from teh July 8th event in other software apps, including Preview and a free copy of GIMP, but they are not recognised there either. If it was only the images on the 'phone that were not working I'd think that I needed to look to the 'phone settings or to a fault withe th 'phone, but the iPhoto event from July 8th has made me think that this is an issue with either the OS X Lion update or with iPhoto.

Anyone got any ideas please?

chscag 07-20-2012 02:25 PM

I don't have an answer for you, however, unless you're making timely backups, you may wind up losing those 26,000 photos. We see so many folks whose hard drives crashed and they lose all their photos. If you are already in the habit of making backups, that's good. Hang on until someone has an answer for you.

And Welcome to the Mac Forums.

Poptasticdave 07-20-2012 02:41 PM

Quote:

Originally Posted by chscag (Post 1427028)
I don't have an answer for you, however, unless you're making timely backups, you may wind up losing those 26,000 photos. We see so many folks whose hard drives crashed and they lose all their photos. If you are already in the habit of making backups, that's good. Hang on until someone has an answer for you.

And Welcome to the Mac Forums.

Thanks for the welcome.

I do daily time machine backups to a Time Capsule, so my photo's should be relatively safe and I'm pretty confident that the issue isn't cased by an corrupted files or failing HDD's.

Hope someone has some ideas .......

Lifeisabeach 07-24-2012 08:14 AM

Quote:

Originally Posted by Poptasticdave (Post 1427035)
Thanks for the welcome.

I do daily time machine backups to a Time Capsule, so my photo's should be relatively safe and I'm pretty confident that the issue isn't cased by an corrupted files or failing HDD's.

Hope someone has some ideas .......

I wouldn't completely rule out the possibility of file corruptions or a failing drive. You could have some cache or permission issues just for starters. I recommend grabbing Onyx and run its full suite of maintenance and cache cleaning tools. If that doesn't fix the problem, then look harder at the drive. Here's a post of mine detailing the best ways to do so:
http://www.mac-forums.com/forums/os-...ml#post1372971

Have you tried importing your photos directly to a folder rather than iPhoto? You can change this using Image Capture, found somewhere in your Applications folder.

EDIT: also… try repairing the iPhoto library.
iPhoto 6 and later: Rebuilding the iPhoto library


All times are GMT -4. The time now is 07:50 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.