Results 1 to 13 of 13
  1. #1

    vitaopus's Avatar
    Member Since
    Oct 28, 2009
    Location
    Minnesota
    Posts
    67
    Specs:
    27" 2.88 Quad-Core i7, 8 GB RAM, 2TB HD, 512 ATI Raedon
    Adobe illustrator CS4 unexpectedly quits
    Today, a problem with Adobe Illustrator CS4 began happening. Anytime I open the application, attempt to create a new document, open an existing document, import any files or try to open any menu in the application-- it quits unexpectedly. Any clue as to why this is happening?

    I've lost around 2 months of work!

  2. #2

    deus_ex_machina's Avatar
    Member Since
    Aug 06, 2004
    Location
    Tejas
    Posts
    1,713
    Specs:
    2GHz Mac Mini 2GB RAM 160GB 10.6.2 | MDD DP 1.25GHz G4 1.5GB RAM 10.4.11 | 233MHz iMac G3 10.3.9
    trash any adobe plists you can find and repair permissions. Such errors gave me issues with CS3.

  3. #3

    vitaopus's Avatar
    Member Since
    Oct 28, 2009
    Location
    Minnesota
    Posts
    67
    Specs:
    27" 2.88 Quad-Core i7, 8 GB RAM, 2TB HD, 512 ATI Raedon
    plists?

  4. #4

    deus_ex_machina's Avatar
    Member Since
    Aug 06, 2004
    Location
    Tejas
    Posts
    1,713
    Specs:
    2GHz Mac Mini 2GB RAM 160GB 10.6.2 | MDD DP 1.25GHz G4 1.5GB RAM 10.4.11 | 233MHz iMac G3 10.3.9
    preference lists, usually in your username/library/preferences. If they get corrupted, the system can recreate them by you deleting them.

  5. #5

    vitaopus's Avatar
    Member Since
    Oct 28, 2009
    Location
    Minnesota
    Posts
    67
    Specs:
    27" 2.88 Quad-Core i7, 8 GB RAM, 2TB HD, 512 ATI Raedon
    Thanks. I found the files and deleted them. Also repaired permissions. The problem persists.

    I attempted to open up a second user account and Illustrator works fine there.

    I contacted both Apple and Adobe Technical Support about the issue (since i'm kind of crippled until this is fixed) and they advised me to reformat my computer. They said that it's a corrupted user administrator account and that there is no other way to fix it but to reformat and start all over again.

    Any other alterantive ideas? I don't really want to reformat my computer that I JUST bought.

  6. #6

    deus_ex_machina's Avatar
    Member Since
    Aug 06, 2004
    Location
    Tejas
    Posts
    1,713
    Specs:
    2GHz Mac Mini 2GB RAM 160GB 10.6.2 | MDD DP 1.25GHz G4 1.5GB RAM 10.4.11 | 233MHz iMac G3 10.3.9
    um - just create a new admin account, move stuff over and delete the old. Accounts are arbitrary.

  7. #7

    vitaopus's Avatar
    Member Since
    Oct 28, 2009
    Location
    Minnesota
    Posts
    67
    Specs:
    27" 2.88 Quad-Core i7, 8 GB RAM, 2TB HD, 512 ATI Raedon
    Hm... still no luck. I created a new admin account, moved the files over and deleted the old account.

    I also tried Apple and Adobe's way of archiving the files and then re-installing OSX.

    Still cannot open Illustrator....

  8. #8


    Member Since
    Jan 22, 2010
    Location
    Victoria, BC
    Posts
    20,911
    Specs:
    Mid-2012 MBP (16GB, 1TB HD), Monoprice 24-inch second monitor, iPhone 5s 32GB, iPad Air 2 64GB
    First of all, I'm really sorry you are getting such completely crappy advice so far.

    I don't have a magic solution, but this sort of thing often happens when fonts become corrupted.

    Have you used any utilities that would clear out font caches, such as OnyX? If not, give that a try first.

    If that doesn't resolve the issue, try this:

    1. Restart the machine.
    2. Hold down the SHIFT key while its restarting. Keep holding till you see the words "Safe Boot" in red.
    3. Try launching Illustrator to see if it works. It may not, but that's okay.
    4. Restart the machine normally.

  9. #9

    deus_ex_machina's Avatar
    Member Since
    Aug 06, 2004
    Location
    Tejas
    Posts
    1,713
    Specs:
    2GHz Mac Mini 2GB RAM 160GB 10.6.2 | MDD DP 1.25GHz G4 1.5GB RAM 10.4.11 | 233MHz iMac G3 10.3.9
    BTW, are you using Fontbook to manage your fonts? I had a problem way back when I tried to activate 5000 fonts and it crashed AI trying to load them all.

  10. #10

    deus_ex_machina's Avatar
    Member Since
    Aug 06, 2004
    Location
    Tejas
    Posts
    1,713
    Specs:
    2GHz Mac Mini 2GB RAM 160GB 10.6.2 | MDD DP 1.25GHz G4 1.5GB RAM 10.4.11 | 233MHz iMac G3 10.3.9
    Also here is a list of steps I found to troubleshoot AI CS4 errors (two of which are my previous posts):

    Troubleshoot system errors or freezes in Illustrator CS4 (Mac OS)

  11. #11

    vitaopus's Avatar
    Member Since
    Oct 28, 2009
    Location
    Minnesota
    Posts
    67
    Specs:
    27" 2.88 Quad-Core i7, 8 GB RAM, 2TB HD, 512 ATI Raedon
    18. Troubleshoot fonts.

    A system error can occur if Illustrator accesses a damaged font. You can troubleshoot fonts to determine if they cause the problem.

    To troubleshoot fonts in Mac OS X v10.4.x-10.5.x:

    1. Deactivate all font management utilities, such as Adobe Type Manager or Extensis Suitcase.
    2. Start Font Book from the Applications folder.
    3. (Mac OS X v10.4.x only) In the Collection column, expand All Fonts.
    4. In the Collection column, select Computer.
    5. Now in the Font column click a font then hit Command A to select all the fonts.
    6. Choose Edit > Disable Fonts. Click Disable, when asked to confirm.
    7. At the Finder, choose File>Find.
    8. Type AdobeFnt12.lst , select the system drive, and then press return.
    9. Delete all the AdobeFnt12.lst files found.
    10. Run Illustrator. Then do one of the following:
    * If the problem recurs, then repeat steps 4-8 to disable the User and Classic collections.
    * If the problem doesn't recur, then the problem font is in the collection you disabled. In Font Book, enable one font at a time in the collection and try to reproduce problem until you find the damaged font.


    This seemed to be the immediate problem-solver. I just removed recently installed fonts (since the problem happened very recently... just yesterday) and now Illustrator works fine. Thanks for all the help guys! I really appreciate it!

  12. #12

    deus_ex_machina's Avatar
    Member Since
    Aug 06, 2004
    Location
    Tejas
    Posts
    1,713
    Specs:
    2GHz Mac Mini 2GB RAM 160GB 10.6.2 | MDD DP 1.25GHz G4 1.5GB RAM 10.4.11 | 233MHz iMac G3 10.3.9
    Glad it worked - them fonts can be pesky!

  13. #13

    vitaopus's Avatar
    Member Since
    Oct 28, 2009
    Location
    Minnesota
    Posts
    67
    Specs:
    27" 2.88 Quad-Core i7, 8 GB RAM, 2TB HD, 512 ATI Raedon
    Specifically, it was the font "dirt2 stickler". Not sure if anyone else has had any problems with that one or not.

    Thanks again!!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Gremlins in Adobe Illustrator CS4
    By rickburn in forum OS X - Operating System
    Replies: 3
    Last Post: 12-12-2010, 04:15 PM
  2. Gremlins in Adobe Illustrator CS4
    By rickburn in forum OS X - Apps and Games
    Replies: 0
    Last Post: 11-18-2010, 05:35 AM
  3. Adobe Illustrator CS4
    By Tiggger33 in forum Images, Graphic Design, and Digital Photography
    Replies: 0
    Last Post: 05-07-2010, 01:59 PM
  4. Adobe Acrobat 6.0 quits unexpectedly
    By trader22 in forum Images, Graphic Design, and Digital Photography
    Replies: 10
    Last Post: 12-31-2009, 04:49 PM
  5. All adobe software unexpectedly quits on launch
    By emmarandom in forum Running Windows (or anything else) on your Mac
    Replies: 2
    Last Post: 03-08-2007, 11:36 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •