New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
Apple TV Discussion of Apple TV, the new revolution in watching television.

Need help troubleshooting AirPlay


Post Reply New Thread Subscribe

 
Thread Tools
RenegadeMonster

 
Member Since: Apr 13, 2013
Posts: 5
RenegadeMonster is on a distinguished road

RenegadeMonster is offline
Good Afternoon,

I am trying to figure out a issue with airplay and I am trying to track down what is causing it and how to fix it.

I just purchased a Apple TV for the first time this week.

Mirroring and AirPlay with video work perfect from my iPad 3 and iPhone 5 to the apple tv. However, air play for music does not. It's most like silent with a skip of music every 10 seconds or so. I can get music to play only by Mirroring.

Home sharing from my iTunes Library will play music, how ever will not play video. Video's will buffer for 20 minutes or so before they play 3 minutes then go back and buffer more.

I was thinking this was a Windows 8 Issue until I got my Apple TV. That is because for more then a year I have been using the AirVideo App and AIR Video server on my laptop to stream video to my iPad. After upgrading to Windows 8 the iPad suffers the same long buffer like the Apple TV. But then to have a different problem from my iPad and iPhone to Apple TV makes me think it's at networking issue. But it makes no since that 1080P video from iPad to Apple TV plays instantly but audio will not.

I have a Lynksis EA2700 Router (Dualband Wireless N)

Anyone have any idea's on what the issue might be and what I can try to trouble shoot this issue? Thanks=)
QUOTE Thanks
mrplow

 
mrplow's Avatar
 
Member Since: Oct 01, 2007
Location: UK
Posts: 6,750
mrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond repute
Mac Specs: 27" iMac i7 (2011) 10.10, iPhone6, iPad Air, AppleTV2

mrplow is offline
It's an odd one. I wonder if you have some QoS rules on your router that's manipulating the traffic?

Don't suppose you have another router you could try or maybe reset the Linksys to factory defaults?

External hard disk acquisition addict - but admitting the problem is the first step to a robust backup

Please use the reputation system if you think you've been helped - top right of this post
QUOTE Thanks
RenegadeMonster

 
Member Since: Apr 13, 2013
Posts: 5
RenegadeMonster is on a distinguished road

RenegadeMonster is offline
I do not have any QoS settings and setting to factory defaults made no difference.

I do not have another router to try, but in 2 weeks I'm going to go visit my parents so I'll bring it with me and see if it works on their router.
QUOTE Thanks
mrplow

 
mrplow's Avatar
 
Member Since: Oct 01, 2007
Location: UK
Posts: 6,750
mrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond repute
Mac Specs: 27" iMac i7 (2011) 10.10, iPhone6, iPad Air, AppleTV2

mrplow is offline
Post back with the results. I can only think its the router. Perhaps, with it being dual-band, it's not managing the traffic between g and n and wired devices.

Any firmware updates available for the router?

External hard disk acquisition addict - but admitting the problem is the first step to a robust backup

Please use the reputation system if you think you've been helped - top right of this post
QUOTE Thanks
RenegadeMonster

 
Member Since: Apr 13, 2013
Posts: 5
RenegadeMonster is on a distinguished road

RenegadeMonster is offline
Well, there is a firmware upgrade available. Every time I try to install it however it fails through the smart upgrade utility app. Going to try to extract the zip and manually upgrade and see if that takes, will update with the results.

Edit:

The manual upgraded failed as well. I tried clicking on the restore previous firmware button hoping to roll back the firmware and being able to upgrade after that. That resulted in the router being restored to the newest firmware. Ok, i'll take that, didn't see that one coming.


I am still having the same issue though, so that didn't work=\
QUOTE Thanks
RenegadeMonster

 
Member Since: Apr 13, 2013
Posts: 5
RenegadeMonster is on a distinguished road

RenegadeMonster is offline
Well. It works fine with the 10 year old linksys wireless g router.

How do I begin troubleshooting my router to make it work.

Edit: I got 8 tacks I'm before the wifi failed / crashed on my ipad forcing me to restart it. Now I am experiencing the familiar skipping for parts of songs where it works ok for a while at other times

Edit 2: the issue with my parents router sees to be it can't handle the load. If I plug the Apple TV via network cable every thing works 100%
QUOTE Thanks
RenegadeMonster

 
Member Since: Apr 13, 2013
Posts: 5
RenegadeMonster is on a distinguished road

RenegadeMonster is offline
Hmm. Wont let me edit my last post again.

Today audio streaming is all choppy and dropping out so silence minutes at a time from my ipad. This is just like it is on my network. Not much better. Here is something odder. It works 100% while I hold my ipad in my hands. As soon as I put it down the audio cuts out. It picks back up as soon as a grab the ipad again. This is with full strength signal and standing 2 feet away from the router.

I am having no audio streaming trouble from my iPhone 5 on this network.

Vedio works sometimes and ther times it won't at all or is very slow. Some times the iPads wifi connection disconnects when playing a video.


I was thinking it was the router but I don't understand the hold the ipad for the streaming audio to work today.
QUOTE Thanks

Post Reply New Thread Subscribe


« Streaming Alternatives to Apple TV ? | Speaker to Receiver Compatibility »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
iPad Mini and Airplay Hollyoak iPad Hardware and Accessories 2 02-26-2013 07:56 AM
Is there really no way to remotely turn on Airplay in OSX? fleurya OS X - Operating System 2 02-25-2013 10:28 AM
Airplay with Airport Express's evilgrimace Other Hardware and Peripherals 5 08-10-2012 10:53 AM
AirPlay Troubleshooting nilesc Apple TV 1 07-08-2012 07:06 AM
Airplay via iPad, mirroring & fullscreen stuttering ovbg Apple TV 6 06-10-2012 12:04 PM

All times are GMT -4. The time now is 08:14 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?