Results 1 to 5 of 5

Thread: Atv3 troubles..

  1. #1


    Member Since
    Nov 04, 2012
    Posts
    4
    Atv3 troubles..
    Hi all, first post, great forum.

    I am getting a bit fed up with my atv3 and other mac stuff for a few reasons here goes...

    After the last atv3 update, it seems that the auto Dolby digital switch will not work now, this manifests itself as follows. Take the film view to a kill, the music is in 2.1 and the film is 5.1 and with the auto switch not working you get no theme tune and incidental music is missing.

    I thought I could use a mac mini and frontrow to get round this but frontrow will not group tv shows and also lists them all backwards. I then tried apple remote app and that also will not group tv shows correctly.

    It seems apple do not bother testing their software updates any more as a lot of people on other forums are suffering now. I have left numerous bug reports but youse know they go in the bin. As a longtime mac fan I find myself looking to jack it all in as it is getting very hard to maintain a working setup now.

    Has anyone here got any suggestions??

  2. #2

    Lifeisabeach's Avatar
    Member Since
    Sep 30, 2007
    Location
    The Republic of Neptune
    Posts
    7,757
    What are the components of your home theater system? How is everything connected? Are these videos iTunes purchases or DRM-free videos that you made yourself? No need to elaborate on how you made them. If they are self-made, drop an example of a file you have trouble with in a free app named Subler and post a screen cap of that, if you could. From that, I may be able to tell if the components are "arranged" properly inside it.

    Please verify and include the exact model/year of your Mac and OS X version number (available from "About This Mac", then "More Info" on the Apple menu).
    ------
    Links: Onyx | EasyFind | Apple Hardware Test | How to test your hard drive | The Safe Mac Adware Removal Guide | Uninstall MacKeeper
    ------
    Lifeisabeach - Mac-Forums Member of the Month June 2009, Feb 2012, and March 2013.

  3. #3


    Member Since
    Nov 04, 2012
    Posts
    4
    Thanks but i have been using the same files over the years on ATV's 1, 2 & 3 and they all worked fine until the last OS update on the ATv3.

    The system is a pretty standard one, im not at home so i cant get model numbers but its all mid-range equipment. The ATV3 is connected via HDM! to my plasma tv, and via optical to my AV amp. I also have the usual sky box connected similarly to other inputs of course.

    This system has been good right up to that last update. It can be made to switch Dolby output from 2.1 to 5.1 via the menu but will not do it itself any more. It seems it only affects files that are 2.1 / 5.1 mixed i.e the themes are 2.1 then the main feature is 5.1.

    I am now in the process of setting up a HTPC system with a mac mini running PLEX software, i will be testing it this weekend. This has many benefits so hopefully will be a solution.

    The ATV is a great box but does have some problems it seems, the previous update bricked my son's ATV3 and it took several resets to get it running again, now the audio is failing on that one too.

    BTW the videos are all DVD rips made with handbrake in the usual way, i have kept the DVD's so they are backups really. I have no DRM content.

    Dave

  4. #4

    Lifeisabeach's Avatar
    Member Since
    Sep 30, 2007
    Location
    The Republic of Neptune
    Posts
    7,757
    Well it sounds like it's the ATV update then since you've been using these same files over multiple devices. I have the ATV2 and the blasted update killed my chapter forward/back buttons (I use a Harmony remote). I'm not particularly aware of the sound issues you are having. I know I've seen media switch between 2.1/5.1 but I couldn't find anything of mine I've played recently that does that. I must be thinking of something off my satellite TV service.

    I used a Mac mini running Plex as an HTPC for a bit. Honestly... I hated it for a variety of reasons. Firstly, although Plex has an awesome UI, it doesn't properly format anamorphic rips that have "non-square pixels", which would be any DVD rip if you are using Handbrake's defaults. The proportions are off a bit and are slightly wide, iirc, though a lot of people don't notice it. This is a problem rooted in XBMC and inherited by Plex. Their iOS version doesn't have the problem. There's a thread here somewhere that I posted an example of this.

    Another problem with Plex is that it just doesn't stream wirelessly very smoothly if the videos have higher bitrates. It was more problematic with videos that had DTS audio. Even when those streamed smoothly, the audio would gradually lose sync.

    There were other problems like losing connection to the AFP server that I had my files on; lockups requiring a reboot of the Mac; and so on. My best advice to make the most of a Mac mini as an HTPC with Plex is to stick with locally-attached storage for your media. Don't do it wirelessly. And make sure all your videos are in x264 for hardware decoding support. If you use a universal remote, there's a piece of software named Remote Buddy that is absolutely FANTASTIC!

    Please verify and include the exact model/year of your Mac and OS X version number (available from "About This Mac", then "More Info" on the Apple menu).
    ------
    Links: Onyx | EasyFind | Apple Hardware Test | How to test your hard drive | The Safe Mac Adware Removal Guide | Uninstall MacKeeper
    ------
    Lifeisabeach - Mac-Forums Member of the Month June 2009, Feb 2012, and March 2013.

  5. #5


    Member Since
    Nov 04, 2012
    Posts
    4
    Thanks for that.

    I have the setup running now, so far I am very impressed, the UI is lovely, the metadata scraping is brilliant and so far no problems with sync etc, plus I can set the output permanently to 1080p unlike the atv3 which set it to what it thought was good. The picture quality does appear to be better.

    All my media is H264 with ac3 and a few DTS ones. The network is all hard wired apart from the iPads and the storage is on a Drobo which has no problem streaming to two or three clients at once, no transcoding of course.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. ATV3 and iTunes 12.0.1 (yosemtie)
    By MACyMouse in forum Apple TV
    Replies: 4
    Last Post: 11-12-2014, 09:21 PM
  2. ATV3 access
    By ragu in forum Apple TV
    Replies: 1
    Last Post: 09-18-2012, 12:52 PM
  3. ATV3 + iPhone4 = Slow Mo!
    By Darker Times in forum Apple TV
    Replies: 2
    Last Post: 09-11-2012, 11:07 AM
  4. Just picked up a new ATV3 and love it
    By elwaylite in forum Apple TV
    Replies: 3
    Last Post: 06-02-2012, 01:16 AM
  5. Replies: 3
    Last Post: 03-23-2012, 03:10 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •