Results 1 to 7 of 7
  1. #1


    Member Since
    Jun 22, 2010
    Posts
    155
    Airplay via iPad, mirroring & fullscreen stuttering
    Hello, I have a question about Airplay from an iPad and full screen mirroring. (iPad3 + ATV3)

    By this, I mean when I watch a streamed video from an App or Website that does allow Airplay, but only with mirroring on, yet full screen on the TV. Not all mirroring does this and here is where it get's a bit odd.

    If I go to a video stream like this and lay on the iPad, it generally starts buffering when viewing on the iPad (not talking about live at the moment, but catchup or on-demand). So, the image quality is without any skipping or stuttering.

    If I select Airplay, many of these sites will not send over to the Apple TV. I am assuming this is because the developer chooses not to. But what they often allow is mirroring to work - and in two ways.

    Some of them allow just basic mirroring, so everything is mirrored directly over to the TV. When I enlarge the video to be full screen, it has black bars around it. This seems to work perfectly well without stuttering.

    Some streams though, when I enlarge the video to full screen on the iPad, also enlarge with mirroring through the Apple TV. When I do this, I no longer get any buffering on the video and it stutters. Is there a way to avoid this stutter? It seems to come every few seconds and the sound continues without issue, but the video freezes for a second, then suddenly catches up.

    If I go out of full screen mode, the normal mirroring function returns (everything on the screen but with black bars on either side) and the stuttering stops - it is perfectly smooth. The stutter is only at full screen.

    I can't seem to find anyone else with this problem, so is it just me? Is there a setting to allow buffering here?

    Is there anything I can do to improve this? (My wifi access point, ATV and iPad are all in the same room with full signal strength)


    Remember, it is only at full screen on mirroring (when the ATV also goes to full screen) and not normal mirroring, or when the full screen on iPad results in black borders around the video on the TV.

    Apps which seem to have this problem for me are (amongst many)
    ITV App (UK) at full screen mirroring
    ABC (iView) Australia at full screen mirroring
    Channel 9 News App (Australia)
    TVNZ App (New Zealand)
    and plenty more, basically any App that requires mirroring to get full screen Airplay

    Normal Airplay at full screen has absolutly no issues with me. i.e. iTunes, YouTube, and streaming HD films from my NAS. Only on these TV websites that don't use normal Airplay.

    Also, oddly, this doesn't affect 4oD (UK) App, which will stream full screen at mirroring without stutter.

  2. #2


    Member Since
    Jun 22, 2010
    Posts
    155
    I sort of guessed not many people are having this problem. Is it possible my ATV is faulty? It seems odd that I have so many Airplay issues that few others seem to have.

  3. #3


    Member Since
    Sep 10, 2011
    Posts
    1,806
    Hi,
    You aren't on your own.

    Try this link and ifan1972's fix with your router.

    https://discussions.apple.com/thread...rt=30&tstart=0

  4. #4


    Member Since
    Jun 22, 2010
    Posts
    155
    Thanks pendlewitch. Although, I am not convinced he is having the same problem as me, I have replied to his post. I am not sure if my Access point can change the NAS settings, and if so, whether that would help in my situation.

    Afterall, I have no problems mirroring without stutter unless I expand a video window to full screen. Also, I can happily Airplay (without Mirroring) 1080 videos from my NAS.

    Online content streams perfectly at full screen with airplay (catchup or live feed) when mirroring is not used.

    And online content streams without issue with mirroring - as long as the video isn't expanded to full size. Only then do I get these terribly stutters which makes watching the video impossible to enjoy.

  5. #5


    Member Since
    Sep 10, 2011
    Posts
    1,806
    Hi,
    I see you've already started two different threads on Apple Support so you may get some more input. NAT is a different thing to NAS btw.

    If everything else is working then your ATV is probably good and wireless would appear to be good also, it may be a video codec/streaming server related annoyance or a conflict with regards to screen resolution and or frame rate settings between your iPad and the HDTV.

    You don't mention altering any settings on your TV. I would also check out your HDMI cable, it's integrity, version and as to whether it's sat in the sockets correctly. Try also switching the cable to one of the other HDMI inputs on your TV as some are temperamental with specific equipment.

  6. #6


    Member Since
    Jun 22, 2010
    Posts
    155
    ^^Thanks for your reply. Yes, I posted there as well as I was expecting very few responses. But I appreciate your help :O)

    Don't worry, I know the difference between my NAS and Network Address Translation. I was mentioning my NAS, as that is quite far away in our basement connected via Homeplugs and then Airplay via Wifi but we get perfect Airplay on recorded material. I guess I was using that as an example that my network works ok, and if there was a wifi issue, or any other issue, why it is only a problem on mirroring with full screen video and not normal mirroring or normal Airplay.

    It is a very good idea to test the HDMI cables and ports as you suggest. Because of what I mentioned above - that it only has the problem with mirroring and full screen, I don't think it would be that issue, but it has to be ruled out.

    I will try and make a video clip of the issue to show exactly what the problem is.

  7. #7


    Member Since
    Sep 10, 2011
    Posts
    1,806
    No worries mate.

    Definitely worth checking out. I had no end of trouble for about 3 weeks with ATV to HDTV connectivity until I sussed out a poorly seated cable. A 10 fix got me going.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Airplay lag/stuttering fix...but not ideal.
    By theymademedoit in forum Apple TV
    Replies: 17
    Last Post: 01-31-2014, 12:26 PM
  2. Using AirPlay Mirroring.
    By rabbitjetta in forum Apple TV
    Replies: 1
    Last Post: 05-31-2013, 02:21 AM
  3. Airplay Mirroring....
    By TopherDel in forum Apple Notebooks
    Replies: 1
    Last Post: 10-08-2012, 08:36 AM
  4. ipod touch airplay mirroring not working
    By Newtomachav4s in forum iPod Hardware and Accessories
    Replies: 1
    Last Post: 04-25-2012, 03:36 PM
  5. AirPlay mirroring for FaceTime appears to be coming in iOS 5
    By OneMoreThing... in forum Apple Rumors and Reports
    Replies: 3
    Last Post: 07-13-2011, 03:32 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •