Results 1 to 14 of 14
  1. #1


    Member Since
    May 15, 2012
    Posts
    3
    apple TV sound problem
    My Apple TV setup works fine, for a while. But usually after watching for an hour, more or less, of streaming content, the audio suddenly gets really bad - voices become totally muddled and unintelligible. People sound like aliens talking. (But I don't want you to think I'm hearing voices...)
    To fix this, I can back out of streaming mode, go to cable for a moment, then come back and it sounds okay. I am rarely able to watch an entire movie without doing this at least once.
    Help!

  2. #2


    Member Since
    Sep 10, 2011
    Posts
    1,806
    Hi,

    Can you view the signal strength indicator in the ATV settings ? How many bars are showing? Also can you tell us a bit more about your specs and set-up please ?

  3. #3


    Member Since
    May 15, 2012
    Posts
    3
    Connectivity does not seem to be the problem - 4 bars most of the time. I just replaced my router, but the problem was not solved.

  4. #4


    Member Since
    May 15, 2012
    Posts
    3
    Also - video is not affected at all when the audio goes wild.

  5. #5


    Member Since
    Sep 10, 2011
    Posts
    1,806
    Quote Originally Posted by lsherrill View Post
    Connectivity does not seem to be the problem - 4 bars most of the time. I just replaced my router, but the problem was not solved.
    There are 3 versions of ATV and I don't know how you have it connected to your TV or AV amp or what output of audio you have the ATV set to . Can you supply more info?

  6. #6


    Member Since
    Jun 29, 2012
    Posts
    1
    I have exactly the same problem. I turn the sound off for a minute and then the audio is fine. This occurs watching anything on my comp.

  7. #7


    Member Since
    Sep 09, 2012
    Posts
    3
    Same crackling problem
    Hi- did anyone ever figure out how to resolve this? I'm having the very same issue. Sometime about an hour after watching (or streaming music via air play) the sounds goes crazy and sounds alien-like. As soon as I back out and turn off, then back on it'll work fine for another hour.

    I've had my apple tv for over a year so I'm not sure Apple would cover it and switch it out.

    Thanks!

  8. #8

    Sur3Mac's Avatar
    Member Since
    Aug 03, 2009
    Location
    The Netherlands
    Posts
    1,563
    Specs:
    Late 2011 MBP 13" i5/16GB RAM,Early 2007 MB white 13", 2x TV 3rd Gen, ᣦ
    Does either of you own a Toshiba or Panasonic TV... cause these models are known to have these problems.
    Anyway, it seems to be an IOS issue, which Apple may resolve or not, but there is a workaround until that happens.

    -On ATV2, go to Settings
    -Go to Audio & Video
    -Go to Audio Output
    -Change it from Auto to 16-bit.
    -Feel free to change it back to Auto.

    If power to the ATV gets shut off, and the noises return... you will need to check these settings again.

    SM

  9. #9


    Member Since
    Sep 17, 2012
    Posts
    3
    Atv
    I have the same problem changed apple TV once and router 2 x Has anyone resolved this ?

  10. #10


    Member Since
    Sep 09, 2012
    Posts
    3
    Audio still messed up
    Quote Originally Posted by Sur3Mac View Post
    Does either of you own a Toshiba or Panasonic TV... cause these models are known to have these problems.
    Anyway, it seems to be an IOS issue, which Apple may resolve or not, but there is a workaround until that happens.

    -On ATV2, go to Settings
    -Go to Audio & Video
    -Go to Audio Output
    -Change it from Auto to 16-bit.
    -Feel free to change it back to Auto.

    If power to the ATV gets shut off, and the noises return... you will need to check these settings again.

    SM
    I own a Toshiba Regza. I tried the 16bit/auto switch and it'll fix it temporarily but about an hour later of watching tv, the funky sound comes back. So now I just seem to have the option of backing all the way out, switching the audio setting, or just turning it off and back on again.

    I'm surprised Apple hasn't pushed out a new update to help resolve this. Does anyone know if there's a general schedule for deployment of Apple TV updates?

    And SM, thanks for your response.

  11. #11


    Member Since
    Sep 17, 2012
    Posts
    3
    thanks
    will try this tonite

  12. #12


    Member Since
    Sep 17, 2012
    Posts
    3
    tried this over the weekend it solved it at first but then happened again an hour later and it came back again

  13. #13


    Member Since
    Sep 09, 2012
    Posts
    3
    Quote Originally Posted by thrasher View Post
    I own a Toshiba Regza. I tried the 16bit/auto switch and it'll fix it temporarily but about an hour later of watching tv, the funky sound comes back. So now I just seem to have the option of backing all the way out, switching the audio setting, or just turning it off and back on again.

    I'm surprised Apple hasn't pushed out a new update to help resolve this. Does anyone know if there's a general schedule for deployment of Apple TV updates?

    And SM, thanks for your response.
    UPDATE: I took it to Apple's Genius Bar and they confirmed the funky sounds so it's not my Toshiba Regza... Because it was over a year old they said they could swap it out for another ATV2 for $60.... I wasn't pumped but made the purchase since my alternative was resetting the audio ever hour or so.

    So I went home and watched a couple of 45 min-long shows and sure enough the sound came back halfway through the second episode. I have a genius appointment today to let them know that their $60 solution didn't work. So I'm going to ask for my $60 back or they need to give me a new ATV3 to try.. SOO frustrating.

  14. #14


    Member Since
    Feb 02, 2015
    Posts
    1
    did anyone solved funky sound in appleTV?
    Quote Originally Posted by thrasher View Post
    UPDATE: I took it to Apple's Genius Bar and they confirmed the funky sounds so it's not my Toshiba Regza... Because it was over a year old they said they could swap it out for another ATV2 for $60.... I wasn't pumped but made the purchase since my alternative was resetting the audio ever hour or so.

    So I went home and watched a couple of 45 min-long shows and sure enough the sound came back halfway through the second episode. I have a genius appointment today to let them know that their $60 solution didn't work. So I'm going to ask for my $60 back or they need to give me a new ATV3 to try.. SOO frustrating.

    I see its an old issue, but did anyone solved this?
    I am experiencing this kind of sounds after an hour of movie play. a new apple TV last version

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. apple tv sound
    By michael_k0 in forum Apple TV
    Replies: 0
    Last Post: 07-06-2013, 11:47 AM
  2. Sound problem with my Apple Tv
    By jtallariti in forum Other Hardware and Peripherals
    Replies: 1
    Last Post: 12-11-2012, 04:33 AM
  3. Apple Worthy Sound Effects?
    By Lukeelston in forum Music, Audio, and Podcasting
    Replies: 1
    Last Post: 08-18-2010, 05:44 AM
  4. Sound Problem
    By lakrportbob in forum Apple Desktops
    Replies: 2
    Last Post: 05-26-2009, 12:10 AM
  5. No Apple Startup Sound?!?!
    By sLux in forum Apple Notebooks
    Replies: 4
    Last Post: 08-14-2007, 10:11 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •