New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
Apple TV Discussion of Apple TV, the new revolution in watching television.

Streaming video to apple tv 2 is laggy


Post Reply New Thread Subscribe

 
Thread Tools
juiceit36

 
Member Since: Nov 19, 2011
Posts: 3
juiceit36 is on a distinguished road

juiceit36 is offline
I just bought an old dell tower on ebay that I converted to a media server with Plex media server. I am trying to store all my media on it and stream it to my apple tv 2. the only problem is, it is not streaming fast enough and the video (720p) keeps buffering every few seconds. Any ideas on how to speed up the connection? I've heard that a faster ethernet card helps, but I don't know anything about ethernet cards. I'd appreciate any suggestions.
QUOTE Thanks
Kevriano

 
Kevriano's Avatar
 
Member Since: Jul 02, 2006
Location: Crawley, England
Posts: 4,561
Kevriano is a name known to allKevriano is a name known to allKevriano is a name known to allKevriano is a name known to allKevriano is a name known to allKevriano is a name known to allKevriano is a name known to all
Mac Specs: 20" Intel iMac 2.4 Ghz/3G Ram/320HD, Snow Leopard. PBook G4, 1.5Ghz/1.5 Ram/250 HD, Leopard 10.5.6.

Kevriano is offline
How fast is your broadband connection? Streaming requires a pretty fast connection if you are using wi-fi in the equation somewhere.
Can you give us more details of the exact set-up, that is what connections etc.?

Try my custom Mac Forums Search Engine: Mac Forums Google Search

Please use the reputation system if you consider any help given useful (it's the little ✓/✘ on the left <---)

QUOTE Thanks
juiceit36

 
Member Since: Nov 19, 2011
Posts: 3
juiceit36 is on a distinguished road

juiceit36 is offline
Quote:
Originally Posted by Kevriano View Post
How fast is your broadband connection? Streaming requires a pretty fast connection if you are using wi-fi in the equation somewhere.
Can you give us more details of the exact set-up, that is what connections etc.?
I am using wifi for the apple tv. The dell tower is connected via ethernet to a netgear router (non wifi), which is connected to an airport express. the airport express is connected wirelessly to the apple tv. One of my roommates set up our cable/internet, so I don't know what our bandwidth is; probably around 2 mbps. I also have the plex server program installed on a macbook pro (2011 model), and that was streaming:

mbpro wifi to airport express-->wifi to apple tv. That streamed just fine, without any lagging or constant buffering.
QUOTE Thanks
Kevriano

 
Kevriano's Avatar
 
Member Since: Jul 02, 2006
Location: Crawley, England
Posts: 4,561
Kevriano is a name known to allKevriano is a name known to allKevriano is a name known to allKevriano is a name known to allKevriano is a name known to allKevriano is a name known to allKevriano is a name known to all
Mac Specs: 20" Intel iMac 2.4 Ghz/3G Ram/320HD, Snow Leopard. PBook G4, 1.5Ghz/1.5 Ram/250 HD, Leopard 10.5.6.

Kevriano is offline
Ok, that's not that fast a connection, but I suspect that the issue will actually be with PLEX. Good that it is (excellent in fact), it's quite a processor heavy programme, and it may be hindering the streaming if you are doing multiple tasks on the Macbook.
That said, if the express>ATV streaming was good, it could also be a lack of processing power in the Dell tower.

Try my custom Mac Forums Search Engine: Mac Forums Google Search

Please use the reputation system if you consider any help given useful (it's the little ✓/✘ on the left <---)

QUOTE Thanks
juiceit36

 
Member Since: Nov 19, 2011
Posts: 3
juiceit36 is on a distinguished road

juiceit36 is offline
Quote:
Originally Posted by Kevriano View Post
Ok, that's not that fast a connection, but I suspect that the issue will actually be with PLEX. Good that it is (excellent in fact), it's quite a processor heavy programme, and it may be hindering the streaming if you are doing multiple tasks on the Macbook.
That said, if the express>ATV streaming was good, it could also be a lack of processing power in the Dell tower.
You don't think it would be the network card in the dell tower? If it's the processor, I guess the dell tower would be worthless?
QUOTE Thanks
Kevriano

 
Kevriano's Avatar
 
Member Since: Jul 02, 2006
Location: Crawley, England
Posts: 4,561
Kevriano is a name known to allKevriano is a name known to allKevriano is a name known to allKevriano is a name known to allKevriano is a name known to allKevriano is a name known to allKevriano is a name known to all
Mac Specs: 20" Intel iMac 2.4 Ghz/3G Ram/320HD, Snow Leopard. PBook G4, 1.5Ghz/1.5 Ram/250 HD, Leopard 10.5.6.

Kevriano is offline
It could well be the card, yes. I'm not PC savvy as such, but if it's a slow card then it will of course restrict the connection.
Do you have any specs for it?

Try my custom Mac Forums Search Engine: Mac Forums Google Search

Please use the reputation system if you consider any help given useful (it's the little ✓/✘ on the left <---)

QUOTE Thanks
baggss

 
baggss's Avatar
 
Member Since: Oct 10, 2004
Location: Margaritaville
Posts: 10,309
baggss has a reputation beyond reputebaggss has a reputation beyond reputebaggss has a reputation beyond reputebaggss has a reputation beyond reputebaggss has a reputation beyond reputebaggss has a reputation beyond reputebaggss has a reputation beyond reputebaggss has a reputation beyond reputebaggss has a reputation beyond reputebaggss has a reputation beyond reputebaggss has a reputation beyond repute
Mac Specs: 27" 3.4 Ghz i7 iMac-13" C2D Macbook-OSX 18.8.2-64Gb iPad 2-32 Gb iPhone 5-ATV 2-14Tb of Storage

baggss is offline
I concur with Kevirano here. The Dell Tower is likely the culprit, either the Ethernet card or the CPU is simply lagging (quite possibly both). Your internet connection would only come into play if you were streaming something like Netflix and having an issue, everything you described is internal to your network in your home. Buying an old/cheap PC to run as a media server is not a recipe for success...


QUOTE Thanks
Lifeisabeach

 
Lifeisabeach's Avatar
 
Member Since: Sep 30, 2007
Location: Wilmington, NC
Posts: 7,001
Lifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond reputeLifeisabeach has a reputation beyond repute
Mac Specs: iMac i3 (mid-2010) + OS 10.9; TV 3; iPhone 5S; iPad 4

Lifeisabeach is offline
I assume you have jailbroken the ATV and are using Plex? The problem is almost certainly Plex, or at least a big part of it. Even on a Mac mini, I had constant issues with streaming video to Plex. It was more problematic with MKV files that had DTS audio (which has a MUCH higher bitrate than AC3), and videos that were encoded in something other than h.264. I believe it is going to be worse on an ATV 2 because ONLY MPEG-4 compliant videos can be played on it, if I'm not mistaken, so Plex has to transcode anything that isn't compliant on-the-fly.
QUOTE Thanks

Post Reply New Thread Subscribe


« Apple TV Price and feature details needed | AppleTV needs an iTunes application »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

All times are GMT -4. The time now is 04:25 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?