New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
Apple Notebooks Apple's notebook computers including MacBook Pro, MacBook, MacBook Air, PowerBook, and iBook.

Powerbook 17in 1.5GHz Display Feels Slow


Post Reply New Thread Subscribe

 
Thread Tools
BlinkyBill
Guest
 
Posts: n/a

Hi Guys,

This is my first post so take it easy on me.

I just took delivery of my new PB17in 1.5 GHz with 2 GB RAM, 128 MB Video, and 5400 RPM HDD. This spec should be the fastest portable mac going ... yes ....... ?

This is my first mac since owning a Mac Plus many many years ago, so I can only compare performance to my current laptop. Its specs are 1.5 GHz Centrino, 64 MB ATI Radeon 9600 Pro, 60 GB 4200 RPM Drive.

Now onto my question, the OSX display feels slower than WinXP, while I understand the MAC has all the eye-candy turned on so this will be adding to the slow down, but is this normal, can I turn off some of the visual effects to make the UI feel quicker?

So far I have tried in sysem prefs, turning on and off the smooth scrolling, changing display from millions to thousands etc etc. Scrolling in Safari, IE or Mozilla is nowhere near as smooth as the Cetrino Laptop, which is running a 1680x1050x32bit display, so it is pushing more pixels around than the mac. Other operations like moving windows around the display also feels "laggy" especially when running in millions of colours.

This is not a troll, I would just like some answers either way.

Other than this issue, living with a mac for 4 days has been very nice, I really like just dropping apps on to the applications folder and using move to trash to uninstall apps. Windows connectivity is also very nice, to my surprise my printer (Samsung SCX4216), DV-Cam and Digital Camera all connect and worked first go (Samsung did need drivers tho).

Looking forward to constructive feedback.
QUOTE Thanks
rman

 
rman's Avatar
 
Member Since: Dec 24, 2002
Location: Los Angeles, California
Posts: 12,591
rman has much to be proud ofrman has much to be proud ofrman has much to be proud ofrman has much to be proud ofrman has much to be proud ofrman has much to be proud ofrman has much to be proud ofrman has much to be proud ofrman has much to be proud ofrman has much to be proud of
Mac Specs: 2 x 3.0GHz Quad-Core, 6GB OS X 10.6.8 | 15in MacBook Pro 2.2GHz OS X 10.6.8 | 64GB iPad 2 WiFi

rman is offline
What version of the OS are you running?

Also is this slowness only with the web browsers?

What are running when you experience this?

Life isn't about waiting for the storm to pass, It's about learning to dance in the rain!
QUOTE Thanks
zakm52
Guest
 
Posts: n/a

I have a 15" powerbook 1 ghz, 512 mb ram. I had the same experience as you. My new mac felt slower than my windows machine. I went into the energy saver control panel and changed the "When on power supply" CPU setting to max performance. This made a huge difference in the speed of my mac. Now when plugged in it runs awesome. So I would try that. Also, before I did this I had the energy saver setting set to "automatic" This setting says it will set the cpu to max performance when plugged in but it I guess it really didn't. Hope it helps!
QUOTE Thanks
BlinkyBill
Guest
 
Posts: n/a

Quote:
Originally Posted by rman
What version of the OS are you running?

Also is this slowness only with the web browsers?

What are running when you experience this?
10.3.5, I just ran all the updates. The whole UI feels "slow", I guess it's more noticable in browers as I'm using a scroll wheel mouse and I'm used to very smooth scrolling in IE60. A good example is I set display prefs to millions, open up a largish window, say 2/3 of display when moving the window it doens't feel as responsive as it should be ?

BlinkyBill
QUOTE Thanks
BlinkyBill
Guest
 
Posts: n/a

Quote:
Originally Posted by zakm52
I have a 15" powerbook 1 ghz, 512 mb ram. I had the same experience as you. My new mac felt slower than my windows machine. I went into the energy saver control panel and changed the "When on power supply" CPU setting to max performance. This made a huge difference in the speed of my mac. Now when plugged in it runs awesome. So I would try that. Also, before I did this I had the energy saver setting set to "automatic" This setting says it will set the cpu to max performance when plugged in but it I guess it really didn't. Hope it helps!

Thanks for the tip, will check this out and report back. On the surface the PB with the ATI 128MB 9700 should have the goods over the ATI 64MB 9600 in the centrino laptop.
QUOTE Thanks
rman

 
rman's Avatar
 
Member Since: Dec 24, 2002
Location: Los Angeles, California
Posts: 12,591
rman has much to be proud ofrman has much to be proud ofrman has much to be proud ofrman has much to be proud ofrman has much to be proud ofrman has much to be proud ofrman has much to be proud ofrman has much to be proud ofrman has much to be proud ofrman has much to be proud of
Mac Specs: 2 x 3.0GHz Quad-Core, 6GB OS X 10.6.8 | 15in MacBook Pro 2.2GHz OS X 10.6.8 | 64GB iPad 2 WiFi

rman is offline
After you updated your system, did you repair permissions?

Life isn't about waiting for the storm to pass, It's about learning to dance in the rain!
QUOTE Thanks
BlinkyBill
Guest
 
Posts: n/a

Quote:
Originally Posted by rman
After you updated your system, did you repair permissions?
I didn't do this, still very new to OSX, I just googled repair permissions, and will do this later on tonight (UTC+1000 here) and report back any findings.

Thanks for the tips so far.

On a side note, I downloaded the Quake III demo linked from the Apple site 1.3.2 (i think), and it doesn't even run, crashes asking to report the bug to apple, anyone know if this needs to be patched for 10.3.5 ?
QUOTE Thanks
MoltenLava
Guest
 
Posts: n/a

The common UI function will feel slower on OS X than on Windows. I think it's the first thing the switcher notices, and probably the biggest barrier for to-be-switchers.

Windows desktop is rendered in 2D only. 2D framebuffer is blazingly fast these days, so any redraw will be instantaneous.

On OS X, the desktop is rendered in 3D. 3D hardware has come a long way in recent years, but it doesn't really match the speed of 2D framebuffer.

There are ways to disable some of 3D hardware rendering through hacking system files. I'm not sure whether it'll result in faster display with 3D disabled though. Apple claims Panther with Quartz Extreme is 30% faster than without. (Quartz Extreme is the rendering engine behind the desktop)

As you use Apple computer more often, you'll kinda get used to its speed. You might be frustrated at first, because you were used to quicker rendering on Windows. Just give it some times.
QUOTE Thanks
MoltenLava
Guest
 
Posts: n/a

BTW, don't waste time repairing permissions especially on a new machine. You might want to do it once a year or so.
QUOTE Thanks
BlinkyBill
Guest
 
Posts: n/a

Tried the suggestions. Looks like MoltenLavas comments are pretty much on the mark. The UI is *not* that slow, but just not as snappy as XP. I did go to the prefs and turn on max performance options on while plugged in and it does seems a little better than the automatic settings.

Thanks for the suggestions so far.
QUOTE Thanks
rman

 
rman's Avatar
 
Member Since: Dec 24, 2002
Location: Los Angeles, California
Posts: 12,591
rman has much to be proud ofrman has much to be proud ofrman has much to be proud ofrman has much to be proud ofrman has much to be proud ofrman has much to be proud ofrman has much to be proud ofrman has much to be proud ofrman has much to be proud ofrman has much to be proud of
Mac Specs: 2 x 3.0GHz Quad-Core, 6GB OS X 10.6.8 | 15in MacBook Pro 2.2GHz OS X 10.6.8 | 64GB iPad 2 WiFi

rman is offline
Quote:
Originally Posted by MoltenLava
BTW, don't waste time repairing permissions especially on a new machine. You might want to do it once a year or so.
Apple recommends that you repair permissions before and after you update or install software. It does resolve a lot of problem. It is not the magis bullet. Just like upgrading using the combo update is better than using the standard update image.

Life isn't about waiting for the storm to pass, It's about learning to dance in the rain!
QUOTE Thanks
rman

 
rman's Avatar
 
Member Since: Dec 24, 2002
Location: Los Angeles, California
Posts: 12,591
rman has much to be proud ofrman has much to be proud ofrman has much to be proud ofrman has much to be proud ofrman has much to be proud ofrman has much to be proud ofrman has much to be proud ofrman has much to be proud ofrman has much to be proud ofrman has much to be proud of
Mac Specs: 2 x 3.0GHz Quad-Core, 6GB OS X 10.6.8 | 15in MacBook Pro 2.2GHz OS X 10.6.8 | 64GB iPad 2 WiFi

rman is offline
Some people ask why must you repair file permissions so often?

Apple has tried to make very easy to install and update software. As you know not all software vendor follow the guide lines in order to install software.

The install application asks you for yur admin pass word. It might change the file permissions on certain files and directories/folders in order to install the given software. Upon completion of this task. In most cases the permissions of these files and/or directories/folders are not return to their original settings.

Because of the new settings, this can lead to various problems. So it is recommended to repair file permissions.

This is a simple explanation, of how things work. Since I don't want to explain unix file permissions and how they work.

Life isn't about waiting for the storm to pass, It's about learning to dance in the rain!
QUOTE Thanks
MoltenLava
Guest
 
Posts: n/a

rman, you are correct about why people should fix file permission once in a while. However, the symptom you will experience when file permission is left wrong on some system file would be obviously identifiable. i.e. You'll experience crashes. Some apps won't run. You'll notice something wrong right away. Especially in this case he just bought a new machine! The chance of any file left with wrong permission is virtually none.

I'm not saying never fix file permission. I'm saying, it's not something you should religiously do every Sunday morning.
QUOTE Thanks
BlinkyBill
Guest
 
Posts: n/a

Thanks for all the advice, in appreciation I have some Gmail invites to give out. So rman, zakm52 and MoltenLava if you would like the invites or if you already have Gmail and want me to send an invite to someone else just send me a PM.

Regards

BlinkyBill
QUOTE Thanks
MoltenLava
Guest
 
Posts: n/a

Thanks, but I got my gmail account already. You are very generous to give the invites away to people you seldom know.
QUOTE Thanks

Post Reply New Thread Subscribe


« Problems with the cd-rom drive. | powerbook 1.5ghz dvd-r speeds? »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
17" PowerBook on its way... schweb Apple Rumors and Reports 0 03-16-2003 10:14 AM

All times are GMT -4. The time now is 06:38 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?