I have a Lacie mobile drive (100 G) that I use on my mac. It was originally formatted on a pc, and so still has the dos fat format. I run paralells on my mac so I do view this drive with windows (running on the mac) at times. Here is the problem described from the mac side and the pc side:


When the drive is plugged in, I can't see it on the desktop or in finder. When I open Disk Utility, it sees the drive. I ran the verify disk with these results:

Verifying volume “KRIS PHOTOS”
** /dev/disk1s1
** Phase 1 - Read FAT
Unable to read FAT (Input/output error)
Error: The underlying task reported failure on exit

1 non HFS volume checked
Volume needs repair

I went to the mac store today and they tried to mount the drive on my computer and on another but it did not mount on either.

PC -

Drive is plugged in but does not show up in Windows Explorer. After some time, the auto-run starts with the flashlight going back and forth, but never opening anything. After some time again, the drive shows up in Windows Explorer. Double clicking on it, while still very slow, eventually says that the drive is not formatted and do I want to format it.