Results 1 to 6 of 6
  1. #1

    Member Since
    Apr 19, 2007
    powerbook g4 disk eject??
    i just put a dvd into my powerbook g4 for burning. the dvd was not recognized at all. now i don't know how to eject it. i was told to open firmware while rebooting and type eject disc but that didn't work. is there any other way to get this dvd out of my powerbook?? help! any info is apprecieated. thanks.

  2. #2

    D3v1L80Y's Avatar
    Member Since
    Feb 02, 2004
    Hold down your mouse button while booting up.
    That will eject it.
    Posting and YOU|Forum Community Guidelines|The Apple Product Cycle|Forum Courtesy

    mac: a waterproof raincoat made of rubberized fabric
    MAC: a data communication protocol sub-layer, also known as the Media Access Control
    Mac: a brand name which covers several lines of personal computers designed, developed, and marketed by Apple Inc.

  3. #3

    Member Since
    Apr 19, 2007
    i tried rebooting holding the mouse button and tried again holding the trackpad button and still nothing.

  4. #4

    Member Since
    Apr 19, 2007
    when i click on the dvd player a window pops up that says "a valid dvd drive could not be found" did my drive take a crap on me??

  5. #5

    Member Since
    Apr 19, 2007
    if i need a new a cd/dvd drive is there a better one than the factory one i should buy. i burn a ton of dvds so is there a faster one out there?? thanks a bunch.

  6. #6

    Member Since
    May 18, 2007
    I've had this a couple of times and found the only way to get it out is by tapping the underside of the machine (directly under where the cd is spinning). Try to eject again and then tap again. Keep doing this a few times and hopefully it'll come out. Can you here the disc whirr around?

    As for internal cd drives check out these from OWC I bought one just recently and have had no problems so far.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Tried Everything Can't Eject Install Disk
    By kcsummer in forum OS X - Operating System
    Replies: 5
    Last Post: 10-03-2012, 10:23 PM
  2. iMac disk eject
    By nedjinski in forum Apple Desktops
    Replies: 1
    Last Post: 11-22-2010, 03:39 PM
  3. Force eject disk
    By casho in forum OS X - Operating System
    Replies: 8
    Last Post: 05-13-2007, 11:31 AM
  4. cannot eject my disk
    By L0GiC in forum Apple Notebooks
    Replies: 7
    Last Post: 12-15-2006, 05:26 AM
  5. Powerbook will NOT eject disk.
    By Matthew_love84 in forum Apple Notebooks
    Replies: 7
    Last Post: 12-03-2006, 09:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts