Results 1 to 5 of 5
  1. #1


    Member Since
    Sep 14, 2004
    Location
    Milwaukee, WI
    Posts
    125
    Specs:
    Aluminum 12" 1.33ghz PowerBook G4 w/ 1280mb RAM, 80gb 5400rpm HD, 64mb vid RAM
    Help! Cruzer Micro 512mb Won't Mount!
    I have a SanDisk Cruzer Micro 512mb USB removable storage device and a PowerBook G4 1.33ghz w/ 512mb of ram and an 80gb hdd running OSX 10.4.5.
    For some reason, when I plug my USB drive into my PowerBook, the light on the USB drive comes on, but the drive doesn't mount (or at least I can't find any evidence of it anywhere). Its icon doesn't appear on the desktop or in finder.
    However, when I go to my System Profiler and click on USB, it shows that the device is connected (although it calls it a Cruzer Mini instead of Micro).
    If I plug the drive in through a USB 1.1 hub I have, then it works. This is obviously inconvenient because of the MUCH slower transfer speeds as well as the awkward necessity to bring a hub along when I want to use my drive.

    There doesn't seem to be any sort of update or firmware available.

    Any suggestions?

  2. #2


    Member Since
    Sep 14, 2004
    Location
    Milwaukee, WI
    Posts
    125
    Specs:
    Aluminum 12" 1.33ghz PowerBook G4 w/ 1280mb RAM, 80gb 5400rpm HD, 64mb vid RAM
    If I plug the drive in through a USB 1.1 hub I have, then it works. This is obviously inconvenient because of the MUCH slower transfer speeds as well as the awkward necessity to bring a hub along when I want to use my drive.
    I take that back... I just tried it and it doesn't seem to work that way now. I hadn't tried it that way since I upgraded to Tiger.

  3. #3

    PowerBookG4's Avatar
    Member Since
    Jan 08, 2005
    Location
    New Jersey
    Posts
    6,188
    Specs:
    Mac Pro 8x3.0ghz 12gb ram 8800GT , MBP 2.16 2GB Ram 17 inch.
    can you see it in disk utility?
    My Website
    Blog
    I love my hosting company!
    I was on the M-F honor roll for Febuary:2006

  4. #4


    Member Since
    Sep 14, 2004
    Location
    Milwaukee, WI
    Posts
    125
    Specs:
    Aluminum 12" 1.33ghz PowerBook G4 w/ 1280mb RAM, 80gb 5400rpm HD, 64mb vid RAM
    Not right now, but right now it's also not showing up in System Profiler like it was before.

  5. #5


    Member Since
    Feb 19, 2005
    Posts
    32
    Specs:
    PowerBook G4 17" 1.67 GHz 1.5 GB RAM 100GB 60GB 5G iPod
    Try going to Finder Preferences, then choose Computer for opening new Finder windows. Open a new window. It might show up in that window.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Script to mount volume (external drive or disk image) which won't mount..?
    By MaccIngs in forum OS X - Development and Darwin
    Replies: 2
    Last Post: 09-09-2011, 09:05 PM
  2. Really dumb question: micro sim slot won't open
    By SJP in forum iPhone Hardware and Accessories
    Replies: 5
    Last Post: 08-02-2010, 05:19 PM
  3. 1GB SanDisk Cruzer Micro on my MacBook question...
    By TheCustomer99 in forum Switcher Hangout
    Replies: 5
    Last Post: 02-22-2007, 08:27 AM
  4. Cruzer Micro 512mb: PowerBook Issues
    By xwonderboy85x in forum Other Hardware and Peripherals
    Replies: 0
    Last Post: 09-14-2006, 11:19 AM
  5. SanDisk Cruzer Micro
    By fasheezy in forum Apple Notebooks
    Replies: 4
    Last Post: 08-17-2006, 07:54 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •