Results 1 to 5 of 5
  1. #1


    Member Since
    Sep 12, 2013
    Posts
    4
    All browsers drop connection to server or receive no data, how do i fix this?
    When I go on any browser I have insalled on my macbook air almost 90% of the time it says for safari "server has unexpectedly dropped the connection" and for google chrome it says "no data received" or "sll connection error". I have cleared all cookies deleted history and cleared just about everything that can be cleared on both browsers. This did not help at all. Any way to fix this?

  2. #2

    mrplow's Avatar
    Member Since
    Oct 01, 2007
    Location
    UK
    Posts
    6,842
    Specs:
    27" iMac i7 (2011) 10.11, Mac Mini i5 (2014), iPhone6s, Apple Watch, iPad Air 2, New AppleTV (4?)
    The difficulty in resolving these kind of issues lies in finding the root cause of the connection loss. We need to determine the point of failure so if you could answer each of these questions it would be helpful:
    1. Which MacBook Air do you have?
    2. Which version of OSX?
    3. Is OSX up to date?
    4. Do you connect over wifi?
    5. Which wifi do you connect to? (hom/office/public coffee shop etc)
    6. Does it behave the same on different wifi networks?
    7. When you get the error in the browser(s) do you still have an internet connection? (e.g. can you still use an email application or check for software updates?)
    8. If connected by wifi does the wifi icon up by the clock show you're still connected to wifi at the time of the problem.
    9. Do you have other devices that can connect without issue at the same time you're having issues on the MBA?
    Not been around these parts for a while. Trying to change that . .

    Please use the reputation system if you think you've been helped - bottom left of this post

  3. #3


    Member Since
    Sep 12, 2013
    Posts
    4
    1. 13inch late 2010
    2. OS X 10.8.5
    3. Yes
    4. Yes
    5. home
    6. yes
    7. Yes
    8. yes.
    9. Yes my computer is the only one with the issue.

  4. #4

    mrplow's Avatar
    Member Since
    Oct 01, 2007
    Location
    UK
    Posts
    6,842
    Specs:
    27" iMac i7 (2011) 10.11, Mac Mini i5 (2014), iPhone6s, Apple Watch, iPad Air 2, New AppleTV (4?)
    It's very odd that everything else works but the browsers. Do you have any third party tools that that manage traffic/AV/anti-malware?

    Try resetting your network preferences.

    In Finder go to:
    yourMacHD/Library/Preferences/SystemConfiguration/preferences.plist

    Rename the preferences.plist to preferences.old

    Restart your Mac

    Attempt to reconnect to your network and try again

    If that doesn't work then do the same thing but for the whole SystemConfiguration folder that the above plist is in.
    Not been around these parts for a while. Trying to change that . .

    Please use the reputation system if you think you've been helped - bottom left of this post

  5. #5


    Member Since
    Jan 22, 2010
    Location
    Victoria, BC
    Posts
    20,911
    Specs:
    Mid-2012 MBP (16GB, 1TB HD), Monoprice 24-inch second monitor, iPhone 5s 32GB, iPad Air 2 64GB
    I think you're on to something there, MrPlow, with your question about traffic/anti-virus programs. Given that that Boltrag said he/she was having the same issue on other (presumably public) Wi-Fi networks, I think we can rule out the router -- and since the issue is browser-only, I think we can rule out the Mac hardware.

    Another option you didn't suggest but I would: Boltrag could set up a fresh new user (even just a "guest account" would do) and see if they have the same problem. I'm guessing the answer would be "no."

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Full internet connection, browsers wont load
    By dillonupgrade in forum Apple Notebooks
    Replies: 1
    Last Post: 04-29-2014, 07:24 PM
  2. Replies: 11
    Last Post: 03-27-2013, 05:22 AM
  3. Browsers can't establish a connection
    By mt1932 in forum OS X - Operating System
    Replies: 0
    Last Post: 11-27-2011, 11:31 PM
  4. Replies: 2
    Last Post: 04-25-2011, 05:46 PM
  5. How do I fix my internet browsers?
    By Pikachoo in forum OS X - Operating System
    Replies: 18
    Last Post: 09-05-2010, 03:37 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •