New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
Apple Notebooks Apple's notebook computers including MacBook Pro, MacBook, MacBook Air, PowerBook, and iBook.

MacBook 13" early 2009 Display Issue Help!


Post Reply New Thread Subscribe

 
Thread Tools
Newbie9113

 
Member Since: Sep 26, 2013
Posts: 1
Newbie9113 is on a distinguished road

Newbie9113 is offline
The charger charges my battery an you can here the laptop come on an the fans come on, but when I press the power button the white light on the front end comes on goes off then continues to beep in 5 second intervals until I turn it off. I tried using force restart the light just flutters comes on then continues the beeping noise. I looked on apple support forums an looked up what the beeping codes were an it says no ram install so I check that there's a 2 gig an 1 gig ram chips installed. I pulled one out an left the 2gig in an powered on display still is off an the beeping continues as usual.

What is going on? Us these repairable? Cause I run a home studio gfx editing video an vocal recording an I need my laptop working again.
QUOTE Thanks
chscag

 
chscag's Avatar
 
Member Since: Jan 23, 2008
Location: Fort Worth, Texas
Posts: 40,880
chscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond repute
Mac Specs: 27" iMac i5, 3.2 GHz, iPad 3, iPhone 5c, 3 iPods, Yosemite

chscag is offline
Try installing brand new memory modules. Use the same configuration in both rams slots; in other words, both modules as 2 GB each. If that doesn't work, your logic board may have died - which will sometimes also result in beeping.

Something else you might want to try... do you have your original install DVD? If you do, try booting the machine with it. That will bypass the hard drive.
QUOTE Thanks

Post Reply New Thread Subscribe


« Macbook says 'not charging' but it is, just super slowly | Transferring data off MacBook Pro for non-apple computer(s) »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
MacBook Pro 13" KVM display issue wifler Apple Notebooks 0 01-26-2013 01:11 PM
13" MacBook display - no backlight cwa107 Apple Notebooks 7 12-30-2011 11:53 PM
Macbook Pro 13" (early 2011) Freezing (+ Crucial C300) kkraemer Apple Notebooks 2 05-13-2011 12:05 PM
Macbook Display Issue (not a normal problem) cbower Apple Notebooks 5 04-01-2010 06:32 PM
MacBook impressions - trip to store kaidomac Schweb's Lounge 24 10-14-2007 02:45 PM

All times are GMT -4. The time now is 03:47 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?