My Mac is issued by my school, so I'd recently took it in for tune up for the next school session. Upon getting it back, I found that I couldn't access my user on the computer. I figured that my password was reset during the tune up process, so I logged in as an admin to change it. When I got to the account in Users & Groups in System Preferences, the option to change the account password wasn't there, so I checked "reset password with apple id" and logged out to try it. I entered the wrong password 3 times and then reset my password, but when I tried to log in that didn't work for some reason. I checked back with my school to see if there was anything they could do, and they said I could come in on Monday. I decided I'd keep trying things out myself. I'd tried reseting the password in other various ways (at startup by pressing command + R then going to terminal...etc) but none of the methods worked, so I rebooted the Mac and tried getting in using this method (second one). When I had entered everything in I got this message: Launch msg(): socket not connected
What does it mean?

(I have a Mac Air running Lion)