New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
Apple Notebooks Apple's notebook computers including MacBook Pro, MacBook, MacBook Air, PowerBook, and iBook.

Serious MacBook Pro HD repair issues


Post Reply New Thread Subscribe

 
Thread Tools
Maconfused

 
Member Since: Aug 08, 2013
Posts: 4
Maconfused is on a distinguished road

Maconfused is offline
Hi all. Please excuse any potential typos-- I'm typing this all from an iPhone, since my MacBook Pro is giving me serious trouble. This story is a long one-- sorry for that, too.

In June, while on vacation, my mid-2009 MBP started switching off on me suddenly. I would be on it and it would act as if someone did a hard shut down. When I would try to power it back up, it would power down again, each time taking less time after the initial power up (to the point that the screen would 't even light up). I chalked it up to the humidity in the area, and when I returned home, the issue stopped.

A week ago, my MBP suddenly locked up completely with the pinwheel icon. I did a hard shut down, and when I booted it up, it got stuck on the gray screen with the apple logo and spinning I on. I booted into DU and found I had HD errors that couldn't be repaired (verbose mode showed me an "I/O error"). Somehow, even though the drive wasn't mounted, I managed to get an image of the failing drive to my external HD.

I replaced the HD with a new one from WD. DU said the new drive was good. I popped in the o10.5 OS disk that came with the MBP to reinstall the OS. First time around, it said the OS couldn't be installed and the disk might be damaged (HD or DVD?). Tried again-- it installed. The MBP was extremely catchy, though-- the slightest action caused the pinwheel to appear for 5-10 seconds (clicking the apple icon, hovering over the dock, etc). Maybe it's the old OS-- I put in my 10.6 DVD to update. This installation took forever-- it got hung up at "20 min left" and took another ~12 hours to install. Still extremely catchy.

At the advice of a coworker, I reformatted the drive to redo the OS installation. Managed to get 10.5 up on the first try. The computer was still catchy-- not as bad as before, but still catchy. I tried to update to 10.6. The first time failed, and it told me to restart and try again. I'm doing that now, and like the first go around it's hung up at ~20 min left.

As a side note, after putting in the new HD, the "normal noises" my DVD drive makes when it first gets a disc sounds a bit different. I also worry that there is a bigger issue at play. I ran the extended hardware test, and it said everything looked good.

What's happened to my MBP? Do I have of salvaging it without shelling out a ton of money, or am I in the market for a new MBP?
QUOTE Thanks
harryb2448

 
harryb2448's Avatar
 
Member Since: Nov 28, 2007
Location: Nambucca Heads Australia
Posts: 18,146
harryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond repute
Mac Specs: iMac i5 2.7GHz, 16GB memory, OS 10.10.1

harryb2448 is offline
G'day and welcome to the forums

When replacing the hard drive in a MBP always replace the SATA cable as they become brittle and crack displaying the symptoms you describe.

Hang on to those original install discs like grim death! Using OS X.7 or later make a bootable USB thumb drive before running Installer!
QUOTE Thanks
Maconfused

 
Member Since: Aug 08, 2013
Posts: 4
Maconfused is on a distinguished road

Maconfused is offline
Could you please elaborate? Which symptoms are indicative of the SATA cable? I ask only because I've already sunk money into a new HD, and I don't want to keep purchasing items if there's a fatal issue with the computer (in which case my purchases would be fruitless).

Does this also mean that the old HD may not, in fact, have been corrupt/damaged? That would be wonderful, because I do not have a back up of that disk-- the best I have is the image I managed to get onto my external HD, but that image refuses to mount.
QUOTE Thanks
bobtomay

 
bobtomay's Avatar
 
Member Since: Dec 22, 2006
Location: Texas, where else?
Posts: 25,136
bobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond repute
Mac Specs: 15" MBP 2.33 C2D 256 4GB, MBA 13" i7 1.8, MB 2.0 2GB, Nano 4th, 3GS, iPad 1

bobtomay is offline
an "I/O error". Would be a little surprised on an '09 model, but that def could be a cable problem along with "all" the symptoms you have described trying to install the OS could by I/O issues rather than drive issues.

I'd go back into the case, unplug the hard drive cable then plug it back in and test before I ordered another one.

And if you have the retail disk of 10.6, there is no reason to be installing 10.5 first.

I cannot be held responsible for the things that come out of my mouth.
In the Windows world, most everything folks don't understand is called a virus.
QUOTE Thanks
techiesteve

 
Member Since: Apr 24, 2009
Location: UK
Posts: 488
techiesteve is a glorious beacon of lighttechiesteve is a glorious beacon of lighttechiesteve is a glorious beacon of lighttechiesteve is a glorious beacon of lighttechiesteve is a glorious beacon of lighttechiesteve is a glorious beacon of light
Mac Specs: MacBook Pro 15" 2.8 GHz, MacBook 2.16 GHz, iPhone 5

techiesteve is offline
Whenever I detect a failed hard drive in a unibody MacBook Pro I always pull it, drop it into a drive caddy and retest. Most of the time the hard drive has failed, but I find quite a few times the drive is fine and the issue is caused by the flex cable. The cable isn't expensive.

The only logical reason to install 10.5 first is if you don't have a newer version of iLife as supplied with 10.5, or haven't previously purchased updated iLife apps you need via the app store. There's no iLife on a retail Snow Leopard.

Steve Bell
UK
QUOTE Thanks
dtravis7

 
dtravis7's Avatar
 
Member Since: Jan 04, 2005
Location: Modesto, Ca.
Posts: 27,860
dtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond repute
Mac Specs: iMac 2.4 C2D 10.10.1, iMac 2.16 C2d 10.6.8, Macbook2007 10.8.4, Mac Mini 10.8.4, iPhone 3GS Note 8!!

dtravis7 is offline
If it was a Macbook I would not think it's a cable issue as the drive plugs into a bay, but on the MBP's that Flex Cable has been proven to over time mess up and flexing it installing a new drive will just make it worse. I think it's worth a shot.

Do you have an external 2.5" USB hard drive case? That would for sure prove what is the issue. Put in both the new and the old hard drive and test them, one at a time of course!
QUOTE Thanks
Maconfused

 
Member Since: Aug 08, 2013
Posts: 4
Maconfused is on a distinguished road

Maconfused is offline
The plot thickens. I didn't have access to an external hard drive case, but I did have access to a friend's MacBook Pro. I swapped my supposedly defective (old) hard drive into his MBP and tried to boot up. Lo and behold, my desktop appeared! I took the opportunity to scavenge my most important files onto an external hard drive; I didn't want to try a full back up, since I'd once gotten my old HD to boot on my own MBP, but trying to back up caused the system to lock up.

Afterward, I turned the MBP and on again. This time, the HD would not boot. A repetitive clicking noise could be heard, similar to what I heard on my own system after problems started developing. I managed to get the system into the disk utility after a reboot, and DU strangely said the HD appeared to be okay (despite not booting up before or after the scan). My friend's own HD worked just fine in his MBP after we swapped back.

I tried installing the OS on my external HD and have had absolutely no problems with that. This gives me hope, since I wouldn't have expected that to work if there were issues with the logic board.

Given this info, how certain are we that the SATA cable is the culprit? I can't help but think that my old internal HD is at least somewhat damaged, since it presented issues even in my friend's MBP. Am I correct in thinking that, if the logic board were the culprit, I wouldn't be able to boot up even from an external HD?
QUOTE Thanks
dtravis7

 
dtravis7's Avatar
 
Member Since: Jan 04, 2005
Location: Modesto, Ca.
Posts: 27,860
dtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond repute
Mac Specs: iMac 2.4 C2D 10.10.1, iMac 2.16 C2d 10.6.8, Macbook2007 10.8.4, Mac Mini 10.8.4, iPhone 3GS Note 8!!

dtravis7 is offline
Well the clicking drive even on your friends MBP shows it's dying. I am glad you got it to boot once so you could get those files.

As far as the Flex Cable since so many have had issues, that would be my first thing to replace. If it's not the Flex Cable then that leaves the Internal SATA controller. I am almost willing to bet it's that cable though.

Keep us posted.
QUOTE Thanks
Maconfused

 
Member Since: Aug 08, 2013
Posts: 4
Maconfused is on a distinguished road

Maconfused is offline
Pardon my ignorance, but I've been searching around online for replacement cables, and I'm a little confused. Most of the cables I've found online are for 13" MBPs, while I have a 15". Would a cable for a 13" MBP work, or would it be too short for a 15" MBP?

I found one cable for a 15" MBP on Amazon, but I'm also worried about compatibility with my new HD, and I'm not familiar with what makes a cable and HD compatible. This is the HD that I bought. Will these two play nicely with one another?

Thanks for all your help, everybody!
QUOTE Thanks
pigoo3

 
pigoo3's Avatar
 
Member Since: May 20, 2008
Location: U.S.
Posts: 27,864
pigoo3 has a reputation beyond reputepigoo3 has a reputation beyond reputepigoo3 has a reputation beyond reputepigoo3 has a reputation beyond reputepigoo3 has a reputation beyond reputepigoo3 has a reputation beyond reputepigoo3 has a reputation beyond reputepigoo3 has a reputation beyond reputepigoo3 has a reputation beyond reputepigoo3 has a reputation beyond reputepigoo3 has a reputation beyond repute
Mac Specs: 13" MB 2.4ghz, 2gig ram, OS 10.7.5

pigoo3 is offline
Try Powerbookmedic.com. They have a pretty good system for identifying parts. Just use their system for identifying your computer...then they will give a list of parts for it.

If you're really really interested if the cable you need is the same for a 13" and 15" MacBook Pro's like yours...you could also look up the cable for the 13" MacBook Pro. Then compare part numbers for both computers. If the part number is the same for both computers...then it's the same cable used for both.

- Nick

- Too many "beachballs", read this: Beachballs
- Computer seems slower than it used to? Read this for some slow computer tips: Speedup
- Almost full hard drive? Some solutions. Out of Space
- Apple Battery Info. Battery
QUOTE Thanks
harryb2448

 
harryb2448's Avatar
 
Member Since: Nov 28, 2007
Location: Nambucca Heads Australia
Posts: 18,146
harryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond reputeharryb2448 has a reputation beyond repute
Mac Specs: iMac i5 2.7GHz, 16GB memory, OS 10.10.1

harryb2448 is offline
If it is a 15" MBP Unibody try this:-

MacBook Pro Unibody 15'' A1286 Hard Drive HDD Cable 821 0812 A SATA Interface | eBay

And for sale in the US:-

http://www.ebay.com/itm/Hard-Drive-D...-/380695823091

Hang on to those original install discs like grim death! Using OS X.7 or later make a bootable USB thumb drive before running Installer!
QUOTE Thanks

Post Reply New Thread Subscribe


« Macbook Pro 13 inch Early 2011 Screen Issues | Burn mark on macbook pro? »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
Various issues with my Macbook Pro HELP! nielspet OS X - Operating System 1 01-26-2012 09:48 AM
MacBook Pro has 'lost' Mac Pro [wireless network] waltonic Internet, Networking, and Wireless 0 09-22-2009 02:17 PM

All times are GMT -4. The time now is 05:51 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?