Mac Forums

Mac Forums (http://www.mac-forums.com/forums/)
-   Apple Notebooks (http://www.mac-forums.com/forums/apple-notebooks/)
-   -   iBook G4 1.2 won't see hard drive (http://www.mac-forums.com/forums/apple-notebooks/297853-ibook-g4-1-2-wont-see-hard-drive.html)

TRI 04-11-2013 07:12 PM

iBook G4 1.2 won't see hard drive
 
I just got a iBook G4 1.2 GHz for $25.

It won't start, you just get the folder with the question mark.

Ran it in Target Mode and ran a Firewire cable to a Powerbook. No Hard Disk icon appears on the Powerbook desktop.

Held down Alt while starting the iBook, the screen that came up where you choose the OS didn't have the iBook hard drive icon.

It will start up from the Tiger instal disk and from there I've run Disk Utility and there's no hard drive icon.

Opened iBook and hard drive wasn't plugged in pc board :) Swapped a known-to-be-good hard drive into the iBook but symptoms remain the same.

Put hard drive from iBook in external case and it was recogized and checked out fine on my desktop Quicksliver.

Any comments appreciated! :)

It would look like the cable running from the board could be bad... but I hate to replace that if it's the motherboard.

chscag 04-11-2013 07:30 PM

Quote:

It would look like the cable running from the board could be bad... but I hate to replace that if it's the motherboard.
This is a common problem with the older iBooks and even some of the older model MacBook and MacBook Pro models. Go ahead and change the cable, the most you'll be out is around $20 if it doesn't work. Check for the cable at Mac Repair - Mac Parts and Service for Apple Macbook, iPhone, iPad. I doubt the logic board is bad, but you can never tell. ;)

TRI 04-11-2013 07:31 PM

BTW, did do Pram Reset on iBook and I thought for sure that the unplugged hard drive was the culprit but it wasn't it.

TRI 04-11-2013 07:39 PM

Thanks chscag, I'll probably spring for the new cable.

I was going through my other Macs to see if there was another whose hard drive cable used the same pc board connector as the iBook G4 1.2 GHz, just to hook it up and see if that was it, but they were all different.

I haven't checked the Powerbook 17" 1.5GHz but the pick looks similar... Im a little nervous that it could be wired differently. If you guys hear a loud boom you'll know it was me. :)

techiesteve 04-12-2013 01:45 AM

The hard drive flex cables in the iBooks are specific to that range. They all used a flex cable other than the 12" 1.33 and 1.42 GHz.

TRI 04-12-2013 02:01 AM

Thanks.

I just found one on eBay for $3 w/free shipping.

I put a working Powerbook in Target Mode and attached it to the broken iBook via Firewire and used the Tiger install disk to get the iBook to boot from the Powerbook's hard drive. In that combo the iBook worked fine.

chscag 04-12-2013 01:58 PM

Quote:

In that combo the iBook worked fine.
That proves the logic board is OK. Let us know when you get the new cable installed.

TRI 04-12-2013 02:08 PM

Quote:

Originally Posted by chscag (Post 1509477)
That proves the logic board is OK. Let us know when you get the new cable installed.

I will post the results, thanks.

I didn't know that these machines can boot from an OS on an external drive (or computer in Target Mode) via Firewire. That seems to be a great basic troubleshooting maneuver! I sent away for a $13 hard drive enclosure that has Firewire on it, the one that I had was only USB. The new enclosure will hold a test drive with OS X on it.

dtravis7 04-12-2013 04:20 PM

I will back others here. It really sounds like the cable from the drive to the board. Do let us know what happens with new cable.

TRI 04-12-2013 04:29 PM

Will do Dennis, thanks.

This $25 specimen looks like it was stripped for resale... no airport, no plug-in RAM and unplugged small hard drive. The hard drive cable connector, where it was connected to the hard drive, was a bit deformed like it may have been pulled off at an angle, so that may well be it.

Kinda fun tho.

TRI 04-19-2013 02:18 AM

Worked!
 
With the replacement cable it started up and runs fine... been using it for several hours. So nice when things work. :^)

I put in a larger hard drive, airport card and RAM from old laptops I had.

If this had not worked I was thinking of MacGyvering the external Firewire drive inside the iBook in the optical drive space.

Thanks very much to everybody for your help.

dtravis7 04-19-2013 02:22 AM

Glad to hear it was the cable and you got it all working. Great news for sure. Thanks for coming back and letting us know!

TRI 04-19-2013 02:29 AM

Thanks, I'm stoked that it worked. :)


All times are GMT -4. The time now is 08:11 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.