Mac Forums

Mac Forums (http://www.mac-forums.com/forums/)
-   Apple Notebooks (http://www.mac-forums.com/forums/apple-notebooks/)
-   -   Seriously sick Powerbook G4 12 inch 1.33 Ghz (http://www.mac-forums.com/forums/apple-notebooks/297631-seriously-sick-powerbook-g4-12-inch-1-33-ghz.html)

actual561 04-06-2013 09:28 PM

Seriously sick Powerbook G4 12 inch 1.33 Ghz
 
Hello fellow Mac Brethren,

I have an Apple Laptop with what appears to be multiple symptoms. It is a PowerBook G4 aluminum body, 12" monitor, 1.33 GHz, 512 Mb cache, 60 GB HD, no built in airport card.

A bit of history first. I am fairly experienced Mac user. I have been using and repairing macs since the Mac II around 1985.

The device in question originally belonged to my niece at college. I think she dropped or threw it down the stairs in a fit. When she handed it off to me, the CD no longer worked and I had a non-apple service replace it. CD was always sticky afterwards due to case damage from the drop. After I used it for a short time, I handed it over to another niece. She used it several years until a cd/dvd became stuck in the drive. After many attempts to eject the cd it developed boot problems. Upon giving it back to me, I managed to remove the stuck CD.

At first machine would not boot. I tried all types of resets and commands. Finally found that holding Shift-Control down while simultaneously holding Power would usually boot the system. These buttons needed to be held for some portion of the startup sequence. I am also at a loss as to what this sequence represents. I can not find it listed on the web anywhere.

The boot process takes the following steps: No Boot sound heard, instead a buzzing sound that is like a representation of ripping paper or something. Screen will be black until sound stops (about 10 sec). Sound stops and screen goes blue. Same sound again plays until screen changes to universe background from OS10.5 Leopard. Machine then thinks some more and then dock and drive icons show up. Machine is now running. Immediately I get a screen indication that clock is set to 1969 and should be reset

Everything now basically works, but it makes no sound. Checking the sound prefs indicates no input or output devices available. no internal speakers etc. Have heard this could be a Leopard Quicktime related issue.

I have fully updated the machine to OS 10.5.8 , which seems to run fine. The battery charges fully, but I have to often reset the clock. Research suggests that the battery electronics may be faulty because this model Powerbook is not supposed to have and internal clock battery. I also do not seem to be able to boot in Target mode to work on the hard drive.

My theories as to the problems are:
1. the battery has some bad circuitry. My niece may have used a 45 W charger from another mac laptop interchangeably. Replacement may be needed. Seems to operate the same on charger with battery removed though.
2. The system may be faulty. I have run Tech Tool Deluxe, Disk Warrior and Disk utility to verify and repair permissions, to find any types of problems they may show. I think the drive should be wiped completely and reinstall the system
3. Can't rule out that something in the optical drive isn't still holding onto the system and is effecting its normal operation. Could I just remove it and buy a cheap external. I don't know if I need to do any type of jumper settings or termination for an ATA bus

The final complication is that I have a new iMac as my main machine. It's great, but apple took out the Firewire Port and the new external DVD drive is not self powered, so it will not help with booting the device. The Powerbook USB ports will not power it.

This could be just a fools chase for such an old machine, but I have a good friend that could use it and I love the challenge.

Any and all advice, Information or opinions are welcome. Just hate to trash an old friend. I think it could still be useful a bit longer if not too expensive to fix.

Thanks to all

pigoo3 04-06-2013 10:15 PM

Not necessary to double post.

Thanks

techiesteve 04-07-2013 04:20 AM

Quote:

Originally Posted by actual561 (Post 1508310)
3. Can't rule out that something in the optical drive isn't still holding onto the system and is effecting its normal operation. Could I just remove it and buy a cheap external. I don't know if I need to do any type of jumper settings or termination for an ATA bus

Removing or replacing the optical drive in a Powerbook G4 12" isn't an easy option, all due to the rear fixing being under the logic board. Thankfully modern Apple portables are now built for easy access.

An easy option to determine if you have an OS or hardware problem is to boot from an external FW drive containing a PPC version of 10.4.11 or 10.5.8. My gut feeling is you have a hardware problem, due to the way it's previously been treated and simple old age.


All times are GMT -4. The time now is 05:44 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.