Hi there,
thought it was time I had a large 2nd hard drive so I purchsed a caddy to replace the superdrive, and an Hitachi 1TB 2.5 sata III. hard disk.

Thru bootcamp, I booted to windows on first boot after intsall, as most of the files I wanted to put on this disk were on NTFS. I formatted the new drive to FAT as I wanted both OS's to be able to access this new drive freely. Put all my files on, restarted to Mac OS

Mac OS said it needed to initialise the new disk, so i clicked OK

The disk drive dissappeared? I went into disk utility and went to Format the drive again. The disk utility froze. The hard disk dissappeared from the utility window?

I restarted and it appeared back. When i tried to format (MAC OS journalled this time) it buzzed away for 10 mins then said it "couldnt write to the last boot sector".

The HD is an Hitachi with GPT. I have tried several utilities from Hitachi,(Disk fitness checks the drive and says its OK and HGST align tool just sits there for hours and does nothing. HELP please anyone?