New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
Apple Notebooks Apple's notebook computers including MacBook Pro, MacBook, MacBook Air, PowerBook, and iBook.

Macbook Pro weird screen patterns and unable to boot


Post Reply New Thread Subscribe

 
Thread Tools
benbrook

 
Member Since: Jul 22, 2012
Posts: 1
benbrook is on a distinguished road

benbrook is offline
My 15" 2.66GHz Macbook Pro (Mid-2010) (MC373LL/A) ran out of battery today, and once I plugged it back in and booted I got these weird patterns on the Hi-Res display. After a long time, the loading symbol froze. I have restarted it several times now and the odd lines come back in different colours (red, blue and green) and the loading symbol continues to freeze. I cannot get past this screen.

I can't take it into the store for some time as I am currently abroad. Any ideas on how I might fix this? And do you think my files are still safe?

Thank you

QUOTE Thanks
techiesteve

 
Member Since: Apr 24, 2009
Location: UK
Posts: 479
techiesteve is a glorious beacon of lighttechiesteve is a glorious beacon of lighttechiesteve is a glorious beacon of lighttechiesteve is a glorious beacon of lighttechiesteve is a glorious beacon of lighttechiesteve is a glorious beacon of light
Mac Specs: MacBook Pro 15" 2.8 GHz, MacBook 2.16 GHz, iPhone 5

techiesteve is offline
As it's freezing it's unlikely to be the display, that leaves the logic board as the most likely culprit. Your HD data is most likely safe.

Steve Bell
UK
QUOTE Thanks

Post Reply New Thread Subscribe


« Upgrade Air Flash Memory | MacBook Pro - different USB ports? »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

All times are GMT -4. The time now is 12:52 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?