Results 1 to 4 of 4
  1. #1

    Member Since
    Jul 12, 2012
    Optibay HDD project gone wrong
    Hello Everybody,

    The short of it is this - I have a mid-2009 15" MBP running Lion with a new SSD in the main SATA bay, and my old HDD, reformatted, installed via an Optibay kit in the secondary SATA bay. The system is functional; however, the secondary drive is not writable. It seemingly mounts just fine, it shows up in Finder, Disk Util lists it valid (and writable), but I simply cannot write anything to that device. Tried via bash (vi, touch, echo with redirection, etc) and also by copying files via Finder. No dice.

    The long of it is this - the original configuration had the following:
    * 500GB HDD in main SATA bay
    * Super Drive (Optical) in secondary SATA bay

    I bought a fresh SSD and mounted it via a SATA dock (Thermaltake, BlacX). I then went through the following steps:
    * While in the SATA dock, formatted the disk as Mac OS Extended (Journaled)
    * I used the Data Migration Assistant to dupe the HDD onto the SSD.
    * Shut down the system, popped the back, and swapped in the SSD for the HDD in the main SATA bay
    * Booted, saw that things were working as they previously were (phew!)
    * Mounted the old HDD in the SATA dock, reformatted (Erase), as a single partition (GUID scheme), Mac OS Extended (Journaled)
    * Installed the HDD into the Optibay enclosure
    * Popped open the back, swapped out the SuperDrive, installed the Optibay kit.
    * Booted, saw that the secondary disk was listed in Finder under Devices.
    * Selected the secondary drive in Finder and attempted to create a new folder. Was rebuffed with error message: "The operation can't be completed. An unexpected error occorred(error code -50)"
    * from bash (iTerm) attempted to create a file on the secondary device: "touch foo" wich resulted in "touch: foo: Invalid argument"
    * I should point out that the filesystem ownership looks to be okay: the directory structure is owned by me with 775 octal permission

    I know that I'm providing a mere sliver of all the information that'll likely be useful (diskutil output, syslogs, etc) but instead of going overboard I thought that the above information should at least get the ball rolling. So...does anyone have any thoughts as to what the problem may be?

    Thanks for reading, and please let me know what other information would be useful here.

  2. #2

    Member Since
    Jul 12, 2012
    Have done, via Disk Utility. Upon the first try it spins for a while, indicating it's trying to unmount, and finally gives this error:

    Partition failed with the error: Couldn't unmount disk

    Which is kinda weird, given the following:
    $ mount
    /dev/disk0s2 on / (hfs, local, journaled)
    devfs on /dev (devfs, local, nobrowse)
    /dev/disk1s2 on /Volumes/MacData (hfs, local, journaled)
    map -hosts on /net (autofs, nosuid, automounted, nobrowse)
    map auto_home on /home (autofs, automounted, nobrowse)
    localhost:/CG2Ry-LnER6PvWlAYBIP-9 on /Volumes/MobileBackups (mtmfs, nosuid, read-only, nobrowse)

    $ lsof | grep MacData
    Finder 247 lala.fishies 24r DIR 14,3 68 125 /Volumes/MacData/.Trashes/502

    So then I go into Finder, and Eject the device. Eventually I'm presented with the option to Force Eject, which I do. Now, back in Disk Utility, I try adding a new partition once again. Like before it spins for a while saying it's trying to unmount. After some time it does, but then gives me this error message:

    Partition failed with the error: Unable to write to the last block of the device.

    So, sadly, simply repartitioning doesn't do the trick. Thanks for responding, I appreciate the thought.

  3. #3

    Member Since
    Jul 12, 2012
    All that said, I have seen other mentions of my particular drive in other posts having similar issues, though none of those threads provide any clear course of action. Here is the full info for my drive:

  4. #4

    Member Since
    Nov 01, 2012
    Quote Originally Posted by lalafishies View Post
    All that said, I have seen other mentions of my particular drive in other posts having similar issues, though none of those threads provide any clear course of action. Here is the full info for my drive:
    Just my 2 cents but i was looking at an optibay myself noticed this thread thought I would say there are many ways to format your drives in your MBP. Forgive me if I overlooked but have you tried partitioning with the Mac OS Install disc loaded via USB? Seems like its considered the ultimate method of formatting. Also I think if you hold the control ^ down while clicking the format "OK" to proceed tab while you are in the OS it formats just about anything? Hope you managed to fix your mbp. cheers

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Optibay for sad or hdd?
    By LEVENDIZ in forum Apple Notebooks
    Replies: 2
    Last Post: 07-16-2012, 10:05 AM
  2. SSD + HDD in optibay boot issue
    By stevegull in forum Apple Notebooks
    Replies: 5
    Last Post: 01-19-2012, 02:17 PM
  3. iDVD burns wrong project
    By terryann in forum OS X - Apps and Games
    Replies: 0
    Last Post: 12-29-2008, 06:32 PM
  4. Project Planning and Project Management Software
    By dslynch in forum OS X - Apps and Games
    Replies: 3
    Last Post: 12-16-2008, 03:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts