Results 1 to 9 of 9
  1. #1


    Member Since
    Feb 21, 2012
    Posts
    2
    Unhappy Macbook says 'not charging' but it is, just super slowly
    So I've had my 13" white macbook for about 3-4 years now and for some reason the battery will charge when it's plugged in, but the icon says "not charging", and the battery takes FOREVER to charge.
    I've gotten a new magsafe, gotten a new battery, and still the same problem.

    Any suggestions?

  2. #2

    chscag's Avatar
    Member Since
    Jan 23, 2008
    Location
    Fort Worth, Texas
    Posts
    47,135
    Specs:
    27" iMac i5, 3.2 GHz, iPad 3, iPhone 5c, iPhone 6+, 3 iPods, El Capitan
    Did you replace the original MagSafe Adapter charger with an original Apple one or was it a third party replacement? Same for the battery?

  3. #3

    rabbitjetta's Avatar
    Member Since
    Nov 08, 2010
    Location
    Indiana
    Posts
    967
    Specs:
    Main-11" Air, iPhone 6+, iPad Mini 3, Hi-Fi Extras- Too many to count
    How much is left in the battery when you first plug it in?

  4. #4


    Member Since
    Feb 21, 2012
    Posts
    2
    @chscag
    Both the battery and magsafe were acquired at the mac store, so they weren't 3rd party items.

    @rabbitjetta
    I plug it in at different percentages, I usually try not to let it die completely before I plug it in so it wont take as long to get back to a full charge

  5. #5


    Member Since
    Oct 02, 2012
    Posts
    1
    did you ever figure this out?
    I am having this same problem, just replaced the magsafe board and bought a new battery, both apple oem parts, computer says not charging, if I sit and watch it, it goes up 1% here and there, and when i put it in standby and leave it over night, fully charges, no lights light up on the magsafe, unless its when i first plug it in, it turns green and then stays a very dim lit green every once in a while, very strange. Help?

  6. #6


    Member Since
    Nov 26, 2012
    Posts
    2
    Quote Originally Posted by domasac View Post
    I am having this same problem, just replaced the magsafe board and bought a new battery, both apple oem parts, computer says not charging, if I sit and watch it, it goes up 1% here and there, and when i put it in standby and leave it over night, fully charges, no lights light up on the magsafe, unless its when i first plug it in, it turns green and then stays a very dim lit green every once in a while, very strange. Help?
    It's like you have the same computer as me.

    I'm running 10.8.2 on 15-inch Late 2008 Macbook.

    I recently recovered from some water (orange juice) damage and swapped in a hard drive from another Macbook. My battery has been through 68 cycles and the charger is brand new.

  7. #7


    Member Since
    Oct 24, 2012
    Location
    NY.
    Posts
    318
    15" PowerBook G4, 1.67GHz, 2GB RAM, 250GB HD ; 16GB iPad2.

  8. #8


    Member Since
    Nov 26, 2012
    Posts
    2
    Quote Originally Posted by ChrisMan287 View Post
    Yeah, I've done several. No dice. For the record, I've done it both by unplugging the magsafe adapter then removing the battery, five second press, replacing battery and putting back the magsafe adapter. And vis-a-versa

  9. #9

    fzanetti's Avatar
    Member Since
    Feb 28, 2007
    Location
    Boston, MA
    Posts
    16
    Specs:
    MacBook Pro 2.33G DUO CORE 17"
    Any luck with your Mac not charging????
    I am having the same problem - macbookpro5,2

    Tried SMC, PRAM, new MagSafe and still no luck...

    Please help!!!


    Thanks!



    Flavio Zanetti
    Flavio Zanetti
    Boston, MA

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 14
    Last Post: 04-15-2015, 11:05 PM
  2. IPad 2 charging very slowly
    By rimo911s in forum iPad Hardware and Accessories
    Replies: 3
    Last Post: 08-30-2014, 03:34 PM
  3. Please Help! Macbook running slowly
    By GAHDOOSH in forum Apple Notebooks
    Replies: 0
    Last Post: 07-06-2011, 07:39 PM
  4. MacBook running very slowly
    By yuppieskum in forum Apple Notebooks
    Replies: 1
    Last Post: 10-17-2009, 08:57 PM
  5. Macbook running slowly?
    By Division.Bell in forum OS X - Operating System
    Replies: 2
    Last Post: 06-08-2009, 12:42 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •