New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
Apple Notebooks Apple's notebook computers including MacBook Pro, MacBook, MacBook Air, PowerBook, and iBook.

new battery and still doesn't detect it


Post Reply New Thread Subscribe

 
Thread Tools
cad2blender

 
Member Since: Nov 19, 2006
Posts: 284
cad2blender is on a distinguished road

cad2blender is offline
I bought this battery:

http://www.amazon.com/Superb-Choice-...ref=pd_vtp_e_3

for my macbook pro 15 inch model A1211 and for some reason once I installed it it doesn't detect it. The battery icon is still has a small cross inside it. I have restarted it and reset the pram and the smc and still nothing. Once I unplug the power cord the computer still runs, so I don't think its a battery issue. What could it be?
EDIT: I read the box and the battery and it says its for the model A1175, could this be the problem? I thought some of these batteries were interchangeable with specific laptop models
QUOTE Thanks
RavingMac

 
RavingMac's Avatar
 
Member Since: Jan 07, 2008
Location: In Denial
Posts: 7,614
RavingMac has a reputation beyond reputeRavingMac has a reputation beyond reputeRavingMac has a reputation beyond reputeRavingMac has a reputation beyond reputeRavingMac has a reputation beyond reputeRavingMac has a reputation beyond reputeRavingMac has a reputation beyond reputeRavingMac has a reputation beyond reputeRavingMac has a reputation beyond reputeRavingMac has a reputation beyond reputeRavingMac has a reputation beyond repute
Mac Specs: 4GB Mac Mini 2012, 13" MBA, 15" MacBook Pro OSX 10.7, 32 GB iPhone 3GS, iPad2 64gb 3G

RavingMac is offline
Quote:
Originally Posted by cad2blender View Post
I bought this battery:

Amazon.com: Superb Choice New Laptop Replacement Battery for Apple MacBook Pro MA463LL/A MA464LL/A MA895LL MA896*/A MB133LL/A a1150 a1211 a1226 ma463 ma600ll/a ma609 ma610ll/a ma680ll/a ma681ll/a mb133x/a: Electronics

for my macbook pro 15 inch model A1211 and for some reason once I installed it it doesn't detect it. The battery icon is still has a small cross inside it. I have restarted it and reset the pram and the smc and still nothing. Once I unplug the power cord the computer still runs, so I don't think its a battery issue. What could it be?
EDIT: I read the box and the battery and it says its for the model A1175, could this be the problem? I thought some of these batteries were interchangeable with specific laptop models
Following the link it looks like the shipper sent you a different and cheaper battery than the one you ordered, if you ordered via the link you posted. I would contact Amazon and have them replace it with the correct item.

EDIT: If your box says for A1175, they probably sent you this one
http://www.amazon.com/Replacement-Ba.../ref=pd_cp_e_0

I've always wanted to be smart, handsome and modest. But, I guess I'll have to be satisfied with two out of three . . .
QUOTE Thanks
cad2blender

 
Member Since: Nov 19, 2006
Posts: 284
cad2blender is on a distinguished road

cad2blender is offline
EDIT: my mistake, they sent me this one. I had to check my amazon account to get the exact model

http://www.amazon.com/gp/product/B00...00_i00_details

Since it says that it fits for both models A1211 and A1175 I think something else may be the cause of the crossed battery icon
QUOTE Thanks
RavingMac

 
RavingMac's Avatar
 
Member Since: Jan 07, 2008
Location: In Denial
Posts: 7,614
RavingMac has a reputation beyond reputeRavingMac has a reputation beyond reputeRavingMac has a reputation beyond reputeRavingMac has a reputation beyond reputeRavingMac has a reputation beyond reputeRavingMac has a reputation beyond reputeRavingMac has a reputation beyond reputeRavingMac has a reputation beyond reputeRavingMac has a reputation beyond reputeRavingMac has a reputation beyond reputeRavingMac has a reputation beyond repute
Mac Specs: 4GB Mac Mini 2012, 13" MBA, 15" MacBook Pro OSX 10.7, 32 GB iPhone 3GS, iPad2 64gb 3G

RavingMac is offline
Still might be worth sending it back and checking at OWC for a battery. They specialize in products for Macs.
http://eshop.macsales.com/shop/Apple/Laptop/Batteries

I've always wanted to be smart, handsome and modest. But, I guess I'll have to be satisfied with two out of three . . .
QUOTE Thanks
cad2blender

 
Member Since: Nov 19, 2006
Posts: 284
cad2blender is on a distinguished road

cad2blender is offline
Thanks for the help. Right now I reset my pram but then it just hung on the grey screen with the apple logo and spinning gear for about 20 minutes. I took off the power supply and tried to boot with the battery and it didn't work. The only way it now boots is after a permissions check. Any other ideas? maybe just reinstall lion again?
QUOTE Thanks
cad2blender

 
Member Since: Nov 19, 2006
Posts: 284
cad2blender is on a distinguished road

cad2blender is offline
UPDATE:

I ran the apple hardware test and it gave me this error:

4SNS/1/4000000 TB0T

After looking it up the sns part means a sensor error, and the TB0T means that the battery max temp sensor has failed or isn't detected. The reason why is because the laptop still does not detect the battery, so it doesn't detect a thermal sensor. I did this on another laptop and it has the same error with the battery uninstalled, once installed it works fine, no errors at all. Not sure what I should do at this point. The computer runs fine, just annoying since the cpu gets throttled down a bit when the laptop does not detect a battery.
QUOTE Thanks

Post Reply New Thread Subscribe


« Missing Address Bar | How accurate is the apple store repair estimation? »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

All times are GMT -4. The time now is 06:30 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?