I'm a long-time mac head. I'm pretty good at working out problems but this one has me stumped.

I've been having problems with my external bus-powered FW800 G-Drive. I had one that was seizing up on transfers, so I returned and replaced it. Now I'm not so sure it was the drive.

The new drive took my 400+gb of files and media just fine. I've been able to edit with FCP, but there have been problems.

The most telling was when I tried backing the drive up to an external e-sata drive. It got a few hundred mb into a transfer and stopped. Beachball. This happened 3-4 times. I could get small files off the drive, but anytime I tried anything larger, it seized. Beachball.

I took the drives and plugged them into my wife's old mac mini. It backed up all of the files just fine. Not on my MBP.

The G-Drive works just fine over the USB. I have a split cable to get the power off of two ports to run the drive.

My lacie rubber-bumpered bus-powered drive works just fine off my MBP's FW800 port.

In summary: G-drive isn't working on my MBP over FW800. (changed cables: no difference)
G-drive works on FW400 on different computer.
G-drive works on USB on my MBP.
Different FW drive works on my MBP.

Any suggestions about what might be the issue, or the next step in diagnosing it?

Thanks! I appreciate the help.

--> Mark

MBP: 17" 2.66ghz dual core i7 running 10.6.8. 8gb ram.