Results 1 to 3 of 3
  1. #1

    Member Since
    Dec 31, 2011
    2009 Macbook HD Issues
    I have a 2009 Macbook pro 13" hard drive went to what i believed was bad the other day so i picked up a new seagate momentus installed it, and then booted up from my snow leopard disk, and disk utility cant find the drive nor is it showing up in system profiler. Both the new and old drive are also spinning while running. any suggestions?

  2. #2

    louishen's Avatar
    Member Since
    Oct 22, 2007
    Mac Mini Core i7 2012 | White 2009 MacBook 2 Ghz | 733 Mhz G4 Quicksilver
    You haven't spilled anything on that Macbook have you?

    The disk should show up but maker sure everything is properly connected and both ends of the hard disk connection are securely in to the drive and the motherboard
    Member of the Month September 2008 & August 2012 | Found advice useful? use the rep system

  3. #3

    Member Since
    Dec 31, 2011
    nothing ever spilled on it, and i have checked and double checked all the connections

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. MacBook Pro medio 2009, sudden heat issues.
    By McColanis in forum Apple Notebooks
    Replies: 1
    Last Post: 08-30-2012, 10:55 AM
  2. Mid 2009 Macbook Pro Heat Issues
    By cirno in forum Apple Notebooks
    Replies: 4
    Last Post: 08-30-2012, 07:19 AM
  3. Macbook Pro 13" mid 2009, man I am having issues.
    By Celestea in forum Apple Notebooks
    Replies: 2
    Last Post: 06-28-2012, 12:52 PM
  4. Mid-2009 17" Macbook Pro display issues
    By guitarmartyr in forum Apple Notebooks
    Replies: 0
    Last Post: 03-11-2011, 09:26 PM
  5. Replies: 0
    Last Post: 07-14-2010, 02:37 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts