I have a MacBook Pro from the fall of 2009.

It has had many problems over the last two years, the most recent of which is a sound problem. I don't think it's related to the headphone jack, because when the sound stops working, it stops working on the speakers as well as with headphones plugged in.

I was able to fix the problem at the beginning by restarting the computer and I only had to do this once every week or two, but now if I wanted sound I would have to restart my computer every few hours at the least. Now it's gotten to the point where even restarting the computer is not restoring the sound.

Some more info:
There is no sound whatsoever when I hit the sound up or down buttons, but otherwise the image that pops up on the screen when adjusting the volume looks totally normal.

The sound when it does work makes a strange cracking sound occasionally and/or fluctuates in volume.

The sound never stops working while I am using it. I have have to open a new youtube video, or stop itunes and then hit play again for the sound to stop working. It's not that the sound stops working every time that I stop using it, just it has never stopped abruptly in the middle of a song or video or anything.

The sound sometimes does not disappear initially, but instead turns into what sound like a lot of loud white noise. If I completely turn the volume down the white noise disappears, but even 1 bar of volume and the white noise is a full volume and sounds the same as if I had the volume completely turned up.

Other times instead of a constant white noise sound, I only hear the sound when adjusting the volume in place of the usual sound that you get when you hit the volume up or down key.

Last thing. Sometimes the volume works, but if I am talking to someone on skype they cannot hear me. It just sounds like a lot of clicking noise or white noise, I don't really know because I can't really talk to myself on skype.

All of this started occurring after I took my computer in to the apple store about 6 months ago because it would start showing the rainbow beach ball circle of death thing and would freeze so much that I couldn't use my computer. The problem seemed fixed, but a few weeks afterwards, this one started appearing.

Once or twice I have been able to fix the problem by plugging in headphones and then unplugging them.

Occasionally the sound comes back. In these circumstances the sound seems normal to me, but if I am talking to someone one skype the clicking noises start.

I am really just fed up with the whole thing and I would like my computer to work so any info is appreciated,