New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
Apple Notebooks Apple's notebook computers including MacBook Pro, MacBook, MacBook Air, PowerBook, and iBook.

local backups staying in HDD


Post Reply New Thread Subscribe

 
Thread Tools
Andres87

 
Andres87's Avatar
 
Member Since: Jul 27, 2011
Posts: 184
Andres87 will become famous soon enough

Andres87 is offline
Hi everybody, well I got a 13 inch MBP with Lion in it i also use time machine to back up all of my stuff. I know Lion has this local back up feature that backs things up when Time Machine isn't present or something like that and once you back up to time machine the back ups disappear form your hard drive well....thats not the case here some of the local back ups won't go away form my hard drive even after backing up to time machine a few times, does anybody know whats the issue here? thanks and sorry for the run on sentences lol
Attached Images
File Type: jpg 1.jpg (137.1 KB, 40 views)
QUOTE Thanks
chscag

 
chscag's Avatar
 
Member Since: Jan 23, 2008
Location: Fort Worth, Texas
Posts: 39,423
chscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond repute
Mac Specs: 27" iMac i5, 3.2 GHz, iPad 3, iPhone 5c, 3 iPods, OS X Mavericks

chscag is offline
This a quirk of the new Time Machine (it's supposed to be a feature) that when the external TM drive is disconnected, TM will continue to make backups and will save them to your internal hard drive. When the external TM drive is once more attached it will copy the backups it made onto the external along with the new backup.

All well and good except that it looks like it does not remove the old backups from the internal drive. The only way I know of getting around that is turn Time Machine off when your external TM drive is not attached. Kind of inconvenient and easy to forget but I know of no other way. I've been searching for a better work around and will let everyone know if I find one.
QUOTE Thanks
XJ-linux

 
XJ-linux's Avatar
 
Member Since: Jul 02, 2007
Location: Going Galt...
Posts: 3,353
XJ-linux has a reputation beyond reputeXJ-linux has a reputation beyond reputeXJ-linux has a reputation beyond reputeXJ-linux has a reputation beyond reputeXJ-linux has a reputation beyond reputeXJ-linux has a reputation beyond reputeXJ-linux has a reputation beyond reputeXJ-linux has a reputation beyond reputeXJ-linux has a reputation beyond reputeXJ-linux has a reputation beyond reputeXJ-linux has a reputation beyond repute
Mac Specs: MacBookAir5,2:10.9.4-MacMini3,1:10.9.4-iPhone6,1:7.1.2

XJ-linux is offline
The short of it solution... from a Terminal window as a user with Administrator privileges type:

sudo tmutil disablelocal

Enter your password and it will stop local backups AND delete the backups currently on your internal disk.

There was an option in the Developer release to turn this feature on and off via the System Preferences Panel for Time Machine. It was removed from the final release. It was also originally also suppose to store internal backups and then transfer those backups to the external TM disk when a laptop was back in range or reconnected to the external disk. These features were changed in the final release. It does not, nor is it suppose to (at the current time) transfer internal backups to your external TM disk when you are in range or reconnected. It's not an option at this time and the only way to get the space back is to wait for TM to remove them, or remove them manually. It is designed to retain the internal backups and use an algorithm to manage how long to keep them now.

Running the above listed command will disable internal backups, yet still allow Time Machine to function as it did in 10.6.8 ie: you don't have to turn TM off completely in System Preferences. Look at the System Preferences window for Time Machine and you will see a description (in the lower right) of what it does, and mention of attempting to keep local backups. Once you run the above command, that text will change and no longer mention the local backups. Hope this helps.

"Those who don't understand Unix are condemned to reinvent it, poorly." Henry Spencer
QUOTE Thanks
Andres87

 
Andres87's Avatar
 
Member Since: Jul 27, 2011
Posts: 184
Andres87 will become famous soon enough

Andres87 is offline
thanks for the replies guys but one more question if I use that command in terminal I would loose that feature right? its a cool feature I guess I would like to keep it is there a way to "Activate it" again after and disable it?
QUOTE Thanks
XJ-linux

 
XJ-linux's Avatar
 
Member Since: Jul 02, 2007
Location: Going Galt...
Posts: 3,353
XJ-linux has a reputation beyond reputeXJ-linux has a reputation beyond reputeXJ-linux has a reputation beyond reputeXJ-linux has a reputation beyond reputeXJ-linux has a reputation beyond reputeXJ-linux has a reputation beyond reputeXJ-linux has a reputation beyond reputeXJ-linux has a reputation beyond reputeXJ-linux has a reputation beyond reputeXJ-linux has a reputation beyond reputeXJ-linux has a reputation beyond repute
Mac Specs: MacBookAir5,2:10.9.4-MacMini3,1:10.9.4-iPhone6,1:7.1.2

XJ-linux is offline
Quote:
Originally Posted by Andres87 View Post
thanks for the replies guys but one more question if I use that command in terminal I would loose that feature right? its a cool feature I guess I would like to keep it is there a way to "Activate it" again after and disable it?
sudo tmutil enablelocal

Get's it back again.

"Those who don't understand Unix are condemned to reinvent it, poorly." Henry Spencer
QUOTE Thanks
Andres87

 
Andres87's Avatar
 
Member Since: Jul 27, 2011
Posts: 184
Andres87 will become famous soon enough

Andres87 is offline
oh and another thing, when I go to the system preferences for TM it doesn't say anything about the local back ups even before typing that command :s
Attached Images
File Type: jpg Untitled.jpg (203.8 KB, 32 views)
QUOTE Thanks
Andres87

 
Andres87's Avatar
 
Member Since: Jul 27, 2011
Posts: 184
Andres87 will become famous soon enough

Andres87 is offline
Quote:
Originally Posted by XJ-linux View Post
sudo tmutil enablelocal

Get's it back again.
awesome let me try it right away and see what happens
QUOTE Thanks
Andres87

 
Andres87's Avatar
 
Member Since: Jul 27, 2011
Posts: 184
Andres87 will become famous soon enough

Andres87 is offline
IT WORKED!!!! you guys are awesome thank you so much for your help http://www.mac-forums.com/forums/mac_images/images/smilies/Grin.png
Attached Images
File Type: jpg 12.jpg (138.5 KB, 33 views)
QUOTE Thanks
XJ-linux

 
XJ-linux's Avatar
 
Member Since: Jul 02, 2007
Location: Going Galt...
Posts: 3,353
XJ-linux has a reputation beyond reputeXJ-linux has a reputation beyond reputeXJ-linux has a reputation beyond reputeXJ-linux has a reputation beyond reputeXJ-linux has a reputation beyond reputeXJ-linux has a reputation beyond reputeXJ-linux has a reputation beyond reputeXJ-linux has a reputation beyond reputeXJ-linux has a reputation beyond reputeXJ-linux has a reputation beyond reputeXJ-linux has a reputation beyond repute
Mac Specs: MacBookAir5,2:10.9.4-MacMini3,1:10.9.4-iPhone6,1:7.1.2

XJ-linux is offline
Quote:
Originally Posted by Andres87 View Post
oh and another thing, when I go to the system preferences for TM it doesn't say anything about the local back ups even before typing that command :s
Yes, it does actually. Look at your own attachment in this thread...

"Time Machine keeps local snapshots as space permits, and"

What does it say after typing the command?

"Those who don't understand Unix are condemned to reinvent it, poorly." Henry Spencer
QUOTE Thanks
Andres87

 
Andres87's Avatar
 
Member Since: Jul 27, 2011
Posts: 184
Andres87 will become famous soon enough

Andres87 is offline
Quote:
Originally Posted by XJ-linux View Post
Yes, it does actually. Look at your own attachment in this thread...

"Time Machine keeps local snapshots as space permits, and"

What does it say after typing the command?
hahahaha ooops well once I typed the first command terminal goes like are you sure blah blah blah the world could end blah blah blah and then I put my password and bingo!!! then when I typed the second one nothing happened lol
QUOTE Thanks
XJ-linux

 
XJ-linux's Avatar
 
Member Since: Jul 02, 2007
Location: Going Galt...
Posts: 3,353
XJ-linux has a reputation beyond reputeXJ-linux has a reputation beyond reputeXJ-linux has a reputation beyond reputeXJ-linux has a reputation beyond reputeXJ-linux has a reputation beyond reputeXJ-linux has a reputation beyond reputeXJ-linux has a reputation beyond reputeXJ-linux has a reputation beyond reputeXJ-linux has a reputation beyond reputeXJ-linux has a reputation beyond reputeXJ-linux has a reputation beyond repute
Mac Specs: MacBookAir5,2:10.9.4-MacMini3,1:10.9.4-iPhone6,1:7.1.2

XJ-linux is offline
Quote:
Originally Posted by Andres87 View Post
hahahaha ooops well once I typed the first command terminal goes like are you sure blah blah blah the world could end blah blah blah and then I put my password and bingo!!! then when I typed the second one nothing happened lol
Yep, there is a time constraint with the sudo command which allows you to run it without reentering the password for a short period of time or until you end the Terminal session. It won't say anything in the terminal window after you hit enter after entering the second sudo command. That's normal.

If you have the local backups disabled currently, the description in the System Preferences > Time Machine should no longer mention anything about local snapshots. Glad it worked.

"Those who don't understand Unix are condemned to reinvent it, poorly." Henry Spencer
QUOTE Thanks
Andres87

 
Andres87's Avatar
 
Member Since: Jul 27, 2011
Posts: 184
Andres87 will become famous soon enough

Andres87 is offline
Quote:
Originally Posted by XJ-linux View Post
Yep, there is a time constraint with the sudo command which allows you to run it without reentering the password for a short period of time or until you end the Terminal session. It won't say anything in the terminal window after you hit enter after entering the second sudo command. That's normal.

If you have the local backups disabled currently, the description in the System Preferences > Time Machine should no longer mention anything about local snapshots. Glad it worked.
yep you're right thanks a lot
QUOTE Thanks

Post Reply New Thread Subscribe


« Wifi to Ethernet | Mbp stuck on white apple screen!!!:( »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
MBP cannot "see" HDD Roed Apple Notebooks 7 07-18-2010 09:22 PM

All times are GMT -4. The time now is 12:12 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?