Mac Forums

Mac Forums (http://www.mac-forums.com/forums/)
-   Apple Notebooks (http://www.mac-forums.com/forums/apple-notebooks/)
-   -   HD clone not recognized when internal (http://www.mac-forums.com/forums/apple-notebooks/244424-hd-clone-not-recognized-when-internal.html)

matthewbr0wn 07-19-2011 02:31 PM

HD clone not recognized when internal
 
Hi all -

First time poster. I have been browsing the forums for someone with my same issue and I can't quite seem to find a solution. Here is my situation:

I have an early 2009 Macbook with 120GB hard drive. I want to clone and replace with a 500GB hard drive. I have tried many different things which I will detail below, but end up with the same results, a hard disk that is bootable as an external drive and when I move it internal, my Macbook can't recognize it and I get a "question mark folder"

So with the details. I have tried both a WD Scorpio Blue 5400RPM 500GB SATA and a Hitachi Travelstar 7200RPM 500GB SATA drive.

I first tried with the WD disk with the following steps:
  1. Place disk in external enclosure and format with Mac Disk Util using GUID and Journaling options
  2. First I cloned with CCC and made a bootable clone
  3. Rebooted holding "Option" selected the new drive which was still external and booted without issue
  4. Shutdown, pulled the original drive, installed new WD disk put the old drive in enclosure and booted with Option
  5. This time, only the old drive which was external showed up
  6. I shutdown, pulled the old drive and booted only with the new drive, got the question mark folder
  7. put the old drive back and booted as external to see if I could select the new internal drive as the startup disk, but the drive isn't visible
  8. swapped the disks again and rebooted with option
  9. Selected the new drive (this time as external) as the startup disk and rebooted with success
  10. put the new drive in as internal disk and got the question mark folder
  11. put old drive back in and ran disk repair, found some permissioning issues, corrected them
  12. Zeroed the new drive, cloned again, booted external no problem
  13. Placed back in Macbook and got question mark folder
  14. Repeated the whole process again using SuperDuper, made sure to check disk permissions again and got the exact same result
  15. Bought a Hitachi drive to see if that made a difference, followed the process over again and got the same result, the question mark folder

So is there some step I am skipping that makes my drives only bootable as external drives? I have beat my head against the wall for HOURS to try and figure out what I am missing. Any help/insight that can be provided will be greatly appreciated! Thanks all!

MYmacROX 07-19-2011 02:45 PM

I think you're making this harder than it has to be. Why not backup your old drive to an external via Time Machine? Then install the new drive and boot with your SL DVD (restart and hold "C"), go through the set up process and at the end allow it to restore from your Time Machine backup?
It's good to have the bootable clone as an additional backup, but can be problematic sometimes when transferring drives.

matthewbr0wn 07-19-2011 02:57 PM

Thanks for the reply, I don't have the OS DVD as I am not the original purchaser of this Macbook. I was given it in exchange for some freelance design work I did. I don't think I am likely to get the install disk, is it possible to make a DVD to do the same?

matthewbr0wn 07-19-2011 03:20 PM

I do know other people with installation disks, would it work to borrow one of those?

MYmacROX 07-19-2011 06:01 PM

No. You need to get the discs from the person who gave you the Mac or you can purchase a retail copy of SL for $29.

matthewbr0wn 07-19-2011 06:10 PM

Yeah, I'll get a copy tonight at the Apple Store and give it a try. Hopefully it works better than what I have been trying. Thanks for the suggestion!


All times are GMT -4. The time now is 10:15 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.