New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus • Advice and insight from world-class Apple enthusiasts • Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
Apple Notebooks Apple's notebook computers including MacBook Pro, MacBook, MacBook Air, PowerBook, and iBook.

Internet is always going on and off with my MacBook Pro?


Post Reply New Thread Subscribe

 
Thread Tools
EPlC MEAL TlME

 
Member Since: Jun 09, 2011
Posts: 3
EPlC MEAL TlME is on a distinguished road

EPlC MEAL TlME is offline
I just recently got back from college. In my dorm room, I used an ethernet cable to connect to the internet and I didn't have any problems connecting the whole year. When I got home, I found that my laptop was having trouble connecting wirelessly to the router in my house. Our big Dell Computer that my parents use has no problems connecting whatsoever, but my Macbook for some reason does.

My MacBook will connect to the internet and then, ranging from about 30 seconds to 20 minutes later, it will all of a sudden disconnect. It will say the usual “you are not connected to the internet” and then give me the “network diagnostics” button. I’ll click network diagnostics, then choose “airport”, and then select the wireless network that our router uses (2WIRE980). It will say “Do you use a DSL or modem to connect to the internet?” Then I will click yes, and it goes through all of those steps which i answer correctly. And then finally it says “Please restart the device. When it is done restarting, click continue. If you do not know how to restart the device, please consult the device’s manual.” I also noticed that if I hold click and hold for about 5 seconds on the "2WIRE980" network, it will go to the next page which requires me to type in the WEP password to my wireless network in order to connect. I have typed in my password about a thousand times, and I shouldn't have to do this. I have tried restarting my computer a bunch of times, and even restarted the router a couple of times, but it just keeps going on and off all the time.

My IP address is 192.168.1.**
My Subnett Mask is 255.255.255.0
My Router is 192.168.1.***

My IP Address and router are a little bit different. I don’t know if this means anything but when i tried to change the IP Address to the same as the router, it says, “Another device on the network is using your computer’s IP Address.”

Anybody know how I can just get my internet to connect strong at all times?
QUOTE Thanks
bobtomay

 
bobtomay's Avatar
 
Member Since: Dec 22, 2006
Location: Texas, where else?
Posts: 25,043
bobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond reputebobtomay has a reputation beyond repute
Mac Specs: 15" MBP 2.33 C2D 256 4GB, MBA 13" i7 1.8, MB 2.0 2GB, Nano 4th, 3GS, iPad 1

bobtomay is offline
Your issue is using WEP encryption. Many Macs have issues with it. This is a good thing as your next door neighbor's 10 year old can crack it in about 1 minute.

Change the encryption to WPA/WPA2.

I cannot be held responsible for the things that come out of my mouth.
In the Windows world, most everything folks don't understand is called a virus.
QUOTE Thanks
EPlC MEAL TlME

 
Member Since: Jun 09, 2011
Posts: 3
EPlC MEAL TlME is on a distinguished road

EPlC MEAL TlME is offline
how exactly do i do that...i have no idea
QUOTE Thanks
chscag

 
chscag's Avatar
 
Member Since: Jan 23, 2008
Location: Fort Worth, Texas
Posts: 40,138
chscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond repute
Mac Specs: 27" iMac i5, 3.2 GHz, iPad 3, iPhone 5c, 3 iPods, OS X Mavericks

chscag is offline
You reset the encryption method from your Router. Dig out your router manual and read how to access it from your browser. Once you're in the router menu, look for wireless settings. You'll see settings for selecting the channel, and also for securing the connection. Select WPA2 and type in a password or phrase. Make sure you're also broadcasting the name of your network. Then from your MacBook, select your network, select connect, type in the password, and you should be good to go.

Also, you can not use the same IP address for both the router and the network as that's not going to work. Just make sure you select DHCP in your airport settings for wireless and the IP address will be assigned automatically.
QUOTE Thanks
chscag

 
chscag's Avatar
 
Member Since: Jan 23, 2008
Location: Fort Worth, Texas
Posts: 40,138
chscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond repute
Mac Specs: 27" iMac i5, 3.2 GHz, iPad 3, iPhone 5c, 3 iPods, OS X Mavericks

chscag is offline
And do not double post. Your question has been answered above. Always reply back to the same thread, do not start a new one.
QUOTE Thanks
Boosted_Brian

 
Boosted_Brian's Avatar
 
Member Since: Mar 28, 2011
Location: Ft. Lauderdale/Tallahassee
Posts: 68
Boosted_Brian is on a distinguished road
Mac Specs: 2011 MacBook Pro, 2.3 GHz i7, 8GB Ram, 750GB HD, Hi-Res AG screen

Boosted_Brian is offline
Quote:
Originally Posted by EPlC MEAL TlME View Post
how exactly do i do that...i have no idea
All you have to do is type in the router ip address into the address bar in your browser. I believe you typed it above.

oddly I dont know how to do this on a mac, but walk over to your parents dell that is having no problem (Probably the best way anyway, since yours is having problems staying connected)

Click start>run>Type "cmd" (enter)

When the command prompt comes up type in "ipconfig" There it should list a bunch of ip address, copy the gateway into the address bar.

Judging by the fact that you are using such simple encryption, I am going to guess you probably also never changed the admin password, which in that case the password to access the router is still "admin"
QUOTE Thanks
iggibar

 
iggibar's Avatar
 
Member Since: Apr 20, 2009
Location: C-Town
Posts: 4,065
iggibar is a splendid one to beholdiggibar is a splendid one to beholdiggibar is a splendid one to beholdiggibar is a splendid one to beholdiggibar is a splendid one to beholdiggibar is a splendid one to beholdiggibar is a splendid one to beholdiggibar is a splendid one to behold
Mac Specs: Mac Pro 4.1 15" MBP. 13" MBP. 17" PB. Power Mac G5. iPhone 5s 64gb

iggibar is offline
I have the same problem in my house. I have a 2Wire wireless modem from AT&T. I have tried every single encryption method, and they all give me the same problem. It disconnects countless times...just did it 10 seconds ago!... I only have this problem when I'm at home. The weird thing is that AT&T is one of the 2 major isp's in my neighborhood, and I have 2 friends who also have a 2wire modem, no macs, and still have internet problems associated with it disconnecting randomly. I can't even do anything about it because there's no other reliable isp. I have learned to move away from the computer when this problem comes up...relax.

To EPIC MEAL TIME,
To get into your modem settings, simply type "gateway.2wire.net" into your web browser. Then, click on "Home Network" on the top tabs. You will see a gray box that is titled "Status at a Glance." In it, click the edit settings on the wireless network. Depending on your security, you might have to enter a password to enter the settings. After the password is entered, you will get a new window that says "Configure the Wireless Network." Below it, you will find a "Wireless Security." Change the authentication to which ever you want besides the WEP one's. For simplicity, choose the "use default encryption key," which is the key found under the modem(sticker). Then just save and exit.

It's worth a try.

“If you are distressed by anything external, the pain is not due to the thing itself but to your own estimate of it; and this you have the power to revoke at any moment.” Marcus Aurelius
QUOTE Thanks
Boosted_Brian

 
Boosted_Brian's Avatar
 
Member Since: Mar 28, 2011
Location: Ft. Lauderdale/Tallahassee
Posts: 68
Boosted_Brian is on a distinguished road
Mac Specs: 2011 MacBook Pro, 2.3 GHz i7, 8GB Ram, 750GB HD, Hi-Res AG screen

Boosted_Brian is offline
Quote:
Originally Posted by idrinorbarsaku View Post
I have the same problem in my house. I have a 2Wire wireless modem from AT&T. I have tried every single encryption method, and they all give me the same problem. It disconnects countless times...just did it 10 seconds ago!... I only have this problem when I'm at home. The weird thing is that AT&T is one of the 2 major isp's in my neighborhood, and I have 2 friends who also have a 2wire modem, no macs, and still have internet problems associated with it disconnecting randomly. I can't even do anything about it because there's no other reliable isp. I have learned to move away from the computer when this problem comes up...relax.

To EPIC MEAL TIME,
To get into your modem settings, simply type "gateway.2wire.net" into your web browser. Then, click on "Home Network" on the top tabs. You will see a gray box that is titled "Status at a Glance." In it, click the edit settings on the wireless network. Depending on your security, you might have to enter a password to enter the settings. After the password is entered, you will get a new window that says "Configure the Wireless Network." Below it, you will find a "Wireless Security." Change the authentication to which ever you want besides the WEP one's. For simplicity, choose the "use default encryption key," which is the key found under the modem(sticker). Then just save and exit.

It's worth a try.
Quick question, have you tried getting just a regular modem from ATT and using a 3rd party wireless router? Come to think of it, I used to have ATT at my old apartment, and when I would use my laptop (a pc) and playing online with my PS3 for whatever reason, both couldn't be on the network at the same time... when one connected the other disconnect. I know its an extra 50 bucks or so for the equipment, but to me, it might be worth the money to avoid the frustration. I have an older model lynksis a/b/g in my house now. Works flawlessly, with all three computers, PS3 and desktops connect at the same time.
QUOTE Thanks
iggibar

 
iggibar's Avatar
 
Member Since: Apr 20, 2009
Location: C-Town
Posts: 4,065
iggibar is a splendid one to beholdiggibar is a splendid one to beholdiggibar is a splendid one to beholdiggibar is a splendid one to beholdiggibar is a splendid one to beholdiggibar is a splendid one to beholdiggibar is a splendid one to beholdiggibar is a splendid one to behold
Mac Specs: Mac Pro 4.1 15" MBP. 13" MBP. 17" PB. Power Mac G5. iPhone 5s 64gb

iggibar is offline
Quote:
Originally Posted by Boosted_Brian View Post
Quick question, have you tried getting just a regular modem from ATT and using a 3rd party wireless router? Come to think of it, I used to have ATT at my old apartment, and when I would use my laptop (a pc) and playing online with my PS3 for whatever reason, both couldn't be on the network at the same time... when one connected the other disconnect. I know its an extra 50 bucks or so for the equipment, but to me, it might be worth the money to avoid the frustration. I have an older model lynksis a/b/g in my house now. Works flawlessly, with all three computers, PS3 and desktops connect at the same time.
The thought has crossed my mind, but the problem is that ATT wanted us to pay 299 +tax +MANDATORY installation fee, and you still have a crappy modem that, according to them, doesn't support wireless N routers. Not happening! You can buy great modem/routers for that price. The modem modem isn't 2wire, and I do suspect 2wire to be the main problem, but I'm not really sure enough to fork over that much money, on a problem that doesn't have a definite fix. What's your modem's make/model?

“If you are distressed by anything external, the pain is not due to the thing itself but to your own estimate of it; and this you have the power to revoke at any moment.” Marcus Aurelius
QUOTE Thanks
osxx

 
osxx's Avatar
 
Member Since: Jan 19, 2008
Location: houston texas
Posts: 4,661
osxx is a name known to allosxx is a name known to allosxx is a name known to allosxx is a name known to allosxx is a name known to allosxx is a name known to allosxx is a name known to all
Mac Specs: 09 MBP 8GB ram 500GB HD OS 10.9 32B iPad 4 32GB iPhone 5 iOs7 2TB TC Apple TV3

osxx is offline
I have Uverse which uses 2Wire RG3800 but I use an Airport Extreme because of issues with disconnects in the past since doing this all my issues with wireless are gone at least for the time being. I have also seen clients running several combinations
of computers and hand held with no problems so its not something you can easily put your finger on. The one thing I noticed even if you select a channel manually with 2Wire if you reboot or it gets a firmware upgrade it will default to auto which seems to play havoc if you have several devices in the home.
QUOTE Thanks
iggibar

 
iggibar's Avatar
 
Member Since: Apr 20, 2009
Location: C-Town
Posts: 4,065
iggibar is a splendid one to beholdiggibar is a splendid one to beholdiggibar is a splendid one to beholdiggibar is a splendid one to beholdiggibar is a splendid one to beholdiggibar is a splendid one to beholdiggibar is a splendid one to beholdiggibar is a splendid one to behold
Mac Specs: Mac Pro 4.1 15" MBP. 13" MBP. 17" PB. Power Mac G5. iPhone 5s 64gb

iggibar is offline
Quote:
Originally Posted by osxx View Post
I have Uverse which uses 2Wire RG3800 but I use an Airport Extreme because of issues with disconnects in the past since doing this all my issues with wireless are gone at least for the time being. I have also seen clients running several combinations
of computers and hand held with no problems so its not something you can easily put your finger on. The one thing I noticed even if you select a channel manually with 2Wire if you reboot or it gets a firmware upgrade it will default to auto which seems to play havoc if you have several devices in the home.
So, you just connected the extreme to the 2wire via ethernet? Did you disable the wireless on the 2wire? Do you think it will work with other n-ruters? It's worth the try in my opinion. I can test one from bestbuy, and if it doesn't work, I can return it.

“If you are distressed by anything external, the pain is not due to the thing itself but to your own estimate of it; and this you have the power to revoke at any moment.” Marcus Aurelius
QUOTE Thanks
osxx

 
osxx's Avatar
 
Member Since: Jan 19, 2008
Location: houston texas
Posts: 4,661
osxx is a name known to allosxx is a name known to allosxx is a name known to allosxx is a name known to allosxx is a name known to allosxx is a name known to allosxx is a name known to all
Mac Specs: 09 MBP 8GB ram 500GB HD OS 10.9 32B iPad 4 32GB iPhone 5 iOs7 2TB TC Apple TV3

osxx is offline
Not sure about their other routers but the 3800 I can put my AEBS in the DMZ or I can set it up in bridge mode which just makes it an overglorified wireless switch either way it will work and yes I disabled the wireless in the 3800 as the new extreme
has dual simultaneous radios and does a better job of it. Note if you set up AEBS in bridge mode occasionally it will try and hand out the same ip for both MBP and AEBS which is resolved by re-new lease it happens but not often.
QUOTE Thanks
Boosted_Brian

 
Boosted_Brian's Avatar
 
Member Since: Mar 28, 2011
Location: Ft. Lauderdale/Tallahassee
Posts: 68
Boosted_Brian is on a distinguished road
Mac Specs: 2011 MacBook Pro, 2.3 GHz i7, 8GB Ram, 750GB HD, Hi-Res AG screen

Boosted_Brian is offline
Quote:
Originally Posted by idrinorbarsaku View Post
The thought has crossed my mind, but the problem is that ATT wanted us to pay 299 +tax +MANDATORY installation fee, and you still have a crappy modem that, according to them, doesn't support wireless N routers. Not happening! You can buy great modem/routers for that price. The modem modem isn't 2wire, and I do suspect 2wire to be the main problem, but I'm not really sure enough to fork over that much money, on a problem that doesn't have a definite fix. What's your modem's make/model?
I now longer have my ATT setup, so all the parts are no longer in my possession.
QUOTE Thanks
iggibar

 
iggibar's Avatar
 
Member Since: Apr 20, 2009
Location: C-Town
Posts: 4,065
iggibar is a splendid one to beholdiggibar is a splendid one to beholdiggibar is a splendid one to beholdiggibar is a splendid one to beholdiggibar is a splendid one to beholdiggibar is a splendid one to beholdiggibar is a splendid one to beholdiggibar is a splendid one to behold
Mac Specs: Mac Pro 4.1 15" MBP. 13" MBP. 17" PB. Power Mac G5. iPhone 5s 64gb

iggibar is offline
Have you guys gotten the new airport update? For some reason, my network has yet to come down! I wonder if this new update had something to do with it? This is not normal, but I'm happy today!

“If you are distressed by anything external, the pain is not due to the thing itself but to your own estimate of it; and this you have the power to revoke at any moment.” Marcus Aurelius
QUOTE Thanks
dtravis7

 
dtravis7's Avatar
 
Member Since: Jan 04, 2005
Location: Modesto, Ca.
Posts: 27,766
dtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond repute
Mac Specs: iMac 2.4 C2D 10.10, iMac 2.16 C2d 10.6.8, Macbook2007 10.8.4, Mac Mini 10.8.4, iPhone 3GS Note 8!!

dtravis7 is offline
Quote:
Originally Posted by idrinorbarsaku View Post
Have you guys gotten the new airport update? For some reason, my network has yet to come down! I wonder if this new update had something to do with it? This is not normal, but I'm happy today!
I have had Zero issues here but did install the new Airport Update today. Figured it can not hurt!
QUOTE Thanks

Post Reply New Thread Subscribe


« Kingston SSD freezes MacBook Pro Core 2 Duo | Will this HDD work »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

All times are GMT -4. The time now is 10:54 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?