Results 1 to 6 of 6
  1. #1


    Member Since
    Oct 12, 2008
    Posts
    5
    Mac Pro Glitches after HD Upgrade
    I hired a small company that specializes in Mac repairs, upgrades, etc. Guy came out to my house and installed Western Digital 500GB on my Macbook Pro 08 w/Snow Leopard. He told me to let it run and reboot. I did.

    Next day I noticed issues:
    -devices are not recognized by iTunes including my iPad; iPhone; iPod
    -iPhoto, see images but opens to black

    There may be more issues....
    Does anyone know what the issue might be? Advice?

    I have tried repeatedly to get help from the person I hired and paid well.
    It's been over a week and he "guarantees" his work!

  2. #2

    Buzzard2010's Avatar
    Member Since
    Oct 22, 2010
    Location
    Bretforton, Worcestershire
    Posts
    2,571
    Specs:
    MacBook Pro 15" 2014, 2.2GHz i7, 16GB RAM, 250GB SSD, OSX 10.9.5 - iPhone 5s 16gb
    Try repairing the disk and permissions by booting from your install dvd, going to Utilities > Disk Utility, clicking your new drive then the first aid tab then click repair disk, after that click repair permissions. Will take a little while so be patient.
    Hopefully it will solve the glitches.

    - Simon

    If you have been helped, don't forget to use the Reputation system at the top right of their post.
    May 2011
    Nominated: March 2011 & April 2011

  3. #3


    Member Since
    Oct 12, 2008
    Posts
    5
    Thank you Buzz.....I did that but still not reading my devices in iTunes.

  4. #4

    Buzzard2010's Avatar
    Member Since
    Oct 22, 2010
    Location
    Bretforton, Worcestershire
    Posts
    2,571
    Specs:
    MacBook Pro 15" 2014, 2.2GHz i7, 16GB RAM, 250GB SSD, OSX 10.9.5 - iPhone 5s 16gb
    Ok another option is to re-install itunes. Make a backup of your library if you want to be extra careful.
    Could sort that problem.

    - Simon

    If you have been helped, don't forget to use the Reputation system at the top right of their post.
    May 2011
    Nominated: March 2011 & April 2011

  5. #5


    Member Since
    Oct 12, 2008
    Posts
    5
    I posted on facebook and someone suggested re-installing iTunes. That worked and it's now reading my devices!! So happy! But now.....

    Do you think this would work for iPhoto as well? I'm apprehensive although I have everything backed up. The issue is I can see images when I open iPhoto but when I click to open, it's black, no image.

    Thanks!!

  6. #6

    Buzzard2010's Avatar
    Member Since
    Oct 22, 2010
    Location
    Bretforton, Worcestershire
    Posts
    2,571
    Specs:
    MacBook Pro 15" 2014, 2.2GHz i7, 16GB RAM, 250GB SSD, OSX 10.9.5 - iPhone 5s 16gb
    If you have everything backed up then you shouldn't have anything to fear

    - Simon

    If you have been helped, don't forget to use the Reputation system at the top right of their post.
    May 2011
    Nominated: March 2011 & April 2011

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. MacBook Pro having a few glitches
    By sxy03RSX in forum OS X - Operating System
    Replies: 5
    Last Post: 08-28-2012, 08:45 PM
  2. Final Cut Pro 7 EXPORT GLITCHES
    By justinmillad in forum OS X - Apps and Games
    Replies: 1
    Last Post: 11-02-2010, 09:57 PM
  3. Old MacBook Pro Screen Glitches
    By billy22 in forum Apple Notebooks
    Replies: 0
    Last Post: 07-24-2010, 12:38 AM
  4. 10.4 glitches after upgrade
    By KingOvok in forum OS X - Operating System
    Replies: 5
    Last Post: 02-15-2010, 05:59 PM
  5. Replies: 3
    Last Post: 10-18-2009, 05:53 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •