New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
Apple Notebooks Apple's notebook computers including MacBook Pro, MacBook, MacBook Air, PowerBook, and iBook.

Wireless problem


Post Reply New Thread Subscribe

 
Thread Tools
hawkeyeradar

 
Member Since: Dec 04, 2010
Posts: 9
hawkeyeradar is on a distinguished road

hawkeyeradar is offline
Both my wife and I have new Macbook pros. They have both worked fine for 3 months however mine has just lost the wireless connectiion, hers is fine. I have reentered my IP address manually because it went on to 'self-assigned'. The airport is working fine and it shows connected to my network, but the internet has failed. Any suggestions?
QUOTE Thanks
mrplow

 
mrplow's Avatar
 
Member Since: Oct 01, 2007
Location: UK
Posts: 6,748
mrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond repute
Mac Specs: 27" iMac i7 (2011) 10.10, iPhone6, iPad Air, AppleTV2

mrplow is offline
Have you tried rebooting your router? Sounds like an IP clash/DHCP issue.

If that doesn't work, log into your router (connect by cable if you have to) and set it to allocate a fixed IP address to your Mac

External hard disk acquisition addict - but admitting the problem is the first step to a robust backup

Please use the reputation system if you think you've been helped - top right of this post
QUOTE Thanks
cwa107

 
cwa107's Avatar
 
Member Since: Dec 20, 2006
Location: Middletown, Pennsylvania
Posts: 26,575
cwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond repute
Mac Specs: 15" MBP, Core i7/2GHz, 8GB RAM, 480GB Crucial M500 SSD

cwa107 is offline
Quote:
Originally Posted by hawkeyeradar View Post
Both my wife and I have new Macbook pros. They have both worked fine for 3 months however mine has just lost the wireless connectiion, hers is fine. I have reentered my IP address manually because it went on to 'self-assigned'. The airport is working fine and it shows connected to my network, but the internet has failed. Any suggestions?
Switch back over to DHCP. Static IP is not the right answer as getting a self-assigned IP is commonly caused by an authentication problem with the wireless security.

You didn't mention what kind of router you have, but if a simple reboot of that router doesn't solve the problem, you'll probably need to connect to it using Ethernet and checking the security settings.

Liquid and computers don't mix. It might seem simple, but we see an incredible amount of people post here about spills. Keep drinks and other liquids away from your expensive electronics!
QUOTE Thanks
hawkeyeradar

 
Member Since: Dec 04, 2010
Posts: 9
hawkeyeradar is on a distinguished road

hawkeyeradar is offline
thanks for those two responses. i have tried rebooting the router (Zyxcel P660HW-D1) with no luck. I agree that it must be a DHCP/IP Issue and will try what you suggest. i will let you know the results. thanks again.
QUOTE Thanks
hawkeyeradar

 
Member Since: Dec 04, 2010
Posts: 9
hawkeyeradar is on a distinguished road

hawkeyeradar is offline
I have just been comparing my wife's working wireless settings with my own I notice that my TCP/IP setting is set to 'manually' whilst hers is 'using DHCP' when I change this setting on my laptop the IP address changes from the correct one that I put in (given to me by my server provider) to a 'self-assigned IP address'. Could this be the problem and do you know how I can resolve this?
QUOTE Thanks
cwa107

 
cwa107's Avatar
 
Member Since: Dec 20, 2006
Location: Middletown, Pennsylvania
Posts: 26,575
cwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond repute
Mac Specs: 15" MBP, Core i7/2GHz, 8GB RAM, 480GB Crucial M500 SSD

cwa107 is offline
Quote:
Originally Posted by hawkeyeradar View Post
I have just been comparing my wife's working wireless settings with my own I notice that my TCP/IP setting is set to 'manually' whilst hers is 'using DHCP' when I change this setting on my laptop the IP address changes from the correct one that I put in (given to me by my server provider) to a 'self-assigned IP address'. Could this be the problem and do you know how I can resolve this?
If it's set manually, then it's a static IP. Wireless routers allocate IP addresses dynamically using DHCP - and those IPs would be in the range of 192.168.xxx.xxx. Any IP provided by the ISP is likely a public IP and isn't intended to be used with computers connected via a router.

Setting your Airport adapter for DHCP is pretty straightforward. Go into System Preferences => Network => Choose Airport in the left window pane. Click Advanced button => Click the TCP/IP tab, and change the "Configure TCP/IP v4" field to "Using DHCP". Click OK.

If this doesn't solve the issue, it is likely related to your wireless security settings. You may want to first try removing the wireless network from the list (System Preferences => Network => Choose Airport in the left window pane. Click Advanced button => AirPort tab => find the network name in the list, click to highlight and then click "-"). Then, try to rejoin the network, it should prompt for a password. Assuming the password is entered correctly, you should connect and be ready to go. If it does not, you may need to access your router's configuration webpage by connecting via Ethernet to the router and checking wireless security settings. It should be set to use WPA or WPA2 (do NOT use WEP).

Specifics on how to access your wireless router's configuration and navigating through the menus are contained in its manual.

Liquid and computers don't mix. It might seem simple, but we see an incredible amount of people post here about spills. Keep drinks and other liquids away from your expensive electronics!
QUOTE Thanks
hawkeyeradar

 
Member Since: Dec 04, 2010
Posts: 9
hawkeyeradar is on a distinguished road

hawkeyeradar is offline
Thanks for your help. I have tried your first two suggestions with no luck. As soon as I change from manually to 'using DHCP' it goes to 'self-assigned IP'. When I '-' the network and rejoin nothing happens and I am not asked for a password. I am on WEP password so am currently looking through my router manual to see if I can change this as you suggest.
QUOTE Thanks
hawkeyeradar

 
Member Since: Dec 04, 2010
Posts: 9
hawkeyeradar is on a distinguished road

hawkeyeradar is offline
My Spanish Internet provider (Telefonica) has a 128 bit WEP password security which happens to be the same as the MAC number. Could this be a problem? I still haven't resolved my wireless connection issue and am presently trawling through the on-line manual. Will let you know what I come up with.
QUOTE Thanks
hawkeyeradar

 
Member Since: Dec 04, 2010
Posts: 9
hawkeyeradar is on a distinguished road

hawkeyeradar is offline
Hang on a minute. If my wife's macbook works ok wirelessly, then how can it be a problem with the router?
Also I have taken my laptop to other wireless locations and it isn't working there either, so it must be a problem with the Mac, mustn't it?
QUOTE Thanks
ukchucktown

 
Member Since: Oct 26, 2009
Posts: 128
ukchucktown has a spectacular aura about

ukchucktown is offline
I too have experienced connectivity issues with the Airport interface at different times. My suggestion is completely delete it from the System Preferences dialog, reboot, then add it back. The default setup should be DHCP so no further configuration should be necessary. Next join your wireless network and enter your wireless security password.
QUOTE Thanks
cwa107

 
cwa107's Avatar
 
Member Since: Dec 20, 2006
Location: Middletown, Pennsylvania
Posts: 26,575
cwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond repute
Mac Specs: 15" MBP, Core i7/2GHz, 8GB RAM, 480GB Crucial M500 SSD

cwa107 is offline
Quote:
Originally Posted by hawkeyeradar View Post
My Spanish Internet provider (Telefonica) has a 128 bit WEP password security which happens to be the same as the MAC number. Could this be a problem? I still haven't resolved my wireless connection issue and am presently trawling through the on-line manual. Will let you know what I come up with.
WEP is problematic in general. It's also useless as it can be cracked in seconds. It's badly obsolete. If it was set by your ISP, you're going to want to contact them and ask how it can be changed to WPA or WPA2.

WEP has been dead since about 2003.

Liquid and computers don't mix. It might seem simple, but we see an incredible amount of people post here about spills. Keep drinks and other liquids away from your expensive electronics!
QUOTE Thanks
cwa107

 
cwa107's Avatar
 
Member Since: Dec 20, 2006
Location: Middletown, Pennsylvania
Posts: 26,575
cwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond repute
Mac Specs: 15" MBP, Core i7/2GHz, 8GB RAM, 480GB Crucial M500 SSD

cwa107 is offline
Quote:
Originally Posted by hawkeyeradar View Post
Hang on a minute. If my wife's macbook works ok wirelessly, then how can it be a problem with the router?
Also I have taken my laptop to other wireless locations and it isn't working there either, so it must be a problem with the Mac, mustn't it?
Not necessarily. The symptoms point to two different things - either the router isn't handing out DHCP (in my experience, this is rare) or the client and the router are not able to properly negotiate and establish a secure session (very common).

When you connect to a WEP-secured wireless network, you have to enter a case-sensitive 26-character WEP key (and it can't be the same as the MAC address as that's only 12-characters, WEP requires a fixed passphrase). Depending on the client OS, it may need to have a $ placed at the beginning of the entry. If they've got it setup to use MAC filtering and your Mac's MAC address isn't in the table, when you go to connect (even if it's using the right WEP key), it will manifest itself as looking like it's connected, but actually using a self-assigned IP.

All of this can be alleviated by switching to the more modern WPA (or better, WPA2) encryption which works with a simple password (and turn off MAC-filtering as it is generally useless as a means of securing a network).

Liquid and computers don't mix. It might seem simple, but we see an incredible amount of people post here about spills. Keep drinks and other liquids away from your expensive electronics!
QUOTE Thanks
hawkeyeradar

 
Member Since: Dec 04, 2010
Posts: 9
hawkeyeradar is on a distinguished road

hawkeyeradar is offline
Thanks for your help again. I have just been in touch with my service provider again, and we have been through the set up again (manually on the TCP/IP) putting in the correct IP address and making sure the subnet mask and DNS servers are as they should be. The technician said that sometimes when there is a power cut the computer reconfigures itself which is why the DHCP no longer connects automatically and reassigns an IP address which is gobbledygook. Therefore I am back to square one. Any ideas about what I can do next?
QUOTE Thanks
ukchucktown

 
Member Since: Oct 26, 2009
Posts: 128
ukchucktown has a spectacular aura about

ukchucktown is offline
You mentioned in a previous post that your laptop is not connecting to any wireless network. That definitely points to a problem with your Mac, not the router. I doubt this is a router problem. Two questions:

1. Did you try connecting the Mac to the router with a cable and test the Internet connectivity?

2. Did you delete the Airport entry in System Preferences and recreate it?

If you did (1) and Internet was good then your network setup is probably okay and you can proceed to step (2).

If you have not tried (2) then do it and report your results. If you did (2) and the problem persists I'd start considering a potential hardware problem mainly because you are having connectivity issues everywhere, not just at home. Sometimes a self-assigned IP can come from wireless interference so you can try changing the wireless channel on your router. That might help but I doubt it. I'd also disable WEP if possible. I'd keep the security off until I connected again.
QUOTE Thanks
hawkeyeradar

 
Member Since: Dec 04, 2010
Posts: 9
hawkeyeradar is on a distinguished road

hawkeyeradar is offline
How do I disable the WEP security? The internet works perfectly with an ethernet cable. I have tried everything else you recommend. I am waiting now to contact Mac support. I'll let you know what happens. Thanks again.
QUOTE Thanks

Post Reply New Thread Subscribe


« Another newbie question >>> | Battery tips »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
Strange wireless problem pejatu Internet, Networking, and Wireless 1 06-08-2010 11:55 AM
Strange wireless internet problem Aceg Apple Desktops 2 03-25-2010 06:06 PM
Sudden problem with connecting to wireless network. calenerd Internet, Networking, and Wireless 2 12-16-2007 05:16 AM
Wireless Disconnect Problem kitjv Internet, Networking, and Wireless 0 11-24-2007 10:27 PM
Powerbook G4 wireless problem! angelggg Internet, Networking, and Wireless 2 02-13-2006 06:24 PM

All times are GMT -4. The time now is 07:45 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?