New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
Apple Notebooks Apple's notebook computers including MacBook Pro, MacBook, MacBook Air, PowerBook, and iBook.

Help!!


Post Reply New Thread Subscribe

 
Thread Tools
nathanbahl1026

 
Member Since: Jun 01, 2010
Posts: 13
nathanbahl1026 is an unknown at this point

nathanbahl1026 is offline
Hey

So...my 2010 Macbook pro crashes. Screen goes black, you can still here the computer on but cannot do anything. Forced to hard boot (hold down power button till off). Every time this happens, I believe I have chrome open. So I was wondering if any one else's macs had an crashes due to google Chrome??

If so..how to solve it. I'm trying to use Safari and really dislike it. Slow and don't really like the interface.

Please help!!
QUOTE Thanks
CrimsonRequiem

 
CrimsonRequiem's Avatar
 
Member Since: Jul 24, 2008
Posts: 6,006
CrimsonRequiem is a name known to allCrimsonRequiem is a name known to allCrimsonRequiem is a name known to allCrimsonRequiem is a name known to allCrimsonRequiem is a name known to allCrimsonRequiem is a name known to allCrimsonRequiem is a name known to all
Mac Specs: MBP 2.3 Ghz 4GB RAM 860 GB SSD, iMac 3.4 GHz Intel Core i7 32GB RAM, Fusion Drive 1TB

CrimsonRequiem is offline
There is always Firefox. However it's slower than Safari.

Chrome doesn't "crash" my MB.

死神はリンゴしか食べない。
QUOTE Thanks
MacDude121

 
MacDude121's Avatar
 
Member Since: Sep 22, 2010
Posts: 1,416
MacDude121 is a glorious beacon of lightMacDude121 is a glorious beacon of lightMacDude121 is a glorious beacon of lightMacDude121 is a glorious beacon of lightMacDude121 is a glorious beacon of lightMacDude121 is a glorious beacon of light
Mac Specs: Black MacBook 2.2GHz C2D, 4GB Ram - iMac G4 700MHz, 512MB Ram

MacDude121 is offline
Maybe try uninstalling/reinstalling Chrome?
QUOTE Thanks
schweb

 
schweb's Avatar
 
Member Since: Oct 27, 2002
Location: Cleveland, Ohio
Posts: 13,198
schweb has a reputation beyond reputeschweb has a reputation beyond reputeschweb has a reputation beyond reputeschweb has a reputation beyond reputeschweb has a reputation beyond reputeschweb has a reputation beyond reputeschweb has a reputation beyond reputeschweb has a reputation beyond reputeschweb has a reputation beyond reputeschweb has a reputation beyond reputeschweb has a reputation beyond repute
Mac Specs: MacBook Pro | LED Cinema Display | iPhone 4 | iPad 2

schweb is offline
In the future, please use more descriptive titles. "Help" doesn't really explain anything.

schweb | community leader
flickr facebook twitter tumblr google+ about.me

Mac-Forums: On Twitter | On Facebook | On Flickr

QUOTE Thanks
cwa107

 
cwa107's Avatar
 
Member Since: Dec 20, 2006
Location: Middletown, Pennsylvania
Posts: 26,599
cwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond repute
Mac Specs: 15" MBP, Core i7/2GHz, 8GB RAM, 480GB Crucial M500 SSD

cwa107 is offline
Quote:
Originally Posted by nathanbahl1026 View Post
Hey

So...my 2010 Macbook pro crashes. Screen goes black, you can still here the computer on but cannot do anything. Forced to hard boot (hold down power button till off). Every time this happens, I believe I have chrome open. So I was wondering if any one else's macs had an crashes due to google Chrome??

If so..how to solve it. I'm trying to use Safari and really dislike it. Slow and don't really like the interface.

Please help!!
Note that forced power downs generally compound the underlying issue(s) by creating filesystem corruption. If you haven't already done so, you would be well advised to run verify/repair disk and verify/repair permissions, as well as run fsck in Single User mode (method described in step 9 here).

I would be willing to bet that Chrome isn't the cause as it's very difficult for an application to crash a modern OS (including Windows), and typically if OS X crashes, it's by way of a kernel panic (which is evident by a translucent screen that overlays the existing app windows and OS). I'd be willing to bet that you've got a hardware problem and would recommend running the Apple Hardware Test. But please do continue testing with other browsers to see if the problem re-emerges.

As far as speed comparisons between Chrome/Safari/Firefox, I honestly think the argument is almost laughable. First of all, Safari and Chrome both use WebKit for rendering. They differ in their Javascript engines, and really, we're talking about microseconds of difference in rendering. In other words, the difference is indiscernible and anyone who claims otherwise is deluded by marketing. Preferences in terms of UI and add-ons are certainly valid, but performance differences are likely a function of the web server you happen to be hitting and the conditions of your ISP - those things will definitely create a discernible difference.

Comparing Firefox to Chrome/Safari is a little different since Firefox's rendering engine is slower in terms of seconds. But then again, Firefox renders a page all at once, rather than rendering parts and pieces in series. Personally, I prefer the Firefox approach and actually think it feels faster since I'm not watching the webpage "paint" itself.

Liquid and computers don't mix. It might seem simple, but we see an incredible amount of people post here about spills. Keep drinks and other liquids away from your expensive electronics!
QUOTE Thanks

Post Reply New Thread Subscribe


« Preparing to re-install Os x. | Got a Display port audio problem »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

All times are GMT -4. The time now is 01:39 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?