Results 1 to 4 of 4
  1. #1


    Member Since
    Oct 05, 2010
    Posts
    2
    External Hard Drive Problem
    Hi, first post here.

    So I recently purchased a 1TB Western Digital 'My Passport' external hard drive for use with my Macbook Pro. I plugged it in and the hard drive showed up in my Finder, no problem. I dragged some files onto the drive and they all copied over, again, no problem.

    However, after ejecting the device, I tried to re-plug it in a little while later, but this time it didn't open on my computer. I could hear the drive humming when I plugged it in, but it didn't appear in the Finder under 'Devices'.

    I also tried plugging in a little 8GB flashdrive I have, and that didn't come up either. I tried every USB port on the computer - no such luck.

    So I restarted my computer, and after that, it seemed to recognize both my new hard drive and flashdrive again. But sure enough, after ejecting the hard drive, waiting a few minutes and then plugging it back in, again it wouldn't open.

    I've recreated this problem three times now. My computer will recognize the hard drive the first time around, but then subsequently won't recognize anything I plug into it until restarting the computer. As of right now, this is a minor inconvenience (the hard drive is usable, but I'd hate to have to restart my computer every single time I want to use it), but I'm afraid this might indicate a more severe issue I might run into with it down the road.

    Any advice? Thanks!

  2. #2

    TomTomTuning's Avatar
    Member Since
    Sep 26, 2008
    Location
    Camp Hill, Pa
    Posts
    497
    Specs:
    15in MBP - 27in iMac - iPhone
    I would start with the simple "Repair Permissions" on the main drive.

  3. #3


    Member Since
    Oct 05, 2010
    Posts
    2
    Thanks for the tip - no luck, though. Problem is still occurring.

  4. #4

    TomTomTuning's Avatar
    Member Since
    Sep 26, 2008
    Location
    Camp Hill, Pa
    Posts
    497
    Specs:
    15in MBP - 27in iMac - iPhone
    What kind of system is it? (iMac, Macbook, Mac Mini etc)
    What version of OSX does it run?
    What all is connected to system?

    One of Apple's official procedures for a problem like this would be;
    Shut down the system
    Unplug everything from the computer
    Turn it back on
    Plug everything back in.

    I've been searching a round but cant really find anything.

    I would also try resetting the PRAM.
    http://support.apple.com/kb/ht1379

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. External Hard Drive problem
    By mikebleines in forum Other Hardware and Peripherals
    Replies: 8
    Last Post: 05-11-2011, 06:17 PM
  2. External Hard Drive Problem
    By PussInBoots in forum Other Hardware and Peripherals
    Replies: 1
    Last Post: 04-26-2010, 09:18 PM
  3. Problem with external hard drive
    By starkhund in forum Other Hardware and Peripherals
    Replies: 4
    Last Post: 03-05-2010, 11:42 AM
  4. Problem with External Hard Drive...
    By BAP3221 in forum Other Hardware and Peripherals
    Replies: 6
    Last Post: 06-20-2008, 04:44 PM
  5. external hard drive problem. please help!
    By roderick in forum Other Hardware and Peripherals
    Replies: 3
    Last Post: 02-16-2008, 05:17 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •