Mac Forums

Mac Forums (http://www.mac-forums.com/forums/)
-   Apple Notebooks (http://www.mac-forums.com/forums/apple-notebooks/)
-   -   MBA won't boot, fsck can't verify (http://www.mac-forums.com/forums/apple-notebooks/196318-mba-wont-boot-fsck-cant-verify.html)

PC812 03-28-2010 10:32 AM

MBA won't boot, fsck can't verify
 
My MacBook was going really slow and I performed a forced shut down because it kept freezing. When I tried to start up again, it wouldn't boot past the Apple logo and the spinning wheel.

Disk Utility won't work because it shuts down before it loads. Same for safe mode. It works in single-user mode and fsck returned the following:

disk0s2: I/O error.
Invalid node structure
(4, 0)
Invalid B-tree node size
(4, 0)
Invalid node structure
(4, 0)
Invalid B-tree node size
(4, 0)
** The volume could not be verified completely.
/dev/rdisk0s2 (hfs) EXITED WITH SIGNAL 8


Any help with this would be greatly appreciated. I'm running Snow Leopard on my machine.

6string 03-28-2010 10:57 AM

Welcome to Mac Forums
Have you tried booting in single user mode (command +s)?
I don't think that disk utility will help you much without the Macbook Air USB superdrive, as you need to boot from either a clone or install disc to repair the disk.

PC812 03-28-2010 11:37 AM

Single-user mode works fine (seems like the only thing), that's how I Used fsck.

6string 03-28-2010 11:52 AM

Sorry, I should have caught that as stated in your OP (a bit late here in Oz) :/
Well, if you can get hold of the Macbook Air USB superdrive, then I believe there is a way to mount if to recover your files in single user mode, but I don't know the procedure, and maybe someone will come along shortly with the answer to that.
Then you can repair, and if the need be, clean install.

6string 03-28-2010 11:57 AM

I'm thinking diskwarrior is going to be needed here too!

Kevriano 03-28-2010 12:13 PM

Still difficult to repair. I'm thinking clean install is the only way to go here, and hope that it keeps files if you archive and install (SL does this by default).

PC812 03-28-2010 06:46 PM

I have a Superdrive so if anyone knows how to mount with that, please tell me.

I ordered a copy of DiskWarrior and the software is being shipped. They sent me a download of it as well, but as it's a dmg file I can't do much with it on the old Windowa laptop I have for a backup computer. I tried putting the dmg on a USB stick and then using it on the MBA but no luck.

I'm not against a clean install. If that's what I have to do, then I'll do it. Problem is the computer shuts down every time I try to boot up the install disc.


All times are GMT -4. The time now is 09:07 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.