Results 1 to 2 of 2

Thread: Power Problems

  1. #1

    Member Since
    Jan 19, 2010
    Unhappy Power Problems
    For a few months, the MagSafe power adapter that came with my Mid 2008 white MacBook had only been working when I straightened the cable and made sure that it was not at an angle to my computer; later on, it intermitted from working altogether a few times, until it totally stopped working (my laptop happened to have 0% battery when it did, leaving a DVD stuck inside my slot-loading drive). I promptly ordered a new one from eBay; it arrived within a week, and worked perfectly; the battery charged again.

    However, on Saturday, even while I had my new adapter plugged in, my computer suddenly powered off; I assumed that it was a one-off fault or something similar; when I powered it back up, and logged in, the menu bar informed me that my battery had 0% charge. I continued using it, assuming that the adapter would charge the battery up. However, less than a few minutes later, the computer shut off again. I checked my power cable; the LED on the end of the adapter showed green (shouldn't it have been orange, since I had no charge?); I tried several different sockets, to no avail. I then booted my computer back up, and in the time I had before it blacked out again, I noticed that, instead of telling me the remaining time left on the battery, the top of the menu presented when clicking on the battery icon in the menu bar read

    Battery is not charging

    Power Source: Power Adapter

    and that the actual menu bar icon displayed the plug icon (plugged in) instead of the lightning bolt icon (battery charging). After some Internet research, I figured that there was something wrong with my battery (which also came with my MacBook), even though the bottom green light still flashed when I pressed the button.

    So, naturally, I shelled out 45 for a replacement battery, this time from a seller on (namely Laptop-Accessories4u); this arrived within a few days. I tried the new battery in my MacBook, but there was no difference; it still refused to charge.

    Since the battery came with 40% charge, I now have around 20% to work with, but I have no idea how to get my Mac to charge the battery again. I have tried reseting my PRAM and SMC, but nothing I have tried yet has worked.

    Does anybody have any idea what may have caused this, and how to fix it?

    [I know that I have posted this on several different forums, but I am really desperate; I haven't been able to use my Mac for two weeks. ]

  2. #2

    chscag's Avatar
    Member Since
    Jan 23, 2008
    Fort Worth, Texas
    27" iMac i5, 3.2 GHz, iPad 3, iPhone 5c, iPhone 6+, 3 iPods, El Capitan
    It could be the MagSafe adapter again or the input DC board. I suggest getting another adapter to try before taking it on in to Apple. If your MacBook is covered by Apple care, by all means make an appointment with your local genius bar and have them look at it.


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Problems with power!
    By tom4villa in forum Apple Desktops
    Replies: 1
    Last Post: 12-10-2008, 08:12 AM
  2. power problems?
    By alcasgrij in forum Apple Notebooks
    Replies: 1
    Last Post: 07-28-2008, 04:06 AM
  3. AC power problems
    By pwdobson in forum Apple Desktops
    Replies: 0
    Last Post: 03-06-2008, 12:16 AM
  4. G4 Power problems
    By pbcsurfer in forum Apple Notebooks
    Replies: 1
    Last Post: 04-12-2007, 06:16 PM
  5. power went out now im having some serious problems...
    By hogface13 in forum Internet, Networking, and Wireless
    Replies: 5
    Last Post: 09-04-2006, 05:37 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts