New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
Apple Notebooks Apple's notebook computers including MacBook Pro, MacBook, MacBook Air, PowerBook, and iBook.

USB drives won't mount


Post Reply New Thread Subscribe

 
Thread Tools
cowwart

 
Member Since: Jan 01, 2010
Posts: 29
cowwart is an unknown at this point

cowwart is offline
Ok,
So I have a 2009 macbook that I got in march. Everything works fine with it except there is one problem; any form of USB memory drive won't mount. I know all of the drives are working fine because I tested them on two other macs. Anyone have any suggestions?
QUOTE Thanks

Post Reply New Thread Subscribe


« CD tries to eject and then re-inserts itself into drive | Upgrading Memory macbook (generation....?) »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
External USB Drives in XP flowereater Running Windows (or anything else) on your Mac 1 05-26-2008 11:23 PM
sharing external usb drives over network jdevleerjr OS X - Operating System 1 11-25-2007 11:11 AM
Ext. HDD mount via USB, not FireWire...Why? green6767 Other Hardware and Peripherals 5 09-08-2007 09:46 PM
G4 Sawtooth AGP - USB problem at startup / firmware kay_mac Apple Desktops 8 04-21-2007 06:02 PM
usb hard drive won't mount after being unplugged without unmounting jimi.heffernan Other Hardware and Peripherals 4 12-01-2006 01:33 AM

All times are GMT -4. The time now is 08:41 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?