Results 1 to 4 of 4
  1. #1

    Member Since
    Dec 23, 2009
    Columbus, OH
    iBook G4
    Internal HD Input Output Error
    I have recently picked up a iBook G4 and somehow the OS was erased when I received. I have a 10.5 leopard disk I am using disk utility and trying to install.

    I tried to format the internal hard drive and kept getting an "input / output error". I replaced the hard drive and received the same error. I have a serial -> usb converter and the hard drive was recognized, and formatted. I put it back into the internal wiring harness, tried to install but the partition was not recognized and received the same error while trying to format / partition.

    I had an old sata drive laying around and bought a sata -> firewire converter for and this has worked. The install went smooth and I can boot OSX off the fw drive. Granted carrying around an external drive everywhere I go to use the comp is rather annoying.

    Other things I have tried are:
    Formatting from a 10.4 disk
    Formatting through terminal / open firmware
    Formatting through disk utility while OSX is running (same error)

    The original and the new ata hard drives I have can both be formatted and used via the usb converter but are useless when used as an internal drive. The drive will appear as "available" in disk utility but anything I try to do gets me an "input output error". So I know the drive is being seen and recognized, it can be modified while in usb but internally does not do a thing. The internal wiring harness is not faulty seeing how I can "see" the drive in disk util. Ive searched and searched looking for an answer to this and have tried everything I can think of.

    Any ideas or suggestions would be greatly appreciated as this is driving me insane for 2 weeks now.

  2. #2

    chscag's Avatar
    Member Since
    Jan 23, 2008
    Fort Worth, Texas
    27" iMac i5, 3.2 GHz, iPad 3, iPhone 5c, iPhone 6+, 3 iPods, El Capitan
    Have you tried to reset the PRAM - NVRAM? See the following Apple KB article: LINK

    If that doesn't work....

    The internal wiring harness is not faulty seeing how I can "see" the drive in disk util.
    Not necessarily. It could be that the internal connector the drive attaches to when placed in the machine is at fault. (dirt, connector bent) The symptoms you describe certainly point to some type of hardware error. I know you stated that Disk Utility can "see" the drive but it may not be "seeing" all of it.

    The hardware bus is Ultra ATA-100, and you stated you are using an ATA type drive so that would eliminate any incompatibility of drives. Besides, a SATA drive will not fit to the ATA connectors.

    I can't think of anything else that could be causing the errors.


  3. #3

    harryb2448's Avatar
    Member Since
    Nov 28, 2007
    Nambucca Heads Australia
    iMac i5 2.7GHz, 16GB memory, OS 10.11.1.
    Does the G4 meet Leopard specs of minimum 867MHz processor, and is the disc from another machine or a full retail install DVD?

  4. #4

    Member Since
    Dec 23, 2009
    Columbus, OH
    iBook G4
    No, resetting the pram does not work.

    Ive examined the connector that goes from the mobo to the hd and it appears to be fine, but we all know looks can be deceiving

    1.33 ghz processor
    768mb Ram

    Hard drives I am using:
    160 Gig hd

    60 Gig HD

    The disc is a burnt copy but the dude claimed it was the same disc he used to install it prior to selling to me. I do believe the guy that it was working before (talked to on the phone)

    Another thing I forgot to mention is when first starting to dive into mac's I was unaware that installing OSX to a usb controlled drive is not possible (cannot boot from). After the usb install I would reattach to the internal hd connector and the drive would read approximately 20 gb difference than the total space of the hard drive. Its like the files are on there but its not being seen. Ill try to explain in more sense.

    60gb hd running through usb. Install OSX while converted through the usb port. Receive the error "OSX will be unbootable through this volume"
    Attach internally, load up disk utility and the drive reads "39.xx gb of available space" although it should be 60gb.
    While booting from the firewire drive and plugging the 60gb hd in from usb, I am able to format the drive and get the 20gb back and have 59.x total.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. input output error
    By John D. Lee in forum Apple Desktops
    Replies: 6
    Last Post: 10-09-2012, 07:08 PM
  2. Input/output Error
    By fear7950 in forum Movies and Video
    Replies: 0
    Last Post: 07-09-2012, 04:59 PM
  3. Partition failed with the error: Input/Output error
    By humboldt24 in forum OS X - Operating System
    Replies: 1
    Last Post: 05-31-2011, 01:35 AM
  4. Internal HD formatting issue - input/output error on 10.4.11
    By piehouse4 in forum Apple Notebooks
    Replies: 2
    Last Post: 12-03-2009, 02:11 AM
  5. what does input/output error mean
    By spring in forum Other Hardware and Peripherals
    Replies: 1
    Last Post: 05-07-2009, 11:53 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts