Hi all.

I am having an unusal problem with respect to moving files from one external to another through my Macbook (Alum)

I have a seagate 1 tb hard drive with 2 partitions:

1st partition - 300 gb in size - for Time machine back ups - Formatted in mac os x extended (journaled)

2nd partition - 700 gb in size - for all documents - FAT 32 because it is used in windows and macs equally.

It has been working perfectly well, i have even moved 200- 300 gb size folders at a time to my FAT32 partition (no single file was larger than 4gb).

However, I have bought a new Seagate 1.5tb hard drive, which i have partitioned the same way as the previous one.

The problem is, I am unable to transfer files from the FAT32 partition on my old seagate to the FAT32 partition on the new seagate. The error message that i get is - This folder already exists in this drive (which it doesn't). And I don't know how file size could be an issue because all the files on the old FAT32 were moved in to it from my MAC through folders which were all in excess of 4 gb (again, folders were large, but no single file was larger than 4gb).

I have reformatted the new seagate drive a few times but to no luck. I have tried to move files manually, one by one, it works for some files but it doesnt for some files. I am not able to manually move some files which are only 50 mb in size - i get the same error message that the file already exists. But i was able to move a file that was 1.4gb in size. And i obviously can't manually move 700 gb of files!!!

Does this have anything to do with my Macbook?
please help!
Thank you!