Mac Forums

Mac Forums (http://www.mac-forums.com/forums/)
-   Apple Notebooks (http://www.mac-forums.com/forums/apple-notebooks/)
-   -   Macbook 13" hard drive upgrade problem (http://www.mac-forums.com/forums/apple-notebooks/159824-macbook-13-hard-drive-upgrade-problem.html)

anandmahey 07-22-2009 11:18 PM

Macbook 13" hard drive upgrade problem
 
Hi everyone, this is my first post here. I have been having a crazy time upgrading my macbook 13" (white) both the hard drive and the ram.

so far i have been able to upgrade the ram, but not before going through all kinds of problem. in the end i bought a Nanya 2 gig stick for $75 and it finally worked, that too with a Kingston stick. so now i have kingston 2gig and nanya gig rams running. but upgrading my hard drive is still a problem.

my macbook is: Intel core 2 duo 2.1 ghz
120GB Fujitsu 1.5 G/bits, 4700 rpm (want to upgrade to 320gb, Hitachi 3.0
G/bit, 5400 rpm)
RAM from 1gig to 4 gigs now.
Model identifier 4.1
Operating system: OSX 10.4 (or 10.5, cant remember at the moment.
typing this post at work)

So here's whats been happening:

All the help sites i've checked out, say its relatively easy to upgrade a macbook's ram and hard drive. not the case. taking them out and putting them in is easy.

Where the new hard drive is concerned, i've tried using SuperDuper and Carbon Copy Cloner to clone the old drive onto the new, made sure it was bootable. I've also made sure the new drive was formatted as MacOSX extended (journaled), verified the disk with disk utility and all that. After cloning the old drive and inserting the new drive into my macbook, all i get is white screen, and after some time, i get the folder with question mark icon.

then i read somewhere that you should try and see if the new hard drive is actually bootable after its cloned (which it should be). so i connected the new drive to a USB 2.0 enclosure, held down the Option key, and started the mac. True enough, both my old (which i inserted back into my macbook) and new drives showed up. So i inserted the new drive back into the macbook and left it running overnight. the next morning, the same folder with question mark icon.

I've also tried booting from the OSX CDs provided to me with the mac, used disk utility and formatted the new drive and tried re-installing OSX. It would install the first disk, and then prompt me to insert the second disk when the computer restarts....but it never asks for the second disk. just gives me a white screen.....

Tonight i'm gonna try using Time Machine to clone my old drive again, and if that doesn't work, I'm gonna try Time Machine.

Can anyone put me out of my misery? my old drive only has 48gb left!

acosta.matt 07-23-2009 10:29 AM

Here is something to try:

Boot up to the old HDD from the external source. When you get into that system go to system preferences - start up disc (there you can chose the one that is installed in the pc, not the external)

any questions feel free to contact me.

anandmahey 07-24-2009 01:33 AM

Hi there acosta.matt,

I've tried that, and get the same result. the computer gets stuck at the white screen, and doesn't go anywhere.

Then I tried something else....inserted the new drive back to the external source (USB enclosure)...and guess what, the **** thing booted up! the same drive internally gets stuck at the white screen.

I just bought another 320GB samsung hard drive, 5400 RPM. hopefully this one works. Any ideas? Anyone?

anandmahey 07-25-2009 01:26 AM

well it finally worked!!! wow!! 230 gigs!! yeeehaaa!!!

mikealfi 10-15-2009 03:17 AM

i am having the same problem.. but My hd won't even show up in the disk utility.. i have the same computer, so how can i get the hd to show up so i can format it.... or how can i format it another way

i have an external hard drive.. macbook pro and pc...

my old macbook hard drive failed already but it is backed up on the external? please help


All times are GMT -4. The time now is 11:45 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.