Results 1 to 2 of 2
  1. #1

    Member Since
    Apr 01, 2009
    Unhappy MBP DVI now no signal detected
    2007 MBP 17" previously worked fine with BenQ 24" external monitor. Now will detect monitor but no signal detected from DVI-D input. OK VGA from my MBP and a PC. Works fine with my wife's MBA detects DVI-D no problem. Have new monitor from BenQ as thought to be fault on input port clearly not the case as other MacBook works! Have cleared RAM repaired disk permissions all to no avail. Multiple restarts and detect displays - display is selected but display detects no signal. Have now tried DVI out to HDMI - same result detects display but not the signal so nothing displays.

  2. #2

    Member Since
    Oct 21, 2009
    Have exactly the same problem with my MBP 15". Did you find a solution?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. DVI to HDMI loses signal
    By gj1881 in forum Apple Notebooks
    Replies: 1
    Last Post: 05-30-2012, 01:46 PM
  2. DVI to HDMI No Signal
    By KG_for_the_win in forum Apple Notebooks
    Replies: 1
    Last Post: 01-26-2011, 09:32 PM
  3. DVI to HDMI signal all black
    By djroue in forum Apple Notebooks
    Replies: 1
    Last Post: 06-23-2010, 05:27 PM
  4. Replies: 5
    Last Post: 04-28-2009, 03:33 PM
  5. MBP DVI now no signal detected
    By keechj in forum Apple Desktops
    Replies: 0
    Last Post: 04-01-2009, 04:26 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts