Mac Forums

Mac Forums (http://www.mac-forums.com/forums/)
-   Apple Notebooks (http://www.mac-forums.com/forums/apple-notebooks/)
-   -   I'm having a weird HDD error with MBP... (http://www.mac-forums.com/forums/apple-notebooks/136133-im-having-weird-hdd-error-mbp.html)

PinkLink 01-06-2009 11:44 PM

I'm having a weird HDD error with MBP...
 
So it goes like this: For a while I had XP installed on a 32 gb partition I created with Boot Camp Assistant that I used for playing TF2 and whatnot when I'm not by my gaming machine. The other day, I deleted said partition (also using Boot Camp Assistant) so that I could create a fresh partition and install the Windows 7 beta, which I am in.

Boot Camp Assistant said that it cannot partition my hard drive... :/

So I opened Disk Utility and told it to verify the disk. Everything was going fine until it was about 90% of the way done, and then it started flinging errors everywhere. It even automatically tried repairing the errors, but immediately stopped because the errors weren't reparable.

This is confusing to me because the hard drive is working fine. I'm typing this message from my Macbook Pro no problem and I tried copying a ton of files from my external HDD to this one to see if there was a bad segment on the platter, but I was able to pretty much completely fill the hard drive with usable and accessible data.

Any ideas on what I should do?

chscag 01-07-2009 01:12 AM

Sounds like you may have some fragmentation or even file errors in the area where the partition is to be created. I would try running iDefrag and see if that will clear the area of any file fragments and give you contiguous space.

BTW, you realize that Windows 7 has not been officially released for public beta and that you'll be installing an illegal copy. (Unless you're an official MS beta tester)

Regards.

PinkLink 01-07-2009 04:53 AM

Would Onyx work? Doesn't that have a defragmenting feature? That other software appears to be a trial version and I'm somewhat distrustful of the functionality of free trial software.

EDIT: I managed to repair the volume by booting into my OSX disc after Onyx told me to do that. Now, when I run Boot Camp Assistant, it starts actually partitioning, but then fails part way through saying some files cannot be moved. If I can successfully defrag the volume, should that get rid of the problem?


All times are GMT -4. The time now is 04:16 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.