Results 1 to 6 of 6
  1. #1
    Unhappy Charging the PowerBook
    For some reason my powerbook G4 isn't recognizing that it's plugged in. So basically I can't charge the battery, or let it run for ever
    I know the power adapter is good as I tried it on one of my friend's powerbook, but for some reason it's not recognized/not doing anything when plugged in mine.
    I'm guessing the logic board is gona have to be replaced, since something happend and probably damaged the power function.
    Any advice? Is there a cap/resistor that burns easily and could be replaced? Basically I'm trying to avoid the cost of a logic board.. but hey.. if it has to be. it will be done.

    ps: on a side not, anyone has a detailed pdf/link on how to take apart the powerbook g4s? So I don't destroy anything in the process

  2. #2

  3. #3
    I am having the exact same problem - my PB is no longer charging when connected to mains power. This has happened a couple of times before, but those times it came back online and start charging after being left plugged in for a couple of days without use. This time it has been several days, and no dice. It was down to about 40% charge when I last shut it down.

    My PB is a 12" Al book, 867MHz, one of the early versions. Don't know if it's still under warranty, as it was purchased almost 2 years ago by my father-in-law, and i can't remember if he bought the apple care deal.

    The PBFixIt Guide looks useful, but scary. Tecknix - have you had any success fixing yours? I really don't want to break mine open, and I was hoping that the problem was with the adapter itself (a steep $79 to replace), but this does not seem to be the case from this posting. I don't have access to another PB to verify if it's the adapter or not.


  4. #4
    I had the same problem with my G3 Powerbook. It turned out to be the connector wasn't properly mounted to the logic board which was caused from 2 years of using it on my lap hitting the adapter with my knee by mistake now and then.

    I recently purchased a new G4 Powerbook, now I use it on a table always unless unplugged.

  5. #5
    before you open it up...give this a try.

  6. #6
    Thanks for the link, meanopause. Tried the instructions for the 12" powerbook G4 (shift-ctrl-option-power), but still no response. My computer was actually in sleep mode when I first tried it, because I had started it up earlier this morning to see if I needed to get some files off it, but it didn't have enough battery left, and went almost immediately into sleep mode.

    When i tried the above keystroke combo, it went out of sleep mode, but the AC adapter connector is still not lighting up, and hitting the power button does nothing. I take this to mean the battery is now completely discharged. Hmm.

    Laptop power connectors and me do not seem to get along.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Powerbook G4 Charging?
    By yamaha in forum Apple Notebooks
    Replies: 8
    Last Post: 01-12-2012, 08:30 PM
  2. powerbook G4 not charging
    By mr.jaggiss in forum Apple Notebooks
    Replies: 2
    Last Post: 02-15-2011, 05:13 PM
  3. Non-charging PowerBook G4 problem
    By BarbMac in forum Apple Notebooks
    Replies: 2
    Last Post: 02-02-2011, 10:13 AM
  4. Powerbook stopped charging
    By ttu97 in forum Apple Notebooks
    Replies: 0
    Last Post: 11-10-2009, 10:26 PM
  5. PowerBook charging issues?
    By oo5yolo10 in forum Apple Notebooks
    Replies: 0
    Last Post: 06-27-2008, 12:53 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts