Results 1 to 8 of 8
  1. #1

    Member Since
    Jun 16, 2008
    Any way to override/disable the internal keyboard?
    My toddler spilled (dumped?) juice on my MacBook Pro computer bag and some got inside the computer. I let it dry out overnight and was able to start it (and back up my stuff). This was a month or two ago, so my problem isn't horrible, but it is getting worse lately.

    The problem now is that certain keys are intermittently not working (c, v, n, mostly bottom row). I can work around this with an external keyboard. However, the problem I can't seem to solve is the z key, which seems to randomly start repeating without being pressed. I can go hours/days without a problem, but then have times when I can't type/do anything, because z keeps appearing (or bezing recognized (that z in "bezing" is an example!).

    My question is this--Is there any way to have the USB keyboard override the internal keyboard when I plug it in (or to disable the *^%&@%$#ing z key)? I plan getting the computer serviced by my employer (who will most likely send to Apple), but that won't be for another couple weeks, when I go on vacation.

    I reviewed other "spill" threads, but didn't see this particular question addressed. Any ideas would be appreciated!!! Thanks!

  2. #2

    Member Since
    Apr 29, 2008
    Brisbane, Australia
    MacBook Pro 15" 2.5 GHz 2 GB RAM 250 GB HDD NViDA GeForce 8600 GMT
    Well it might be possible to disable keyboard if you close the lid of your computer & use external monitor as your monitor..But I am not very sure about this one....Just making a guess...But it might be possible with command line...But as I'm a newbie with macs...Don't know much about it..!!
    Otherwise a simple but not complete solution could be that you can go to Your Keyboard pref.s & turn off the key repeatation. So that 'z' won't keep on typing....
    iPod 5.5 Gen Video 30 GB | iPod Classic 80 GB |Airport Express |
    MacBook Pro Penryn 2.5 GHz | 2 GB RAM | NVida GeFroce 8600 GMT|

  3. #3

    Member Since
    May 27, 2008
    MBP 2.5ghz, 4gb/r, 200g7.2krpm
    You can get new keyboards for cheap, and they are easy to replace yourself.
    -Zach, A.C.T.

  4. #4

    Member Since
    Sep 09, 2010
    Key repeat problem : how to disable the internal keyboard ?

    i've exactly the same issue as bluj for the same reason.
    i use an external keyboard and want to disable the internal one in order to stop it repeating eeeeeeee, gggggggg and .

    does anyoneeee know how to do it ?e

    i've already disabled the key repeating preference but it still continue pressing some keys.
    i think it's both hardware and software issue

    any idea would help

    thank you !

  5. #5

    Tarek's Avatar
    Member Since
    Sep 18, 2008
    13" 2015 MacBook Pro Retina / 15" 2010 MacBook Pro
    Nah, I believe there is no way to disable your internal keyboard.

  6. #6

    brairden's Avatar
    Member Since
    Jul 24, 2010
    Dayton, Ohio
    2 iMacs, 1 MBP, 1 UMB, 1 mini
    Download and install "keyboard cleaner"

    It blocks input from your keyboard. What I don't know is if it would also block your external keyboard. My suggestion would be to run this program without the external connected. Once the program is blocking the input from the internal, then connect the external. I don't think this program has any sort of live updating written into the software. It shouldn't recognize that there is a another keyboard connected.

    Not a 100% sure this will work, but it is definitely worth a try.

    Keyboard Cleaner for Mac - Free software downloads and software reviews - CNET
    15" 2.53ghz i5 MacBook Pro (2010) 8gb, 500gb HD - 60gb OWC SSD
    13" 2.4ghz MacBook Unibody (late 2008) 4gb, 250gb
    24" 2.4ghz Aluminum iMac (mid 2007) 3gb, 1tb
    mini 2.0ghz - 32gb iPhone 4

  7. #7

    Member Since
    Oct 02, 2010
    Having the same problem
    Funnily enough I'm having the same problem, except I don't have a toddler to blame for the accident. It's the same keys that are jammed on: g and e but not the symbol you mentioned.
    I called the Applecare line and they suggested resetting the power supply (something like that anyway), which is done by:
    removing the battery, holding down the power switch for five seconds. Then you replace the battery and immediately after switching it on hold down Apple key, alt, P and R. I'm pretty sure that was the combo, but check on google for it.
    It seems likely that the damage is done and I expect this won't help although maybe in some circumstances it might.
    The one useful thing I have to say is press down num lock on the broken keyboard, if that's still working of course. That will enable you to type with the external.


  8. #8

    Member Since
    Apr 26, 2011
    Smile Toggling the Keyboard On/Off
    By pressing the "control" key and the "F1" key, you can toggle on or off the keyboard. This may or may not solve your problem, but its worth a try!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. How to disable internal webcam...
    By dj russell p in forum Music, Audio, and Podcasting
    Replies: 5
    Last Post: 09-15-2011, 12:15 PM
  2. Can I disable internal keyboard/trackpad on MBP?
    By markwco in forum Apple Notebooks
    Replies: 0
    Last Post: 02-12-2008, 10:52 PM
  3. Keyboard backlight Override
    By smachimo in forum Apple Notebooks
    Replies: 0
    Last Post: 07-31-2007, 06:31 PM
  4. How can I override the backlight for the Keyboard?
    By quattro4life in forum Apple Notebooks
    Replies: 3
    Last Post: 03-29-2007, 01:16 AM
  5. Disable Internal Hard Disk
    By timswim78 in forum macOS - Operating System
    Replies: 2
    Last Post: 03-25-2006, 08:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts