Mac Forums

Mac Forums (http://www.mac-forums.com/forums/)
-   Apple Notebooks (http://www.mac-forums.com/forums/apple-notebooks/)
-   -   Any way to override/disable the internal keyboard? (http://www.mac-forums.com/forums/apple-notebooks/112387-any-way-override-disable-internal-keyboard.html)

bluj 06-16-2008 08:36 PM

Any way to override/disable the internal keyboard?
 
My toddler spilled (dumped?) juice on my MacBook Pro computer bag and some got inside the computer. I let it dry out overnight and was able to start it (and back up my stuff). This was a month or two ago, so my problem isn't horrible, but it is getting worse lately.

The problem now is that certain keys are intermittently not working (c, v, n, mostly bottom row). I can work around this with an external keyboard. However, the problem I can't seem to solve is the z key, which seems to randomly start repeating without being pressed. I can go hours/days without a problem, but then have times when I can't type/do anything, because z keeps appearing (or bezing recognized (that z in "bezing" is an example!).

My question is this--Is there any way to have the USB keyboard override the internal keyboard when I plug it in (or to disable the *^%&@%$#ing z key)? I plan getting the computer serviced by my employer (who will most likely send to Apple), but that won't be for another couple weeks, when I go on vacation.

I reviewed other "spill" threads, but didn't see this particular question addressed. Any ideas would be appreciated!!! Thanks!

umang7888 06-16-2008 09:10 PM

Well it might be possible to disable keyboard if you close the lid of your computer & use external monitor as your monitor..But I am not very sure about this one....Just making a guess...But it might be possible with command line...But as I'm a newbie with macs...Don't know much about it..!!
Otherwise a simple but not complete solution could be that you can go to Your Keyboard pref.s & turn off the key repeatation. So that 'z' won't keep on typing....

rich6490 06-16-2008 10:33 PM

You can get new keyboards for cheap, and they are easy to replace yourself.

fllecopr 09-09-2010 06:37 AM

Key repeat problem : how to disable the internal keyboard ?
 
hi

i've exactly the same issue as bluj for the same reason.
i use an external keyboard and want to disable the internal one in order to stop it repeating eeeeeeee, gggggggg and .

does anyoneeee know how to do it ?e

i've already disabled the key repeating preference but it still continue pressing some keys.
i think it's both hardware and software issue

any idea would help

thank you !

Tarek 09-09-2010 09:00 AM

Nah, I believe there is no way to disable your internal keyboard.

brairden 09-09-2010 10:50 AM

Download and install "keyboard cleaner"

It blocks input from your keyboard. What I don't know is if it would also block your external keyboard. My suggestion would be to run this program without the external connected. Once the program is blocking the input from the internal, then connect the external. I don't think this program has any sort of live updating written into the software. It shouldn't recognize that there is a another keyboard connected.

Not a 100% sure this will work, but it is definitely worth a try.


Keyboard Cleaner for Mac - Free software downloads and software reviews - CNET Download.com

D_Swallow 10-02-2010 04:59 PM

Having the same problem
 
Funnily enough I'm having the same problem, except I don't have a toddler to blame for the accident. It's the same keys that are jammed on: g and e but not the symbol you mentioned.
I called the Applecare line and they suggested resetting the power supply (something like that anyway), which is done by:
removing the battery, holding down the power switch for five seconds. Then you replace the battery and immediately after switching it on hold down Apple key, alt, P and R. I'm pretty sure that was the combo, but check on google for it.
It seems likely that the damage is done and I expect this won't help although maybe in some circumstances it might.
The one useful thing I have to say is press down num lock on the broken keyboard, if that's still working of course. That will enable you to type with the external.

Dave

hannah1997 04-26-2011 10:37 AM

Toggling the Keyboard On/Off
 
By pressing the "control" key and the "F1" key, you can toggle on or off the keyboard. This may or may not solve your problem, but its worth a try!


All times are GMT -4. The time now is 06:29 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.