Mac Forums

Mac Forums (http://www.mac-forums.com/forums/)
-   Apple Notebooks (http://www.mac-forums.com/forums/apple-notebooks/)
-   -   Problem with MBP screen coming out of sleep mode (http://www.mac-forums.com/forums/apple-notebooks/100032-problem-mbp-screen-coming-out-sleep-mode.html)

markwco 03-08-2008 11:42 PM

Problem with MBP screen coming out of sleep mode
 
My fiancee just had an odd problem start with her MBP a couple days ago. When she closes the screen to transport her laptop and then reopens the screen it doesn't come out of sleep mode properly. I thought at first it was simply staying in sleep mode but you can hear the sounds when you press any keys so I think the computer itself is out of sleep mode but the screen stays dark. The only way we can fix it is to hold down the power button a few seconds to turn the computer off and restart it. I thought it was a one time thing but it has happened every 5 or so times she's closed her laptop the last couple times. Any idea what's causing this? She hasn't made any changes with software or hardware lately and is using the latest Leopard 10.5.2 and all patches.

bobtomay 03-09-2008 08:54 AM

Try using the screen brightness key next time it occurs and let us know.

dmoon74 03-15-2008 02:29 PM

i've just started having the exact same problem. I can hear the mbp coming out of sleep mode but the screen is dark as if it's not on at all. using the screen brightness does not solve the problem. I also have leopard and latest updates.

Waterpolo820 03-15-2008 03:45 PM

do you guys have any form of iStat on there?

rohan 03-15-2008 04:43 PM

which version of MBP is this? ...may help narrow down the troubleshooting process...

Waterpolo820 03-15-2008 05:52 PM

Ok this just happened to me right now, but it has happened before. i called apple support ( the first time it happened around 4 weeks ago) and made a case file so I can call and exchange it with a brand new one since the computer is still brand new. (purchased in early part of February)

But i think that it is being caused by iStat, because when I uninstalled it it stopped, but i recently re-installed it and it is acting up again.

dmoon74 03-15-2008 09:26 PM

my mbp is 2.2 C2D. I am also NOT running istat. However I am wondering if smcFan Control is causing this problem. Was on the mac last night doing some light web browsing and noticed how hot the mac was. The fans weren't kicking in and the temperature was around 77 celcius. So today whenever I open the mac from sleep mode, I would get the black screen. I've searched around and this seems to be a problem for several of us. I wonder if one of the mac updates is causing this issue....

Waterpolo820 03-15-2008 10:18 PM

Well Im running smcFanControl too but I'm not having any trouble with it, just turned up my fans to 3500 rpm and now running at 38 C, and it is working.

frankie.horak 03-17-2008 01:27 PM

I got the exactly same thing... but it does not happen often but it is still pretty annoying.. I got MBP 2.2Ghz with leopard and I am running iStat... Then I got one a bit to the topic question: I usually switch of my laptop before I move anywhere. I just shut it only when I go between classes or room to room and my friend with MacBook was really shocked when she saw it and she says she just shuts it every time... is this safe for the hardware if it is wobbling around in a second skin in my backpack?

thanks

Noxian 03-17-2008 02:11 PM

Quote:

Originally Posted by Waterpolo820 (Post 614675)
do you guys have any form of iStat on there?

Yes I do, and I am also having this problem. I guess your next suggestion is going to be to disable istat.

SJTV1 03-17-2008 03:52 PM

iStat had a problem but new version has it fixed, so just update it.
I had the same probs and they stopped after update.

http://forums.mactalk.com.au/46/3961...m-leopard.html
Solution is on page 2.

Noxian 03-17-2008 04:18 PM

Quote:

Originally Posted by SJTV1 (Post 615815)
iStat had a problem but new version has it fixed, so just update it.
I had the same probs and they stopped after update.

http://forums.mactalk.com.au/46/3961...m-leopard.html
Solution is on page 2.

Thanks, I had the latest version of iStat in, but I also had iStat Menu installed, I will disable them both and see where I end up, then if the problem does not reoccur I will reinstall istat then iStat Menu

Hostile 11-08-2008 06:44 AM

I have a 2.16GHz 15" MBP and it just started doing this last night. As far as I know I do not have iStat installed, I've never heard of it.

It also has a problem that, when the ac adapter is not connected the laptop randomly shuts down after a few minutes. This has been going on for a few months now.

macfan76 11-08-2008 04:21 PM

I had this happen, too, and iStat was definitely the problem. Disabled it, and the problem was fixed.


All times are GMT -4. The time now is 03:10 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.