Results 1 to 10 of 10
  1. #1

    jokerman's Avatar
    Member Since
    Dec 11, 2007
    Location
    Bethlehem, Georgia
    Posts
    42
    Specs:
    MacBook Pro 2.16 C2D 10.4.10
    G4 MDD starts up and chimes but there's no picture on the monitor
    Any ideas on whether or not this might be an easy problem to fix. I can buy a 1.25/256/combo drive for $59 and was wondering if I should bother. Any info would be great. Thanks.

  2. #2

    louishen's Avatar
    Member Since
    Oct 22, 2007
    Location
    London
    Posts
    8,968
    Specs:
    Mac Mini Core i7 2012 | White 2009 MacBook 2 Ghz | 733 Mhz G4 Quicksilver
    for $59 you cannot go wrong

    Problems could be:
    No operating system
    No hard disk or connector has come out
    No RAM installed
    Video Card defective
    Lithium Battery has gone dead

  3. #3

    jokerman's Avatar
    Member Since
    Dec 11, 2007
    Location
    Bethlehem, Georgia
    Posts
    42
    Specs:
    MacBook Pro 2.16 C2D 10.4.10
    great, I think i will give it a go

  4. #4

    jokerman's Avatar
    Member Since
    Dec 11, 2007
    Location
    Bethlehem, Georgia
    Posts
    42
    Specs:
    MacBook Pro 2.16 C2D 10.4.10
    Video card expensive?
    Here is what the seller said regarding the video board:

    "I know it's not the video board as I swapped it with the one in the G4 that I left and both boards worked great in that one but neither board works in this one."

  5. #5

    louishen's Avatar
    Member Since
    Oct 22, 2007
    Location
    London
    Posts
    8,968
    Specs:
    Mac Mini Core i7 2012 | White 2009 MacBook 2 Ghz | 733 Mhz G4 Quicksilver
    probably not the video card then

    If he has done anything with the Ram - then that's the most likely culprit

  6. #6

    jokerman's Avatar
    Member Since
    Dec 11, 2007
    Location
    Bethlehem, Georgia
    Posts
    42
    Specs:
    MacBook Pro 2.16 C2D 10.4.10
    I think I have some ram. Hopefully that is all it is. I will keep you posted. Thanks for all the help.

  7. #7

    harryb2448's Avatar
    Member Since
    Nov 28, 2007
    Location
    Nambucca Heads Australia
    Posts
    21,871
    Specs:
    Imac 27" Retina 3.3GHz, 512GB Flash, 16GB memory, OS X.11.4.
    Double check that graphics card. It should be an ATI Radeon 9000 with 64MB SDRAM which was standard in the MDD. Some flashed cards, such as the nVida GeForce 6200 with 256MB SDRAM will work with earlier G4 but NOT with MDD.

    Next do a Google for MDD startup problems. Often this model require a replacement internal battery if they have been standing, or a boot with internal battery not installed.

    Make sure any RAM is fully compliant with the machine specs. A lot of memory sold on auction sites is PC only.

    Good luck and keep us advised.

  8. #8

    jokerman's Avatar
    Member Since
    Dec 11, 2007
    Location
    Bethlehem, Georgia
    Posts
    42
    Specs:
    MacBook Pro 2.16 C2D 10.4.10
    couldn't find any particular articles regarding my problem. I will keep you posted.

  9. #9

    harryb2448's Avatar
    Member Since
    Nov 28, 2007
    Location
    Nambucca Heads Australia
    Posts
    21,871
    Specs:
    Imac 27" Retina 3.3GHz, 512GB Flash, 16GB memory, OS X.11.4.
    Remove all RAM, insert one stick and try reboot.

    Have a look at this link:-

    http://forums.dealmac.com/read.php?4,2665037,2667894

  10. #10

    jokerman's Avatar
    Member Since
    Dec 11, 2007
    Location
    Bethlehem, Georgia
    Posts
    42
    Specs:
    MacBook Pro 2.16 C2D 10.4.10
    I am picking it up this afternoon, I will let you know what happens after I try your suggestions.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Dual 1.25 MDD to old 15" CRT monitor - what video adapter?
    By steveball in forum Apple Desktops
    Replies: 6
    Last Post: 12-04-2011, 12:02 PM
  2. Secondary display picture doesn't fit on monitor
    By cudn in forum OS X - Operating System
    Replies: 3
    Last Post: 04-05-2011, 03:10 PM
  3. No picture when hooking Macbook to HDTV/Monitor
    By JimInGA in forum Apple Notebooks
    Replies: 8
    Last Post: 08-10-2009, 09:11 PM
  4. G5 Starts Up Fine But Doesn't Start Monitor Consistently!
    By snazz123 in forum Apple Desktops
    Replies: 11
    Last Post: 03-23-2008, 12:42 PM
  5. help. osx starts monitor out of range. cant do anything!
    By jdevleerjr in forum OS X - Operating System
    Replies: 3
    Last Post: 09-06-2007, 06:24 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •